Commit d6d47592 authored by Gábor Udvari's avatar Gábor Udvari

Add a version condition for the mcrypt package

In PHP 7.2 the MCrypt extension was moved out from core to PECL.
A condition was added to only include the mcrypt package if the PHP
version is lower than 7.2.
parent 375dab87
......@@ -83,7 +83,7 @@ php__server_api_packages: [ 'cli', 'fpm' ]
# .. envvar:: php__base_packages [[[
#
# Install set of standard PHP packages.
php__base_packages: [ '{{ "php" + php__version }}', 'curl', 'gd', 'mcrypt' ]
php__base_packages: [ '{{ "php" + php__version }}', 'curl', 'gd', '{{ "mcrypt" if php__version | version_compare("7.2","<") else None }}' ]
# ]]]
# .. envvar:: php__packages [[[
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment