Commit 06a1ff63 authored by Reto Gantenbein's avatar Reto Gantenbein

Various minor documentation fixes and updates

parent f86bb2e3
......@@ -110,7 +110,7 @@ Fixed
~~~~~
- Fix documentation build error due to deleted link definition to deprecated
`debops.php5` role repository. [ganto_]
``debops.php5`` role repository. [ganto_]
- Probe if :envvar:`roundcube__domain` is a string and construct :envvar:`roundcube__git_checkout` accordingly. [cultcom]
......
......@@ -18,7 +18,7 @@ default values, your setup is likely to break if you simply execute the
updated role. To avoid this, take care of the following issues:
- If you are using a custom playbook, make sure to review the changes in
:ref:`roundcube__ref_example_playbook`.
the :ref:`roundcube__ref_example_playbook`.
- The following variables were replaced and therefore are not defined
anymore in the default variables:
......@@ -84,8 +84,7 @@ defined in the example playbook.
6. In case Roundcube was installed into a new directory but you didn't use the
default :envvar:`roundcube__www` configuration before the update or you
experience SQL schema issues, you need to manually run the upstream post
update script on the Roundcube server. The given ``--version`` parameter
indicates the previous Roundcube version you were updating from.
update script on the Roundcube server.
.. code:: shell
......@@ -93,5 +92,5 @@ defined in the example playbook.
-c "php /srv/www/sites/roundcube.example.com/public/bin/updatedb.sh \
--package=roundcube --dir=/srv/www/sites/roundcube.example.com/public/SQL"
7. If you manually installed some additional plugins you might need to re-
install or update them for the new Roundcube version.
7. If you manually installed some additional plugins you might need to reinstall
or update them for the new Roundcube version.
......@@ -59,7 +59,7 @@ roundcube__base_php_packages:
#
# PHP packages which are installed via APT repository if they are available
# in a sufficiently new version in the current distribution. The required
# minimal versions are taken from the composer.json.dist of the Roundcube
# minimal versions are taken from the file:`composer.json.dist` of the Roundcube
# 1.3.0 release. If you install an older version of Roundcube you may want
# to adjust this list.
roundcube__apt_php_packages: '{{ [ "mail-mime", "net-smtp", "pear" ]
......@@ -103,10 +103,10 @@ roundcube__composer_phar: '{{ True
# ]]]
# .. envvar:: roundcube__composer_phar_url [[[
#
# URL to the composer.phar script which will be used to install PHP packages
# not available in the APT repository on distribution releases which don't
# package PHP composer. If this is set to `False`, :command:`composer` will
# be installed via APT package manager.
# URL to the file:`composer.phar` script which will be used to install PHP
# packages not available in the APT repository on distribution releases which
# don't package PHP composer. If this is set to ``False``, :command:`composer`
# will be installed via APT package manager.
roundcube__composer_phar_url: 'https://getcomposer.org/composer.phar'
# ]]]
......
Credits
=======
* Reto Gantenbein <reto.gantenbein_at_linuxmonk_ch>
* author of the Ansible roundcube role
......@@ -11,7 +11,6 @@ Ansible role: debops-contrib.roundcube
defaults
guides
copyright
credits
changelog
upgrade
......
......@@ -10,7 +10,7 @@ IMAP Web client written in PHP.
Installation
~~~~~~~~~~~~
This role requires at least Ansible ``v1.8.0``. To install it, run:
This role requires at least Ansible ``v2.3.0``. To install it, run:
.. code-block:: console
......
Markdown is supported
0%
or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment