Commit de400db6 authored by Mitar's avatar Mitar

Updating instructions.

parent bffebc14
Pipeline #98017212 failed with stages
in 39 minutes and 7 seconds
......@@ -6,7 +6,7 @@ Some notes how to manage this repository and [Docker `images` repository](https:
* For `core` image, copy latest stable Dockerfile and name it after the new core
package version. For example, `ubuntu-artful-python36-v2018.6.5.dockerfile` to
`ubuntu-artful-python36-v2018.7.10.dockerfile`.
* If any of the following fixed package versions has changed, update `base` Dockerfile
* If any of the following fixed package versions has changed, update `libs` Dockerfile
to install those versions: `tensorflow-gpu`, `keras`, `Theano`, `torch`. Make sure
CUDA and other dependencies are correct for those new versions.
* Copy Dockerfile for `primitives` Docker image in the same way.
......@@ -17,7 +17,7 @@ Some notes how to manage this repository and [Docker `images` repository](https:
two versions + `devel` Dockerfile should be in `primitives` directory.
This will disable building Docker images for old versions and
effectively freeze the images for those versions.
* If fixed package versions in the `base` Dockerfile had to be changed, it might
* If fixed package versions in the `libs` Dockerfile had to be changed, it might
be that only the latest Dockerfile for `core` and `primitives` can be kept,
in that case archive all older versions.
* Make sure these files are moved before moving old primitive annotations
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment