Commit 71c0c1f2 authored by Milan Broz's avatar Milan Broz

Fix pkgconfig to use proper package version (Issue 60, thanks to Jan Engelhardt).

git-svn-id: https://cryptsetup.googlecode.com/svn/trunk@196 36d66b0a-2a48-0410-832c-cd162a569da5
parent 743fbbc4
2010-04-12 Milan Broz <mbroz@redhat.com>
* Fix package config to use proper package version.
2010-04-06 Milan Broz <mbroz@redhat.com>
* Prefer some device paths in status display.
* Support device topology detectionfor data alignment.
......
AC_PREREQ(2.57)
AC_INIT(cryptsetup,1.1.0)
dnl library version from <major>.<minor>.<release>[-<suffix>]
LIBCRYPTSETUP_VERSION=$(echo $PACKAGE_VERSION | cut -f1 -d-)
LIBCRYPTSETUP_VERSION_INFO=1:0:0
AC_CONFIG_SRCDIR(src/cryptsetup.c)
AC_CONFIG_MACRO_DIR([m4])
......@@ -94,8 +99,10 @@ fi
LIBS=$saved_LIBS
DEVMAPPER_LIBS="$DEVMAPPER_LIBS $LIB_PTHREAD"
AC_SUBST(DEVMAPPER_LIBS)
AC_SUBST(SELINUX_STATIC_LIBS)
AC_SUBST([DEVMAPPER_LIBS])
AC_SUBST([SELINUX_STATIC_LIBS])
AC_SUBST([LIBCRYPTSETUP_VERSION])
AC_SUBST([LIBCRYPTSETUP_VERSION_INFO])
dnl ==========================================================================
AC_DEFUN([CS_DEFINE],
......
......@@ -26,7 +26,7 @@ libcryptsetup_la_DEPENDENCIES = libcryptsetup.sym
libcryptsetup_la_LDFLAGS = \
$(_STATIC_LIBRARY) \
-Wl,--version-script=$(top_srcdir)/lib/libcryptsetup.sym \
-version-info 1:0:0
-version-info @LIBCRYPTSETUP_VERSION_INFO@
libcryptsetup_la_CFLAGS = -Wall @LIBGCRYPT_CFLAGS@
......
......@@ -5,6 +5,6 @@ includedir=@includedir@
Name: cryptsetup
Description: cryptsetup library
Version: 1.0.0
Version: @LIBCRYPTSETUP_VERSION@
Cflags: -I${includedir}
Libs: -L${libdir} -lcryptsetup
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment