Commit 74cc8ced authored by Connor Shea's avatar Connor Shea 🏄

Merge branch 'dependabot-test' into 'master'

Testing adding dependabot

See merge request !5
parents ce98e45a 2148b663
Pipeline #43080303 failed with stage
in 2 minutes and 53 seconds
......@@ -5,7 +5,7 @@ variables:
LC_ALL: C.UTF-8
before_script:
- bundle install
- bundle install --without dependabot
test:
stage: test
......@@ -14,6 +14,8 @@ test:
artifacts:
paths:
- test
except:
- schedules
pages:
stage: deploy
......@@ -24,3 +26,20 @@ pages:
- public
only:
- master
except:
- schedules
dependabot:
stage: build
variables:
GIT_SUBMODULE_STRATEGY: normal
PROJECT_PATH: $CI_PROJECT_PATH
PACKAGE_MANAGER: bundler
GITLAB_HOST_NAME: gitlab.com
GITLAB_AUTO_MERGE: "true"
before_script:
- bundle install
script:
- ruby bin/dependabot.rb
only:
- schedules
[submodule "dependabot-script"]
path = vendor/dependabot-script
url = https://github.com/dependabot/dependabot-script
......@@ -4,3 +4,7 @@ gem 'jekyll', '~> 3.8.5'
gem 'jekyll-auto-image', '~> 1.1.3'
gem 'jekyll-feed', '~> 0.11.0'
gem 'jekyll-compose', '~> 0.9.0'
group :dependabot do
gem "dependabot-omnibus", git: "https://github.com/dependabot/dependabot-core", tag: "v0.86.16"
end
GIT
remote: https://github.com/dependabot/dependabot-core
revision: 6f707b8e94c6760c9caf47ecde2332cabcce773b
tag: v0.86.16
specs:
dependabot-cargo (0.86.16)
dependabot-core (= 0.86.16)
dependabot-core (0.86.16)
aws-sdk-ecr (~> 1.5)
bundler (>= 1.16, < 3.0.0)
docker_registry2 (~> 1.4)
excon (~> 0.55)
gitlab (~> 4.1)
gpgme (~> 2.0)
nokogiri (~> 1.8)
octokit (~> 4.6)
parseconfig (~> 1.0)
parser (~> 2.5)
toml-rb (~> 1.1, >= 1.1.2)
dependabot-docker (0.86.16)
dependabot-core (= 0.86.16)
dependabot-elm (0.86.16)
dependabot-core (= 0.86.16)
dependabot-git_submodules (0.86.16)
dependabot-core (= 0.86.16)
dependabot-gradle (0.86.16)
dependabot-core (= 0.86.16)
dependabot-maven (0.86.16)
dependabot-core (= 0.86.16)
dependabot-nuget (0.86.16)
dependabot-core (= 0.86.16)
dependabot-omnibus (0.86.16)
dependabot-cargo (= 0.86.16)
dependabot-core (= 0.86.16)
dependabot-docker (= 0.86.16)
dependabot-elm (= 0.86.16)
dependabot-git_submodules (= 0.86.16)
dependabot-gradle (= 0.86.16)
dependabot-maven (= 0.86.16)
dependabot-nuget (= 0.86.16)
dependabot-python (= 0.86.16)
dependabot-terraform (= 0.86.16)
dependabot-python (0.86.16)
dependabot-core (= 0.86.16)
dependabot-terraform (0.86.16)
dependabot-core (= 0.86.16)
GEM
remote: https://rubygems.org/
specs:
addressable (2.5.2)
public_suffix (>= 2.0.2, < 4.0)
ast (2.4.0)
aws-eventstream (1.0.1)
aws-partitions (1.127.0)
aws-sdk-core (3.44.1)
aws-eventstream (~> 1.0)
aws-partitions (~> 1.0)
aws-sigv4 (~> 1.0)
jmespath (~> 1.0)
aws-sdk-ecr (1.10.0)
aws-sdk-core (~> 3, >= 3.39.0)
aws-sigv4 (~> 1.0)
aws-sigv4 (1.0.3)
citrus (3.0.2)
colorator (1.1.0)
concurrent-ruby (1.1.4)
docker_registry2 (1.4.1)
rest-client (>= 1.8.0)
domain_name (0.5.20180417)
unf (>= 0.0.5, < 1.0.0)
em-websocket (0.5.1)
eventmachine (>= 0.12.9)
http_parser.rb (~> 0.6.0)
eventmachine (1.2.7)
excon (0.62.0)
faraday (0.15.4)
multipart-post (>= 1.2, < 3)
ffi (1.9.25)
forwardable-extended (2.6.0)
gitlab (4.7.0)
httparty (>= 0.14.0)
terminal-table (>= 1.5.1)
gpgme (2.0.18)
mini_portile2 (~> 2.3)
http-cookie (1.0.3)
domain_name (~> 0.5)
http_parser.rb (0.6.0)
httparty (0.16.3)
mime-types (~> 3.0)
multi_xml (>= 0.5.2)
i18n (0.9.5)
concurrent-ruby (~> 1.0)
jekyll (3.8.5)
......@@ -37,6 +114,7 @@ GEM
sass (~> 3.4)
jekyll-watch (2.1.2)
listen (~> 3.0)
jmespath (1.4.0)
kramdown (1.17.0)
liquid (4.0.1)
listen (3.1.5)
......@@ -44,12 +122,30 @@ GEM
rb-inotify (~> 0.9, >= 0.9.7)
ruby_dep (~> 1.2)
mercenary (0.3.6)
mime-types (3.2.2)
mime-types-data (~> 3.2015)
mime-types-data (3.2018.0812)
mini_portile2 (2.4.0)
multi_xml (0.6.0)
multipart-post (2.0.0)
netrc (0.11.0)
nokogiri (1.9.1)
mini_portile2 (~> 2.4.0)
octokit (4.13.0)
sawyer (~> 0.8.0, >= 0.5.3)
parseconfig (1.0.8)
parser (2.5.3.0)
ast (~> 2.4.0)
pathutil (0.16.2)
forwardable-extended (~> 2.6)
public_suffix (3.0.3)
rb-fsevent (0.10.3)
rb-inotify (0.10.0)
ffi (~> 1.0)
rest-client (2.0.2)
http-cookie (>= 1.0.2, < 2.0)
mime-types (>= 1.16, < 4.0)
netrc (~> 0.8)
rouge (3.3.0)
ruby_dep (1.5.0)
safe_yaml (1.0.4)
......@@ -58,15 +154,27 @@ GEM
sass-listen (4.0.0)
rb-fsevent (~> 0.9, >= 0.9.4)
rb-inotify (~> 0.9, >= 0.9.7)
sawyer (0.8.1)
addressable (>= 2.3.5, < 2.6)
faraday (~> 0.8, < 1.0)
terminal-table (1.8.0)
unicode-display_width (~> 1.1, >= 1.1.1)
toml-rb (1.1.2)
citrus (~> 3.0, > 3.0)
unf (0.1.4)
unf_ext
unf_ext (0.0.7.5)
unicode-display_width (1.4.1)
PLATFORMS
ruby
DEPENDENCIES
dependabot-omnibus!
jekyll (~> 3.8.5)
jekyll-auto-image (~> 1.1.3)
jekyll-compose (~> 0.9.0)
jekyll-feed (~> 0.11.0)
BUNDLED WITH
1.17.1
1.17.2
#!/usr/bin/env ruby
# frozen_string_literal: true
ENV["BUNDLE_GEMFILE"] ||= File.expand_path("../Gemfile", __dir__)
require "bundler/setup"
load File.expand_path("../vendor/dependabot-script/generic-update-script.rb", __dir__)
Subproject commit 2a189bfded33ad56ecd82bcf0657842020927010
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment