Commit 2854da4f authored by John Vandenberg's avatar John Vandenberg

requirements.txt: Use custom sarge with Win fixes

sarge was not correctly handling .bat and .cmd files,
preventing `gem` and similar from being executed.

Closes #231
parent 9ea26bdb
Pipeline #64403459 failed with stages
in 16 minutes and 6 seconds
......@@ -12,10 +12,13 @@ variables:
# git is required by python package codecov and go get
# make is used by cpan
# tar is used by haskellstack.sh
# mercurial is used by pip for requirements.txt
# on openSUSE, mercurial needs python2 for ssl.so
COMMON_DEPS: >
bzip2
git
make
mercurial
tar
DEBIAN_PACKAGE_MANAGERS: >
cabal-install
......@@ -41,6 +44,7 @@ variables:
OPENSUSE_OTHER_DEPS: >
java-1_8_0-openjdk
lua53-devel
python2
ARCH_OTHER_DEPS: >
jdk8-openjdk
# Until the following was fixed, add rubygem-rdoc for GemRequirementTest
......
......@@ -15,7 +15,7 @@ scm_host: gitlab.com
keywords: []
dependencies:
- sarge~=0.1.5
- hg+https://bitbucket.org/jayvdb/[email protected]#egg=sarge
- coala-utils~=0.6
configuration:
......
sarge~=0.1.5
hg+https://bitbucket.org/jayvdb/[email protected]#egg=sarge
coala-utils~=0.6
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment