Commit ae900622 authored by bgermann's avatar bgermann

Use gmime 3.0 for Gambas 3.11.4

parent 9df78177
......@@ -8,7 +8,7 @@ publish the [gambas3 Cygwin packages](https://cygwin.com/cgi-bin2/package-grep.c
To install all required dependencies, run Cygwin's [setup tool](https://cygwin.com/install.html)
with the following parameters via a Windows terminal:
`setup.exe --packages pkg-config,xdg-utils,libffi-devel,libpcre-devel,zlib-devel,libcairo-devel,libsqlite3-devel,libdbus1-devel,libXtst-devel,libgnome-keyring-devel,libgsl-devel,libgtk2.0-devel,librsvg2-devel,libgtkglext1.0-devel,libgdk_pixbuf2.0-devel,libImlib2-devel,libxml2-devel,libgstreamer1.0-devel,libgmime2.6-devel,libncurses-devel,libcurl-devel,libglib2.0-devel,libGL-devel,libGLEW-devel,libGLU-devel,openssl-devel,libpoppler-devel,libSDL-devel,libSDL2-devel,libSDL2_ttf-devel,libSDL_ttf-devel,libSDL_mixer-devel,libSDL2_mixer-devel,libxslt-devel,libQt5Core-devel,libQt5Gui-devel,libQt5WebKit-devel,libQt5Svg-devel,libQt5X11Extras-devel,libQt5Widgets-devel,libQt5PrintSupport-devel,libQt5Network-devel,libQt5Xml-devel,libQtCore4-devel,libopenal-devel,libalure-devel,libgtk3-devel,libSM-devel,libICE-devel,libpq-devel,libSDL2_image-devel,libQtGui4-devel,libQtSvg4-devel,libQtScript4-devel,libQt3Support4-devel,libQtNetwork4-devel,libQtDBus4-devel,libQtXml4-devel,libQtWebKit4-devel,libQtOpenGL4-devel,libX11-devel,libgstinterfaces1.0-devel,libbz2-devel,libcrypt-devel,libgmp-devel,libllvm3.5-devel,libmysqlclient-devel,libiodbc-devel,postgresql-devel`
`setup.exe --packages cygport,git,pkg-config,xdg-utils,libffi-devel,libpcre-devel,zlib-devel,libcairo-devel,libsqlite3-devel,libdbus1-devel,libXtst-devel,libgnome-keyring-devel,libgsl-devel,libgtk2.0-devel,librsvg2-devel,libgtkglext1.0-devel,libgdk_pixbuf2.0-devel,libImlib2-devel,libxml2-devel,libgstreamer1.0-devel,libgmime3.0-devel,libncurses-devel,libcurl-devel,libglib2.0-devel,libGL-devel,libGLEW-devel,libGLU-devel,openssl-devel,libpoppler-devel,libSDL-devel,libSDL2-devel,libSDL2_ttf-devel,libSDL_ttf-devel,libSDL_mixer-devel,libSDL2_mixer-devel,libxslt-devel,libQt5Core-devel,libQt5Gui-devel,libQt5WebKit-devel,libQt5Svg-devel,libQt5X11Extras-devel,libQt5Widgets-devel,libQt5PrintSupport-devel,libQt5Network-devel,libQt5Xml-devel,libQtCore4-devel,libopenal-devel,libalure-devel,libgtk3-devel,libSM-devel,libICE-devel,libpq-devel,libSDL2_image-devel,libQtGui4-devel,libQtSvg4-devel,libQtScript4-devel,libQt3Support4-devel,libQtNetwork4-devel,libQtDBus4-devel,libQtXml4-devel,libQtWebKit4-devel,libQtOpenGL4-devel,libX11-devel,libgstinterfaces1.0-devel,libbz2-devel,libcrypt-devel,libgmp-devel,libllvm3.5-devel,libmysqlclient-devel,libiodbc-devel,postgresql-devel`
## Usage
......
......@@ -3,11 +3,11 @@
# It follows the guideline "How To Package Gambas" (http://gambaswiki.org/wiki/howto/package).
NAME="gambas3"
VERSION=3.11.3
VERSION=3.11.4
RELEASE=1
HOMEPAGE="http://gambas.sourceforge.net"
DEPEND="pkgconfig(libffi) pkgconfig(libpcre) pkgconfig(zlib) pkgconfig(cairo) pkgconfig(cairo-ft) pkgconfig(sqlite3) pkgconfig(dbus-1) pkgconfig(xtst) pkgconfig(gnome-keyring-1) pkgconfig(gsl) pkgconfig(gtk+-2.0) pkgconfig(gtk+-unix-print-2.0) pkgconfig(librsvg-2.0) pkgconfig(gtkglext-1.0) pkgconfig(gdk-pixbuf-2.0) pkgconfig(imlib2) pkgconfig(libxml-2.0) pkgconfig(gstreamer-1.0) pkgconfig(gmime-2.6) pkgconfig(ncurses) pkgconfig(panel) pkgconfig(libcurl) pkgconfig(glib-2.0) pkgconfig(gl) pkgconfig(glew) pkgconfig(glu) pkgconfig(openssl) pkgconfig(poppler) pkgconfig(sdl) pkgconfig(sdl2) pkgconfig(SDL2_ttf) pkgconfig(SDL_ttf) pkgconfig(SDL_mixer) pkgconfig(SDL2_mixer) pkgconfig(libxslt) pkgconfig(Qt5Core) pkgconfig(Qt5Gui) pkgconfig(Qt5WebKit) pkgconfig(Qt5Svg) pkgconfig(Qt5X11Extras) pkgconfig(Qt5Widgets) pkgconfig(Qt5PrintSupport) pkgconfig(Qt5Network) pkgconfig(Qt5Xml) pkgconfig(Qt5WebKitWidgets) pkgconfig(QtCore) pkgconfig(openal) pkgconfig(gtk+-3.0) pkgconfig(gtk+-unix-print-3.0) pkgconfig(sm) pkgconfig(ice) pkgconfig(mariadb) pkgconfig(libiodbc) pkgconfig(libpq) pkgconfig(SDL2_image) pkgconfig(QtGui) pkgconfig(QtSvg) pkgconfig(QtScript) pkgconfig(Qt3Support) pkgconfig(QtNetwork) pkgconfig(QtDBus) pkgconfig(QtXml) pkgconfig(QtWebKit) pkgconfig(QtOpenGL) pkgconfig(x11) pkgconfig(alure) pkgconfig(gstreamer-video-1.0) libbz2-devel libcrypt-devel libgmp-devel libllvm3.5-devel postgresql-devel xdg-utils"
DEPEND="pkgconfig(libffi) pkgconfig(libpcre) pkgconfig(zlib) pkgconfig(cairo) pkgconfig(cairo-ft) pkgconfig(sqlite3) pkgconfig(dbus-1) pkgconfig(xtst) pkgconfig(gnome-keyring-1) pkgconfig(gsl) pkgconfig(gtk+-2.0) pkgconfig(gtk+-unix-print-2.0) pkgconfig(librsvg-2.0) pkgconfig(gtkglext-1.0) pkgconfig(gdk-pixbuf-2.0) pkgconfig(imlib2) pkgconfig(libxml-2.0) pkgconfig(gstreamer-1.0) pkgconfig(gmime-3.0) pkgconfig(ncurses) pkgconfig(panel) pkgconfig(libcurl) pkgconfig(glib-2.0) pkgconfig(gl) pkgconfig(glew) pkgconfig(glu) pkgconfig(openssl) pkgconfig(poppler) pkgconfig(sdl) pkgconfig(sdl2) pkgconfig(SDL2_ttf) pkgconfig(SDL_ttf) pkgconfig(SDL_mixer) pkgconfig(SDL2_mixer) pkgconfig(libxslt) pkgconfig(Qt5Core) pkgconfig(Qt5Gui) pkgconfig(Qt5WebKit) pkgconfig(Qt5Svg) pkgconfig(Qt5X11Extras) pkgconfig(Qt5Widgets) pkgconfig(Qt5PrintSupport) pkgconfig(Qt5Network) pkgconfig(Qt5Xml) pkgconfig(Qt5WebKitWidgets) pkgconfig(QtCore) pkgconfig(openal) pkgconfig(gtk+-3.0) pkgconfig(gtk+-unix-print-3.0) pkgconfig(sm) pkgconfig(ice) pkgconfig(mariadb) pkgconfig(libiodbc) pkgconfig(libpq) pkgconfig(SDL2_image) pkgconfig(QtGui) pkgconfig(QtSvg) pkgconfig(QtScript) pkgconfig(Qt3Support) pkgconfig(QtNetwork) pkgconfig(QtDBus) pkgconfig(QtXml) pkgconfig(QtWebKit) pkgconfig(QtOpenGL) pkgconfig(x11) pkgconfig(alure) pkgconfig(gstreamer-video-1.0) libbz2-devel libcrypt-devel libgmp-devel libllvm3.5-devel postgresql-devel xdg-utils"
GIT_URI="https://gitlab.com/gambas/gambas.git"
GIT_TAG="${PV}"
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment