Commit 4ba14f32 authored by colmoneill's avatar colmoneill

A specific commit on these two to note that we will have to

work with a specific version of Flask-Security because of
this bug I ran into :
https://stackoverflow.com/questions/50105057/flask-security-error-valueerror-too-many-values-to-unpack

best to run the MIGRATION lines in the readme for further
smooth dev
parent 54a4362c
......@@ -9,32 +9,16 @@ Main components:
Current requirements are as so:
```
Babel==2.6.0
blinker==1.4
click==6.7
Flask==1.0.2
Flask-BabelEx==0.9.3
Flask-FlatPages==0.6
Flask-Login==0.4.1
Flask-Mail==0.9.1
flask-mongoengine==0.9.5
Flask-Principal==0.4.0
Flask-Security==3.0.0
Flask-WTF==0.14.2
itsdangerous==0.24
Jinja2==2.10
Markdown==2.6.11
MarkupSafe==1.0
mongoengine==0.15.0
passlib==1.7.1
pymongo==3.7.0
pytz==2018.5
PyYAML==3.12
six==1.11.0
speaklater==1.3
Werkzeug==0.14.1
WTForms==2.2.1
git+https://github.com/mattupstate/flask-security
```
### MIGRATION:
pip uninstall Flask-Login Flask-Mail Flask-Principal Flask-WTF isitdangerous passlib
pip install git+https://github.com/mattupstate/flask-security
Mongod startup example for dev purposes:
`mongod --noauth --dbpath /home/colm/git/bemaker/eu.bemaker.flask/data/`
Babel==2.6.0
bcrypt==3.1.4
blinker==1.4
cffi==1.11.5
click==6.7
Flask==1.0.2
Flask-BabelEx==0.9.3
......@@ -8,7 +10,9 @@ Flask-Login==0.4.1
Flask-Mail==0.9.1
flask-mongoengine==0.9.5
Flask-Principal==0.4.0
Flask-Security==3.0.0
# Flask-Security following
https://stackoverflow.com/questions/50105057/flask-security-error-valueerror-too-many-values-to-unpack
git+https://github.com/mattupstate/flask-security
Flask-WTF==0.14.2
itsdangerous==0.24
Jinja2==2.10
......@@ -16,6 +20,7 @@ Markdown==2.6.11
MarkupSafe==1.0
mongoengine==0.15.0
passlib==1.7.1
pycparser==2.18
pymongo==3.7.0
pytz==2018.5
PyYAML==3.12
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment