Commit 94ca91b6 authored by Mehmet Kozan's avatar Mehmet Kozan

project groups changed to autokent.

parent a6a81720
Pipeline #14890405 passed with stages
in 3 minutes and 24 seconds
......@@ -8,29 +8,8 @@ stages:
- package
before_script:
# Install ssh-agent if not already installed, it is required by Docker.
# (change apt-get to yum if you use a CentOS-based image)
#- 'which ssh-agent || ( apt-get update -y && apt-get install openssh-client -y )'
# Run ssh-agent (inside the build environment)
#- eval $(ssh-agent -s)
# Add the SSH key stored in SSH_PRIVATE_KEY variable to the agent store
#- ssh-add <(echo "$SSH_PRIVATE_KEY")
# For Docker builds disable host key checking. Be aware that by adding that
# you are suspectible to man-in-the-middle attacks.
# WARNING: Use this only with the Docker executor, if you use it with shell
# you will overwrite your user's SSH config.
#- mkdir -p ~/.ssh
#- '[[ -f /.dockerenv ]] && echo -e "Host *\n\tStrictHostKeyChecking no\n\n" > ~/.ssh/config'
# In order to properly check the server's host key, assuming you created the
# SSH_SERVER_HOSTKEYS variable previously, uncomment the following two lines
# instead.
# - mkdir -p ~/.ssh
# - '[[ -f /.dockerenv ]] && echo "$SSH_SERVER_HOSTKEYS" > ~/.ssh/known_hosts'
- git config --global user.email $GIT_EMAIL
- git config --global user.name $GIT_USER
- git config --global user.email $GITLAB_USER_EMAIL
- git config --global user.name $GITLAB_USER_LOGIN
after_script:
- echo "end of script"
......@@ -61,10 +40,10 @@ version_check:
- |
if [ "${REPO_VERSION}" != "${CURRENT_VERSION}" ]; then
echo "repo version not equal to current version"
echo REPO_VERSION=${REPO_VERSION}
echo CURRENT_VERSION=${CURRENT_VERSION}
git tag v${CURRENT_VERSION} master
git push origin v${CURRENT_VERSION}
#git push [email protected]:mehmet.kozan/${CI_PROJECT_NAME}.git v${CURRENT_VERSION}
#git push https://gitlab-ci-token:${REPO_TOKEN}@gitlab.com/mehmet.kozan/${CI_PROJECT_NAME}.git/ v${CURRENT_VERSION}
git push ${CI_REPOSITORY_URL//$CI_REGISTRY_PASSWORD/$CI_ACCESS_TOKENS} v${CURRENT_VERSION}
fi
npm_publish:
......
......@@ -6,7 +6,7 @@
[![version](https://img.shields.io/npm/v/crawler-url-parser.svg)](https://www.npmjs.org/package/crawler-url-parser)
[![downloads](https://img.shields.io/npm/dt/crawler-url-parser.svg)](https://www.npmjs.org/package/crawler-url-parser)
[![node](https://img.shields.io/node/v/crawler-url-parser.svg)](https://nodejs.org/)
[![status](https://gitlab.com/mehmet.kozan/crawler-url-parser/badges/master/pipeline.svg)](https://gitlab.com/mehmet.kozan/crawler-url-parser/pipelines)
[![status](https://gitlab.com/autokent/crawler-url-parser/badges/master/pipeline.svg)](https://gitlab.com/autokent/crawler-url-parser/pipelines)
## Installation
`npm install crawler-url-parser`
......
{
"name": "crawler-url-parser",
"version": "1.4.7",
"version": "1.4.8",
"description": "An `URL` parser for crawling purpose.",
"main": "crawler-url-parser.js",
"keywords": [
......
Markdown is supported
0%
or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment