Commit ba4667a1 authored by Emeric Verschuur's avatar Emeric Verschuur

Add a check on the bash version

parent 0a424862
......@@ -42,8 +42,8 @@ print_info() {
}
# Check bash
if [ -z "$BASH" ]; then
print_critical "This script needs BASH"
if [ -z "$BASH" ] && [ "${BASH_VERSION%%.*}" -ge 4 ]; then
print_critical "This script needs BASH version 4 or greater"
fi
# ci-tools base directory bath
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment