• Christian Boltz's avatar
    Switch utils to python3 · 1c4a885e
    Christian Boltz authored
    As discussed a while ago, switch the utils (including their tests) to
    use python3 by default. While on it, drop usage of "env" to always get
    the system python3 instead of a random one that happens to live
    somewhere in $PATH.
    
    In practise, this patch doesn't change much - AFAIK openSUSE, Debian and
    Ubuntu already patch aa-* to use python3.
    
    Also add a note to README to officially deprecate Python 2.x.
    (I won't break Python 2.x support intentionally - unless some future
    change gives me a very good reason to finally drop Python 2.x support.)
    Acked-by: 's avatarSeth Arnold <seth.arnold@canonical.com>
    (since 2016-08-23, but the commit had to wait for the FileRule series
     because it touches test-file.py)
    1c4a885e
aa-complain 1.4 KB