Commit 69db2506 authored by Dan Allen's avatar Dan Allen

set minimum version of Node to 8.0.0, but recommend latest in 8.x series

parent 373d01e2
......@@ -183,7 +183,7 @@ To see which version of Node you have installed, open a terminal and type:
If `node --version` doesn't return any information, you don't yet have Node installed.
The minimum required version of Node is *v8.5.0*, as indicated in the [.path]_package.json_ file.
The minimum required version of Node is *8.0.0*, as indicated in [.path]_package.json_, though we recommend using the latest release in the 8.x series.
This is also the recommended version of Node for development.
.Why Node 8?
......@@ -195,7 +195,7 @@ In order to use this feature, we need least Node v7.10.1.
For stability reasons, we decided to go for Node 8 since our dependencies are compatible and it will have longer support.
****
If you don't yet have Node installed, or the version of Node you have isn't Node 7, we strongly recommend using {uri-nvm}[nvm] (Node Version Manager) to manage your Node installations.
If you don't yet have Node installed, or the version of Node you have isn't Node 8, we strongly recommend using {uri-nvm}[nvm] (Node Version Manager) to manage your Node installations.
Follow the {uri-nvm-install}[nvm installation instructions] to set up nvm on your machine.
TIP: Many CI environments use nvm to install the version of Node used for the build job.
......
......@@ -22,7 +22,7 @@ We will bump the minimum version of Node to develop and use Antora from Node 7 t
The only factor that was previously holding back this change was for nodegit to support Node 8.
Installing nodegit on Node 8 used to require the installer to build nodegit from source, which took several minutes.
We've confirmed that nodegit installs on Node 8.5 using Yarn 1.1.0 in a few seconds.
We've confirmed that nodegit installs on Node 8 using Yarn in a few seconds (tested using Node v8.5.0 and Yarn 1.1.0).
Now that nodegit supports Node 8, there is nothing preventing Antora from upgrading.
== Consequences
......
......@@ -9,7 +9,7 @@
"license": "MPL-2.0",
"main": "lib/index.js",
"engines": {
"node": ">= 8.5.0"
"node": ">= 8.0.0"
},
"devDependencies": {
"array-to-stream": "^1.0.2",
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment