...
 
Commits (3)
......@@ -13,6 +13,7 @@
"build": {
"builder": "@angular-devkit/build-angular:browser",
"options": {
"aot": true,
"outputPath": "../../../target/frontend",
"index": "src/index.html",
"main": "src/main.ts",
......@@ -29,6 +30,12 @@
},
"configurations": {
"production": {
"budgets": [
{
"type": "anyComponentStyle",
"maximumWarning": "6kb"
}
],
"fileReplacements": [
{
"replace": "src/environments/environment.ts",
......
......@@ -8,37 +8,39 @@
"build": "ng build",
"test": "ng test",
"lint": "ng lint",
"e2e": "ng e2e"
"e2e": "ng e2e",
"postinstall": "ngcc"
},
"private": true,
"dependencies": {
"@angular/animations": "8.2.13",
"@angular/cdk": "^8.2.3",
"@angular/common": "8.2.13",
"@angular/compiler": "8.2.13",
"@angular/core": "8.2.13",
"@angular/forms": "8.2.13",
"@angular/platform-browser": "8.2.13",
"@angular/platform-browser-dynamic": "8.2.13",
"@angular/router": "8.2.13",
"@angular/animations": "9.1.11",
"@angular/cdk": "^9.1.3",
"@angular/common": "9.1.11",
"@angular/compiler": "9.1.11",
"@angular/core": "9.1.11",
"@angular/forms": "9.1.11",
"@angular/localize": "^9.1.11",
"@angular/platform-browser": "9.1.11",
"@angular/platform-browser-dynamic": "9.1.11",
"@angular/router": "9.1.11",
"@auth0/auth0-spa-js": "^1.5.0",
"@ng-bootstrap/ng-bootstrap": "^5.1.1",
"@swimlane/ngx-charts": "^12.0.1",
"@swimlane/ngx-charts": "^12.1.0",
"core-js": "^2.4.1",
"d3": "^5.12.0",
"rxjs": "^6.5.3",
"tslib": "^1.9.0",
"zone.js": "~0.9.1"
"tslib": "^2.0.0",
"zone.js": "~0.10.3"
},
"devDependencies": {
"@angular-devkit/build-angular": "~0.803.18",
"@angular/cli": "^8.3.18",
"@angular/compiler-cli": "8.2.13",
"@angular/language-service": "8.2.13",
"@angular-devkit/build-angular": "~0.1000.0",
"@angular/cli": "^9.1.9",
"@angular/compiler-cli": "9.1.11",
"@angular/language-service": "9.1.11",
"@types/jasmine": "~2.8.3",
"@types/jasminewd2": "~2.0.2",
"@types/node": "^6.0.101",
"codelyzer": "^5.0.1",
"@types/node": "^12.11.1",
"codelyzer": "^5.1.2",
"jasmine-core": "~2.8.0",
"jasmine-spec-reporter": "~4.2.1",
"karma": "^4.3.0",
......@@ -49,6 +51,6 @@
"protractor": "^5.4.0",
"ts-node": "~4.1.0",
"tslint": "~5.9.1",
"typescript": "3.5.3"
"typescript": "3.8.3"
}
}
/***************************************************************************************************
* Load `$localize` onto the global scope - used if i18n tags appear in Angular templates.
*/
import '@angular/localize/init';
/***************************************************************************************************
* Zone JS is required by default for Angular itself.
*/
import 'zone.js/dist/zone'; // Included with Angular CLI.
/**
......@@ -8,14 +15,6 @@
// import 'web-animations-js'; // Run `npm install --save web-animations-js`.
/***************************************************************************************************
* Zone JS is required by default for Angular itself.
*/
import 'zone.js/dist/zone'; // Included with Angular CLI.
/***************************************************************************************************
* APPLICATION IMPORTS
*/
......@@ -5,8 +5,11 @@
"baseUrl": "./",
"types": []
},
"exclude": [
"test.ts",
"**/*.spec.ts"
"files": [
"main.ts",
"polyfills.ts"
],
"include": [
"src/**/*.d.ts"
]
}