Commit 204940a4 authored by Alex Ives's avatar Alex Ives 🔶
Browse files

Upgrade jekyll/ruby add bin

parent 15964d93
Pipeline #118665298 failed with stages
in 43 seconds
......@@ -2,3 +2,4 @@ _site
.DS_Store
public
.env
.jekyll-cache
......@@ -4,8 +4,6 @@
JEKYLL_ENV: production
before_script:
- bundle install
except:
- schedules
stages:
- test
......@@ -16,27 +14,11 @@ test:
stage: test
script:
- bundle exec rake test
except:
refs:
- schedules
variables:
- $CI_COMMIT_MESSAGE =~ /Automated Let's Encrypt renewal/
artifacts:
paths:
- test
renew:letsencrypt:
stage: deploy
image: alexives/gitlab-le
retry: 2
only:
- schedules
script:
- gitlab-le --email $GITLAB_USER_EMAIL --domain alex.ives.mn --repository https://gitlab.com/alexives/alexives.gitlab.io --token $GITLAB_LETSENCRYPT_TOKEN --path .letsencrypt --production
build:docker:
except:
- schedules
only:
changes:
- Dockerfile
......
FROM ruby:2.4-alpine
FROM ruby:2.6-alpine
COPY Gemfile* /app/
......
......@@ -6,14 +6,14 @@ Encoding.default_internal = Encoding::UTF_8
require 'json'
require 'open-uri'
gem 'jekyll', '= 3.5.2'
gem 'jekyll'
gem 'rake'
group :jekyll_plugins do
gem 'jekyll-gitlab-letsencrypt'
gem 'jekyll-paginate', '= 1.1.0'
gem 'jekyll-paginate'
end
group :test do
gem 'html-proofer'
end
\ No newline at end of file
end
GEM
remote: https://rubygems.org/
specs:
acme-client (0.6.2)
acme-client (0.6.3)
faraday (~> 0.9, >= 0.9.1)
activesupport (4.2.9)
i18n (~> 0.7)
activesupport (6.0.2.1)
concurrent-ruby (~> 1.0, >= 1.0.2)
i18n (>= 0.7, < 2)
minitest (~> 5.1)
thread_safe (~> 0.3, >= 0.3.4)
tzinfo (~> 1.1)
addressable (2.5.2)
public_suffix (>= 2.0.2, < 4.0)
zeitwerk (~> 2.2)
addressable (2.7.0)
public_suffix (>= 2.0.2, < 5.0)
colorator (1.1.0)
colorize (0.8.1)
concurrent-ruby (1.0.5)
ethon (0.11.0)
concurrent-ruby (1.1.5)
em-websocket (0.5.1)
eventmachine (>= 0.12.9)
http_parser.rb (~> 0.6.0)
ethon (0.12.0)
ffi (>= 1.3.0)
faraday (0.13.1)
eventmachine (1.2.7)
faraday (0.17.3)
multipart-post (>= 1.2, < 3)
ffi (1.9.18)
ffi (1.11.3)
forwardable-extended (2.6.0)
html-proofer (3.7.4)
activesupport (>= 4.2, < 6.0)
html-proofer (3.15.0)
addressable (~> 2.3)
colorize (~> 0.8)
mercenary (~> 0.3.2)
nokogiri (~> 1.7)
mercenary (~> 0.3)
nokogumbo (~> 2.0)
parallel (~> 1.3)
typhoeus (~> 0.7)
rainbow (~> 3.0)
typhoeus (~> 1.3)
yell (~> 2.0)
i18n (0.9.1)
http_parser.rb (0.6.0)
i18n (1.7.0)
concurrent-ruby (~> 1.0)
jekyll (3.5.2)
jekyll (4.0.0)
addressable (~> 2.4)
colorator (~> 1.0)
jekyll-sass-converter (~> 1.0)
jekyll-watch (~> 1.1)
kramdown (~> 1.3)
em-websocket (~> 0.5)
i18n (>= 0.9.5, < 2)
jekyll-sass-converter (~> 2.0)
jekyll-watch (~> 2.0)
kramdown (~> 2.1)
kramdown-parser-gfm (~> 1.0)
liquid (~> 4.0)
mercenary (~> 0.3.3)
pathutil (~> 0.9)
rouge (~> 1.7)
rouge (~> 3.0)
safe_yaml (~> 1.0)
jekyll-gitlab-letsencrypt (0.2.0)
terminal-table (~> 1.8)
jekyll-gitlab-letsencrypt (0.4.1)
acme-client (~> 0.6)
activesupport (>= 3.0.0)
jekyll-paginate (1.1.0)
jekyll-sass-converter (1.5.0)
sass (~> 3.4)
jekyll-watch (1.5.0)
listen (~> 3.0, < 3.1)
kramdown (1.13.2)
liquid (4.0.0)
listen (3.0.6)
rb-fsevent (>= 0.9.3)
rb-inotify (>= 0.9.7)
jekyll-sass-converter (2.0.1)
sassc (> 2.0.1, < 3.0)
jekyll-watch (2.2.1)
listen (~> 3.0)
kramdown (2.1.0)
kramdown-parser-gfm (1.1.0)
kramdown (~> 2.0)
liquid (4.0.3)
listen (3.2.1)
rb-fsevent (~> 0.10, >= 0.10.3)
rb-inotify (~> 0.9, >= 0.9.10)
mercenary (0.3.6)
mini_portile2 (2.3.0)
minitest (5.10.3)
multipart-post (2.0.0)
nokogiri (1.8.1)
mini_portile2 (~> 2.3.0)
parallel (1.12.0)
pathutil (0.16.0)
mini_portile2 (2.4.0)
minitest (5.13.0)
multipart-post (2.1.1)
nokogiri (1.10.7)
mini_portile2 (~> 2.4.0)
nokogumbo (2.0.2)
nokogiri (~> 1.8, >= 1.8.4)
parallel (1.19.1)
pathutil (0.16.2)
forwardable-extended (~> 2.6)
public_suffix (3.0.1)
rake (12.3.0)
rb-fsevent (0.10.2)
rb-inotify (0.9.10)
ffi (>= 0.5.0, < 2)
rouge (1.11.1)
safe_yaml (1.0.4)
sass (3.5.3)
sass-listen (~> 4.0.0)
sass-listen (4.0.0)
rb-fsevent (~> 0.9, >= 0.9.4)
rb-inotify (~> 0.9, >= 0.9.7)
public_suffix (4.0.2)
rainbow (3.0.0)
rake (13.0.1)
rb-fsevent (0.10.3)
rb-inotify (0.10.1)
ffi (~> 1.0)
rouge (3.14.0)
safe_yaml (1.0.5)
sassc (2.2.1)
ffi (~> 1.9)
terminal-table (1.8.0)
unicode-display_width (~> 1.1, >= 1.1.1)
thread_safe (0.3.6)
typhoeus (0.8.0)
ethon (>= 0.8.0)
tzinfo (1.2.4)
typhoeus (1.3.1)
ethon (>= 0.9.0)
tzinfo (1.2.6)
thread_safe (~> 0.1)
yell (2.0.7)
unicode-display_width (1.6.0)
yell (2.2.0)
zeitwerk (2.2.2)
PLATFORMS
ruby
DEPENDENCIES
html-proofer
jekyll (= 3.5.2)
jekyll
jekyll-gitlab-letsencrypt
jekyll-paginate (= 1.1.0)
jekyll-paginate
rake
BUNDLED WITH
......
#!/usr/bin/env ruby
# frozen_string_literal: true
#
# This file was generated by Bundler.
#
# The application 'jekyll' is installed as part of a gem, and
# this file is here to facilitate running it.
#
require "pathname"
ENV["BUNDLE_GEMFILE"] ||= File.expand_path("../../Gemfile",
Pathname.new(__FILE__).realpath)
bundle_binstub = File.expand_path("../bundle", __FILE__)
if File.file?(bundle_binstub)
if File.read(bundle_binstub, 300) =~ /This file was generated by Bundler/
load(bundle_binstub)
else
abort("Your `bin/bundle` was not generated by Bundler, so this binstub cannot run.
Replace `bin/bundle` by running `bundle binstubs bundler --force`, then run this command again.")
end
end
require "rubygems"
require "bundler/setup"
load Gem.bin_path("jekyll", "jekyll")
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment