Commit 0db11c54 authored by Matthew Collins's avatar Matthew Collins

Use a dark theme for the site

parent 616c7df6
......@@ -5,6 +5,7 @@ gem "sprockets", "~> 4.0.beta", {
}
gem "image_optim"
gem "image_optim_pack"
gem 'image_optim_rails'
gem "mini_magick"
gem "sass"
gem 'jekyll', '~> 3.8', '>= 3.8.2'
......
GEM
remote: https://rubygems.org/
specs:
activesupport (5.2.0)
actioncable (5.2.2)
actionpack (= 5.2.2)
nio4r (~> 2.0)
websocket-driver (>= 0.6.1)
actionmailer (5.2.2)
actionpack (= 5.2.2)
actionview (= 5.2.2)
activejob (= 5.2.2)
mail (~> 2.5, >= 2.5.4)
rails-dom-testing (~> 2.0)
actionpack (5.2.2)
actionview (= 5.2.2)
activesupport (= 5.2.2)
rack (~> 2.0)
rack-test (>= 0.6.3)
rails-dom-testing (~> 2.0)
rails-html-sanitizer (~> 1.0, >= 1.0.2)
actionview (5.2.2)
activesupport (= 5.2.2)
builder (~> 3.1)
erubi (~> 1.4)
rails-dom-testing (~> 2.0)
rails-html-sanitizer (~> 1.0, >= 1.0.3)
activejob (5.2.2)
activesupport (= 5.2.2)
globalid (>= 0.3.6)
activemodel (5.2.2)
activesupport (= 5.2.2)
activerecord (5.2.2)
activemodel (= 5.2.2)
activesupport (= 5.2.2)
arel (>= 9.0)
activestorage (5.2.2)
actionpack (= 5.2.2)
activerecord (= 5.2.2)
marcel (~> 0.3.1)
activesupport (5.2.2)
concurrent-ruby (~> 1.0, >= 1.0.2)
i18n (>= 0.7, < 2)
minitest (~> 5.1)
tzinfo (~> 1.1)
addressable (2.5.2)
addressable (2.6.0)
public_suffix (>= 2.0.2, < 4.0)
arel (9.0.0)
builder (3.2.3)
colorator (1.1.0)
concurrent-ruby (1.0.5)
concurrent-ruby (1.1.4)
crass (1.0.4)
em-websocket (0.5.1)
eventmachine (>= 0.12.9)
http_parser.rb (~> 0.6.0)
erubi (1.8.0)
eventmachine (1.2.7)
execjs (2.7.0)
exifr (1.3.4)
exifr (1.3.6)
extras (0.3.0)
forwardable-extended (~> 2.5)
fastimage (2.1.3)
ffi (1.9.25)
fastimage (2.1.5)
ffi (1.10.0)
forwardable-extended (2.6.0)
fspath (3.1.0)
globalid (0.4.2)
activesupport (>= 4.2.0)
http_parser.rb (0.6.0)
i18n (0.9.5)
concurrent-ruby (~> 1.0)
image_optim (0.26.1)
image_optim (0.26.3)
exifr (~> 1.2, >= 1.2.2)
fspath (~> 3.0)
image_size (~> 1.5)
image_size (>= 1.5, < 3)
in_threads (~> 1.3)
progress (~> 3.0, >= 3.0.1)
image_optim_pack (0.5.1)
image_optim_pack (0.5.1.20190105)
fspath (>= 2.1, < 4)
image_optim (~> 0.19)
image_size (1.5.0)
in_threads (1.5.0)
jekyll (3.8.3)
image_optim_rails (0.4.1)
image_optim (~> 0.24)
rails
sprockets
image_size (2.0.0)
in_threads (1.5.1)
jekyll (3.8.5)
addressable (~> 2.4)
colorator (~> 1.0)
em-websocket (~> 0.5)
......@@ -49,7 +95,7 @@ GEM
pathutil (~> 0.9)
rouge (>= 1.7, < 4)
safe_yaml (~> 1.0)
jekyll-assets (3.0.11)
jekyll-assets (3.0.12)
activesupport (~> 5.0)
execjs (~> 2.7)
extras (~> 0.2)
......@@ -68,10 +114,10 @@ GEM
jekyll (~> 3.1)
jekyll-sass-converter (1.5.2)
sass (~> 3.4)
jekyll-watch (2.0.0)
jekyll-watch (2.1.2)
listen (~> 3.0)
kramdown (1.17.0)
liquid (4.0.0)
liquid (4.0.1)
liquid-tag-parser (1.9.0)
extras (~> 0.3)
liquid (>= 3.0, < 5.0)
......@@ -79,34 +125,80 @@ GEM
rb-fsevent (~> 0.9, >= 0.9.4)
rb-inotify (~> 0.9, >= 0.9.7)
ruby_dep (~> 1.2)
loofah (2.2.3)
crass (~> 1.0.2)
nokogiri (>= 1.5.9)
mail (2.7.1)
mini_mime (>= 0.1.1)
marcel (0.3.3)
mimemagic (~> 0.3.2)
mercenary (0.3.6)
mini_magick (4.8.0)
mini_portile2 (2.3.0)
method_source (0.9.2)
mimemagic (0.3.3)
mini_magick (4.9.2)
mini_mime (1.0.1)
mini_portile2 (2.4.0)
minitest (5.11.3)
nokogiri (1.8.3)
mini_portile2 (~> 2.3.0)
pathutil (0.16.1)
nio4r (2.3.1)
nokogiri (1.10.1)
mini_portile2 (~> 2.4.0)
pathutil (0.16.2)
forwardable-extended (~> 2.6)
progress (3.4.0)
public_suffix (3.0.2)
rack (2.0.5)
progress (3.5.0)
public_suffix (3.0.3)
rack (2.0.6)
rack-test (1.1.0)
rack (>= 1.0, < 3)
rails (5.2.2)
actioncable (= 5.2.2)
actionmailer (= 5.2.2)
actionpack (= 5.2.2)
actionview (= 5.2.2)
activejob (= 5.2.2)
activemodel (= 5.2.2)
activerecord (= 5.2.2)
activestorage (= 5.2.2)
activesupport (= 5.2.2)
bundler (>= 1.3.0)
railties (= 5.2.2)
sprockets-rails (>= 2.0.0)
rails-dom-testing (2.0.3)
activesupport (>= 4.2.0)
nokogiri (>= 1.6)
rails-html-sanitizer (1.0.4)
loofah (~> 2.2, >= 2.2.2)
railties (5.2.2)
actionpack (= 5.2.2)
activesupport (= 5.2.2)
method_source
rake (>= 0.8.7)
thor (>= 0.19.0, < 2.0)
rake (12.3.2)
rb-fsevent (0.10.3)
rb-inotify (0.9.10)
ffi (>= 0.5.0, < 2)
rouge (3.1.1)
rb-inotify (0.10.0)
ffi (~> 1.0)
rouge (3.3.0)
ruby_dep (1.5.0)
safe_yaml (1.0.4)
sass (3.5.6)
sass (3.7.3)
sass-listen (~> 4.0.0)
sass-listen (4.0.0)
rb-fsevent (~> 0.9, >= 0.9.4)
rb-inotify (~> 0.9, >= 0.9.7)
sprockets (4.0.0.beta7)
sprockets (4.0.0.beta8)
concurrent-ruby (~> 1.0)
rack (> 1, < 3)
sprockets-rails (3.2.1)
actionpack (>= 4.0)
activesupport (>= 4.0)
sprockets (>= 3.0.0)
thor (0.20.3)
thread_safe (0.3.6)
tzinfo (1.2.5)
thread_safe (~> 0.1)
websocket-driver (0.7.0)
websocket-extensions (>= 0.1.0)
websocket-extensions (0.1.3)
PLATFORMS
ruby
......@@ -114,6 +206,7 @@ PLATFORMS
DEPENDENCIES
image_optim
image_optim_pack
image_optim_rails
jekyll (~> 3.8, >= 3.8.2)
jekyll-assets (~> 3.0, >= 3.0.11)
jekyll-feed (~> 0.9.3)
......@@ -122,8 +215,5 @@ DEPENDENCIES
sass
sprockets (~> 4.0.beta)
RUBY VERSION
ruby 2.5.1p57
BUNDLED WITH
1.16.1
2.0.1
......@@ -18,9 +18,9 @@
body {
font-family: 'Noto Sans', sans-serif;
line-height: 1.4;
background-color: #EEE;
background-color: #111;
font-size: 16px;
color: #222;
color: #EEE;
padding: 0;
max-width: 800px;
margin: 50px auto;
......@@ -36,7 +36,7 @@ h1.title {
a {
text-decoration: none;
color: #222;
color: #EEE;
}
}
......@@ -50,7 +50,7 @@ span.postmeta {
}
p > code {
background-color: #DDD;
background-color: #333;
}
code {
......@@ -60,13 +60,14 @@ code {
pre.highlight {
padding: 16px 16px;
overflow-x: scroll;
overflow-x: auto;
}
.highlight {
background-color: #444;
background-color: #000;
margin: 0 0;
color: #f8f8f2;
box-shadow: inset 0px 0px 10px 10px #111;
}
.cimage {
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment