Commit 59881dca authored by Tails developers's avatar Tails developers

Add dialogs and error messages to IUK blueprint

parent 4506e8e0
......@@ -101,3 +101,102 @@ Or maybe this can happen behind the scenes, e.g.: Automatically
switch circuit every X minutes or Y% progress? That could even make
fingerprinting the download on the Tor client <-> Entry Node side of
the pipe a bit more difficult, for whatever that's worth.
# Dialogs and error messages
## Not enough memory available
**Not enough memory available to check for upgrades.**
- Make sure this system satisfies the requirements for running Tails.<br/>
See file:///usr/share/doc/tails/website/doc/about/requirements.en.html
- Try to restart Tails and upgrade again.
- Or do a manual upgrade.<br/>
See https://tails.boum.org/doc/first_steps/upgrade#manual
## Error while checking for upgrades
**Could not determine whether an upgrade is available from our website.**
Check your network connection, and restart Tails to try upgrading again.
If the problem persists, go to file:///usr/share/doc/tails/website/doc/upgrade/error/check.en.html.
**Debugging information**
...
## Upgrade available
**You should upgrade to Tails 0.22.**
For more information about this new version, go to https://tails.boum.org/news/version_0.22/.
Note that:
- It is recommended to close all the open applications during the upgrade.
- Downloading the upgrade might take a long time, from several minutes to a few hours.
- The networking will be disabled after downloading the upgrade.
Download size: 201 MB
Do you want to upgrade now?
[Upgrade later] [Upgrade now]
## New version available
**You should manually upgrade to Tails 0.22.**
For more information about this new version, go to https://tails.boum.org/news/version_0.22/.
Note that it is not possible to do an automatic upgrade on your
system. Automatic upgrades are only possible on a Tails device
installed using Tails Installer.
To learn how to manually upgrade, go to https://tails.boum.org/doc/first_steps/upgrade#manual
## Downloading upgrade
Downloading the upgrade to Tails 0.22...
## Error while downloading the upgrade
**The upgrade could not be downloaded.**
Check your network connection, and restart Tails to try upgrading again.
If the problem persists, go to file:///usr/share/doc/tails/website/doc/upgrade/error/download.en.html.
**Debugging information**
...
## Upgrading the system
**Your Tails device is being upgraded...**
For security reasons, the networking is now disabled.
## Error while installing the upgrade
**An error occured while installing the upgrade.**
Your Tails device needs to be repaired and might be unable to restart.
Please follow the instructions at file:///usr/share/doc/tails/website/doc/upgrade/error/install.en.html
**Debugging information**
...
## Restart Tails
**Your Tails device was successfully upgraded.**
Some security features were temporarily disabled.<br/>
You should restart Tails on the new version as soon as possible.
Do you want to restart now?
[Restart later] [Restart now]
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment