Commit d2aec735 authored by Hanspeter Portner's avatar Hanspeter Portner

update travis to use latest compilers.

parent 2d4fd00e
......@@ -4,11 +4,15 @@ compiler:
- gcc
- clang
before_install:
- wget https://github.com/libuv/libuv/archive/v1.4.2.tar.gz
- tar xzf v1.4.2.tar.gz
- if [ "$CC" = "clang" ]; then sudo add-apt-repository -y ppa:h-rayflood/llvm-upper; fi
- sudo add-apt-repository -y ppa:ubuntu-toolchain-r/test
- sudo apt-get -q update
install:
- pushd libuv-1.4.2 && sh autogen.sh && ./configure --prefix=/usr && make && sudo make install && popd
- if [ "$CC" = "clang" ]; then sudo apt-get install -y clang-3.6 libstdc++-5-dev; fi
- if [ "$CC" = "gcc" ]; then sudo apt-get install -y gcc-5 g++-5; fi
before_script:
- if [ "$CC" = "clang" ]; then export CXX="clang++-3.6" CC="clang-3.6" CFLAGS="-ffreestanding"; fi
- if [ "$CC" = "gcc" ]; then export CXX="g++-5" CC="gcc-5"; fi
- mkdir build && pushd build && cmake -DBUILD_TESTING=1 -DCMAKE_BUILD_TYPE=Debug .. && popd
script:
- pushd build && make && ARGS="-VV" make test && popd
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment