Commit 7ddfea2b authored by Mischa Krüger's avatar Mischa Krüger

Improve docstring phrasing

... for `RscriptRequirement` and `MavenRequirement`.

Closes coala/package_manager#86
parent febb4280
...@@ -38,8 +38,8 @@ class MavenRequirement(PackageRequirement): ...@@ -38,8 +38,8 @@ class MavenRequirement(PackageRequirement):
:param package: A string with the {groupId:artifactId} of :param package: A string with the {groupId:artifactId} of
the package to be installed. the package to be installed.
:param version: A version string. :param version: A version string.
:param repo: The repository from which the package to :param repo: The repository from which the package is to be
be installed is from. installed.
""" """
package_regex = '([^: /]*:[^: /]*)' package_regex = '([^: /]*:[^: /]*)'
package_match = (re.compile(package_regex)).match(package) package_match = (re.compile(package_regex)).match(package)
......
...@@ -44,8 +44,8 @@ class RscriptRequirement(PackageRequirement): ...@@ -44,8 +44,8 @@ class RscriptRequirement(PackageRequirement):
:param version: A version string. Leave empty to specify latest version. :param version: A version string. Leave empty to specify latest version.
:param flag: A string that specifies any additional flags, that :param flag: A string that specifies any additional flags, that
are passed to the type. are passed to the type.
:param repo: The repository from which the package to be installed is :param repo: The repository from which the package is to be
from. installed.
""" """
PackageRequirement.__init__(self, 'R', package, version, repo) PackageRequirement.__init__(self, 'R', package, version, repo)
self.flag = flag self.flag = flag
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment