Commit 64feff4f authored by John Johnson's avatar John Johnson

dev-libs/libpeas: disable lua

parent 34204395
......@@ -14,7 +14,7 @@ LICENSE="LGPL-2+"
SLOT="0"
KEYWORDS="~alpha amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc x86 ~amd64-fbsd ~amd64-linux ~x86-linux"
IUSE="+gtk glade lua luajit +python"
IUSE="+gtk glade +python"
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
RDEPEND="
......@@ -22,10 +22,6 @@ RDEPEND="
>=dev-libs/gobject-introspection-1.39:=
glade? ( >=dev-util/glade-3.9.1:3.10 )
gtk? ( >=x11-libs/gtk+-3:3[introspection] )
lua? (
>=dev-lua/lgi-0.9.0
luajit? ( >=dev-lang/luajit-2:2 )
!luajit? ( =dev-lang/lua-5.1*:0 ) )
python? (
${PYTHON_DEPS}
>=dev-python/pygobject-3.2:3[${PYTHON_USEDEP}] )
......@@ -47,7 +43,6 @@ pkg_setup() {
src_prepare() {
# Gentoo uses unversioned lua - lua.pc instad of lua5.1.pc, /usr/bin/lua instead of /usr/bin/lua5.1
eapply "${FILESDIR}"/${PN}-1.14.0-lua.pc.patch
eautoreconf
gnome2_src_prepare
}
......@@ -64,9 +59,9 @@ src_configure() {
--disable-python2
$(use_enable python python3)
# lua
$(use_enable lua lua5.1)
$(use_enable $(usex luajit lua luajit) luajit)
--disable-lua5.1
--disable-luajit
)
gnome2_src_configure "${myconf[@]}"
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment