Commit 8f94614a authored by Luis Anton Rebollo's avatar Luis Anton Rebollo

Merge pull request #1169 from eightyeight/add-vagrant

Add Vagrant config
parents 19534b13 2416297b
# -*- mode: ruby -*-
# vi: set ft=ruby :
def gui?
!ENV.fetch('GUI', '').empty?
end
# Vagrantfile API/syntax version. Don't touch unless you know what you're doing!
VAGRANTFILE_API_VERSION = '2'
Vagrant.configure(VAGRANTFILE_API_VERSION) do |config|
config.vm.box = 'ubuntu/trusty64'
config.vm.provider 'virtualbox' do |vb|
vb.memory = 1024
if gui?
vb.memory = 2048
vb.customize ['modifyvm', :id, '--vram', '256']
vb.customize ['modifyvm', :id, '--accelerate3d', 'on']
vb.customize ['modifyvm', :id, '--hwvirtex', 'on']
vb.gui = true
end
end
config.vm.synced_folder '../../', '/torque'
config.vm.provision :shell, path: 'provision.sh'
if gui?
config.vm.provision :shell, path: 'provision-gui.sh'
end
# config.vm.network 'forwarded_port', guest: 80, host: 8080
# More info at http://fgrehm.viewdocs.io/vagrant-cachier/usage
if Vagrant.has_plugin?('vagrant-cachier')
config.cache.scope = :box
end
end
# Install Unity desktop for GUI purposes.
apt-get install --no-install-recommends \
ubuntu-desktop \
gnome-terminal \
-y
# Make sure package listings are up to date.
apt-get update -y
# Install software for development.
sudo apt-get install \
git \
build-essential \
nasm \
cmake \
cmake-qt-gui \
xorg-dev \
ninja-build \
gcc-multilib \
g++-multilib \
-y
# Install libraries.
sudo apt-get install \
libogg-dev \
libxft-dev \
libx11-dev \
libxxf86vm-dev \
libopenal-dev \
libfreetype6-dev \
libxcursor-dev \
libxinerama-dev \
libxi-dev \
libxrandr-dev \
libxss-dev \
libglu1-mesa-dev \
-y
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment