Skip to content
Snippets Groups Projects
Commit fbe61eb8 authored by Jan Beich's avatar Jan Beich
Browse files

x11-wm/theseus-ship: update to 6.1.0

Changes:	https://github.com/winft/theseus-ship/releases/tag/v6.1.0
Reported by:	GitHub (watch releases)
parent a8e6bc89
No related branches found
No related tags found
No related merge requests found
PORTNAME= theseus-ship
DISTVERSIONPREFIX= v
DISTVERSION= 6.0.0
DISTVERSION= 6.1.0
CATEGORIES= x11-wm # wayland: https://github.com/winft/theseus-ship/issues/9
MAINTAINER= jbeich@FreeBSD.org
......@@ -10,8 +10,6 @@ WWW= https://github.com/winft/theseus-ship
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/LICENSE
BROKEN= fails to build with como-0.2.0
LIB_DEPENDS= libepoxy.so:graphics/libepoxy \
libwayland-server.so:graphics/wayland \
libWraplandServer.so:graphics/wrapland \
......
TIMESTAMP = 1709039440
SHA256 (winft-theseus-ship-v6.0.0_GH0.tar.gz) = ffd8cf6c0b48cda918a74df372c55f42e00c9151420b4148b5e9f67ae05a05d5
SIZE (winft-theseus-ship-v6.0.0_GH0.tar.gz) = 2691337
TIMESTAMP = 1718822874
SHA256 (winft-theseus-ship-v6.1.0_GH0.tar.gz) = dd3bb31644636e4d3e855df36b4467b20312184ac2b5462594c211107f36824c
SIZE (winft-theseus-ship-v6.1.0_GH0.tar.gz) = 2693171
SHA256 (llvm-llvm-project-llvmorg-16.0.1_GH0.tar.gz) = b5a9ff1793b1e2d388a3819bf35797002b1d2e40bb35a10c65605e0ea1435271
SIZE (llvm-llvm-project-llvmorg-16.0.1_GH0.tar.gz) = 179289803
Drop after x11/plasma6-libplasma >= 6.1.0 update
Drop after x11-wm/plasma6-kdecoration >= 6.1.0
CMake Warning at CMakeLists.txt:59 (find_package):
Could not find a configuration file for package "Plasma" that is compatible
with requested version "6.1".
The following configuration files were considered but not accepted:
/usr/local/lib/cmake/Plasma/PlasmaConfig.cmake, version: 6.0.4
CMake Error at CMakeLists.txt:68 (find_package):
Could not find a configuration file for package "KDecoration2" that is
compatible with requested version "6.1".
The following configuration files were considered but not accepted:
/usr/local/lib/cmake/KDecoration2/KDecoration2Config.cmake, version: 6.0.4
kcms/decoration/declarative-plugin/buttonsmodel.cpp:72:32: error: no member named 'Spacer' in 'KDecoration2::DecorationButtonType'
case DecorationButtonType::Spacer:
~~~~~~~~~~~~~~~~~~~~~~^
kcms/decoration/declarative-plugin/buttonsmodel.cpp:72:32: error: no member named 'Spacer' in 'KDecoration2::DecorationButtonType'
case DecorationButtonType::Spacer:
~~~~~~~~~~~~~~~~~~~~~~^
kcms/decoration/utils.cpp:46:42: error: no member named 'Spacer' in 'KDecoration2::DecorationButtonType'
{KDecoration2::DecorationButtonType::Spacer, QChar('_')},
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~^
--- CMakeLists.txt.orig 2024-06-19 18:47:54 UTC
+++ CMakeLists.txt
@@ -56,7 +56,7 @@ set_package_properties(KF6Kirigami PROPERTIES
TYPE RUNTIME
)
-find_package(Plasma ${CMAKE_PROJECT_VERSION_MAJOR}.${CMAKE_PROJECT_VERSION_MINOR}
+find_package(Plasma ${CMAKE_PROJECT_VERSION_MAJOR}
CONFIG
)
set_package_properties(Plasma PROPERTIES
@@ -65,7 +65,7 @@ set_package_properties(Plasma PROPERTIES
TYPE RUNTIME
)
-find_package(KDecoration2 ${CMAKE_PROJECT_VERSION_MAJOR}.${CMAKE_PROJECT_VERSION_MINOR}
+find_package(KDecoration2 ${CMAKE_PROJECT_VERSION_MAJOR}
CONFIG REQUIRED
)
--- kcms/decoration/declarative-plugin/previewbutton.cpp.orig 2024-06-19 18:47:54 UTC
+++ kcms/decoration/declarative-plugin/previewbutton.cpp
@@ -121,12 +121,7 @@ void PreviewButtonItem::paint(QPainter* painter)
}
const QRect rect(0, 0, width(), height());
- if (type() == KDecoration2::DecorationButtonType::Spacer) {
- static const QIcon icon = QIcon::fromTheme(QStringLiteral("distribute-horizontal"));
- icon.paint(painter, rect);
- } else {
m_button->paint(painter, rect);
- }
painter->setCompositionMode(QPainter::CompositionMode_SourceAtop);
painter->fillRect(rect, m_color);
--- kcms/decoration/declarative-plugin/buttonsmodel.cpp.orig 2024-06-19 18:47:54 UTC
+++ kcms/decoration/declarative-plugin/buttonsmodel.cpp
@@ -32,7 +32,6 @@ ButtonsModel::ButtonsModel(QObject* parent)
DecorationButtonType::ContextHelp,
DecorationButtonType::KeepBelow,
DecorationButtonType::KeepAbove,
- DecorationButtonType::Spacer,
}),
parent)
{
@@ -69,8 +68,6 @@ static QString buttonToName(DecorationButtonType type)
return i18n("Keep below other windows");
case DecorationButtonType::KeepAbove:
return i18n("Keep above other windows");
- case DecorationButtonType::Spacer:
- return i18n("Spacer");
default:
return QString();
}
--- kcms/decoration/utils.cpp.orig 2024-06-19 18:47:54 UTC
+++ kcms/decoration/utils.cpp
@@ -43,7 +43,6 @@ const QHash<KDecoration2::DecorationButtonType, QChar>
{KDecoration2::DecorationButtonType::KeepAbove, QChar('F')},
{KDecoration2::DecorationButtonType::KeepBelow, QChar('B')},
{KDecoration2::DecorationButtonType::Shade, QChar('L')},
- {KDecoration2::DecorationButtonType::Spacer, QChar('_')},
};
}
......@@ -13,6 +13,8 @@ lib/libkcmkwincommon.so.%%VERSION%%
%%QT_PLUGINDIR%%/plasma/kcms/systemsettings_qwidgets/kcm_kwinscreenedges.so
%%QT_PLUGINDIR%%/plasma/kcms/systemsettings_qwidgets/kcm_kwintouchscreen.so
%%QT_PLUGINDIR%%/plasma/kcms/systemsettings_qwidgets/kwincompositing.so
%%QT_QMLDIR%%/org/kde/kwin/private/kdecoration/kde-qmlmodule.version
%%QT_QMLDIR%%/org/kde/kwin/private/kdecoration/kdecorationprivatedeclarative.qmltypes
%%QT_QMLDIR%%/org/kde/kwin/private/kdecoration/libkdecorationprivatedeclarative.so
%%QT_QMLDIR%%/org/kde/kwin/private/kdecoration/qmldir
libexec/kwin-applywindowdecoration
......
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Please register or to comment