Skip to content
Snippets Groups Projects
Commit fb107dc4 authored by Piotr Kubaj's avatar Piotr Kubaj
Browse files

graphics/mesa-libs: fix build on powerpc64le

Checking if "POWER8 intrinsics" compiles: NO

meson.build:720:6: ERROR: Problem encountered: POWER8 intrinsic support required but not found.
parent e37f7e5a
Branches
Tags
No related merge requests found
--- meson.build.orig 2023-09-20 17:15:34 UTC
+++ meson.build
@@ -709,7 +709,7 @@ if _power8.allowed()
int main() {
vector unsigned char r;
vector unsigned int v = vec_splat_u32 (1);
- r = __builtin_vec_vgbbd ((vector unsigned char) v);
+ r = __builtin_altivec_vgbbd ((vector unsigned char) v);
return 0;
}''',
args : '-mpower8-vector',
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Please register or to comment