Skip to content
Snippets Groups Projects
Commit faae5c3e authored by Muhammad Moinur Rahman's avatar Muhammad Moinur Rahman
Browse files

net/ipsvd: Remove expired port

2023-12-31 net/ipsvd: bogus assumption of system type widths, likely crash-prone
parent e537589f
No related branches found
No related tags found
No related merge requests found
......@@ -8197,3 +8197,4 @@ emulators/gngeo||2023-12-31|Has expired: BROKEN for more that 2 years after the
net/rp-pppoe||2023-12-31|Has expired: Upstream restricting future OS support to Linux. Use net/mpd5 or pppoed instead. https://dianne.skoll.ca/pipermail/rp-pppoe/2023q2/000639.html
net/spread4||2023-12-31|Has expired: BROKEN on all supported versions after the EOL of 12
net/quiterss||2023-12-31|Has expired: Depends on deprecated www/qt5-webkit
net/ipsvd||2023-12-31|Has expired: bogus assumption of system type widths, likely crash-prone
......@@ -285,7 +285,6 @@
SUBDIR += ipgrab
SUBDIR += ipinfo-cli
SUBDIR += ipsumdump
SUBDIR += ipsvd
SUBDIR += ipxe
SUBDIR += irrd
SUBDIR += isboot-kmod
......
PORTNAME= ipsvd
PORTVERSION= 1.0.0
PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= http://smarden.org/ipsvd/
MAINTAINER= ports@FreeBSD.org
COMMENT= Internet protocol service daemons
WWW= http://smarden.org/ipsvd/
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/package/COPYING
DEPRECATED= bogus assumption of system type widths, likely crash-prone
EXPIRATION_DATE=2023-12-31
BROKEN_armv6= fails to install: Checking udpsvd... drop: unable to read from socket: bad address
BROKEN_armv7= fails to install: Checking udpsvd... drop: unable to read from socket: bad address
BROKEN_mips64= fails to install: tcpsvd failed
BROKEN_riscv64= fails to install: Checking udpsvd... drop: unable to read from socket: bad address
USE_CSTD= c89
ALL_TARGET= default
WRKSRC= ${WRKDIR}/net/${DISTNAME}
DOCS= package/CHANGES package/COPYING package/README doc/*.html
OPTIONS_DEFINE= DOCS
.include <bsd.port.options.mk>
.if ${OPSYS} == FreeBSD && ( ${OSVERSION} >= 1400091 || ( ${OSVERSION} >= 1302507 && ${OSVERSION} < 1400000 ))
CFLAGS+= -Wno-error=incompatible-function-pointer-types
.endif
do-configure:
@${ECHO_CMD} "${CC} ${CFLAGS} -include unistd.h" > ${WRKSRC}/src/conf-cc
@${ECHO_CMD} "${CC} ${LDFLAGS}" > ${WRKSRC}/src/conf-ld
@${ECHO_CMD} "${LOCALBASE}/include/libdjbdns" \
> ${WRKSRC}/src/conf-djbdnsinc
@${ECHO_CMD} "${LOCALBASE}/lib" > ${WRKSRC}/src/conf-djbdnslib
do-build:
cd ${WRKSRC} && package/compile && package/check
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/command/* ${STAGEDIR}${PREFIX}/sbin
.for n in 5 7 8
${INSTALL_MAN} ${WRKSRC}/man/*.${n} ${STAGEDIR}${MANPREFIX}/man/man${n}
.endfor
do-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
(cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${STAGEDIR}${DOCSDIR})
.include <bsd.port.mk>
SHA256 (ipsvd-1.0.0.tar.gz) = ef7a725bc85acb5d09ab57658385bb470b3e4da5a4ffc88b5da6c6bd37d01fad
SIZE (ipsvd-1.0.0.tar.gz) = 77903
--- src/udpsvd.c.orig 2008-06-15 20:31:14 UTC
+++ src/udpsvd.c
@@ -268,7 +268,7 @@ int main(int argc, const char **argv, const char *cons
if (user) {
bufnum[fmt_ulong(bufnum, ugid.uid)] =0;
out(", uid "); out(bufnum);
- bufnum[fmt_ulong(bufnum, ugid.gid)] =0;
+ bufnum[fmt_ulong(bufnum, ugid.gid[0])] =0;
out(", gid "); out(bufnum);
}
flush(", starting.\n");
ipsvd is a set of internet protocol service daemons.
It currently includes a TCP/IP service daemon, and a UDP/IP service daemon.
An internet protocol service (ipsv) daemon waits for incoming connections
on a local socket. On incoming connections, the ipsv daemon conditionally
runs an arbitrary program with standard input reading from the socket, and
standard output writing to the socket, that handles the connection.
Standard error is used for logging.
ipsv daemons can be told to read and follow pre-defined instructions on
how to handle incoming connections. It's possible to run different
programs, or to set a different environment, or to deny a connection, or
to set a per host concurrency limit, depending on the client's address or
hostname.
Normally the ipsv daemons are run by a supervisor process, such as runsv
from the runit package, or supervise from the daemontools package.
ipsvd can be used to run services normally run by inetd, xinetd, or tcpserver.
sbin/ipsvd-cdb
sbin/tcpsvd
sbin/udpsvd
man/man5/ipsvd-instruct.5.gz
man/man7/ipsvd.7.gz
man/man8/ipsvd-cdb.8.gz
man/man8/sslio.8.gz
man/man8/sslsvd.8.gz
man/man8/tcpsvd.8.gz
man/man8/udpsvd.8.gz
%%PORTDOCS%%%%DOCSDIR%%/CHANGES
%%PORTDOCS%%%%DOCSDIR%%/COPYING
%%PORTDOCS%%%%DOCSDIR%%/README
%%PORTDOCS%%%%DOCSDIR%%/benefits.html
%%PORTDOCS%%%%DOCSDIR%%/examples.html
%%PORTDOCS%%%%DOCSDIR%%/index.html
%%PORTDOCS%%%%DOCSDIR%%/install.html
%%PORTDOCS%%%%DOCSDIR%%/ipsvd-cdb.8.html
%%PORTDOCS%%%%DOCSDIR%%/ipsvd-instruct.5.html
%%PORTDOCS%%%%DOCSDIR%%/ipsvd.7.html
%%PORTDOCS%%%%DOCSDIR%%/sslio.8.html
%%PORTDOCS%%%%DOCSDIR%%/sslsvd.8.html
%%PORTDOCS%%%%DOCSDIR%%/tcpsvd.8.html
%%PORTDOCS%%%%DOCSDIR%%/udpsvd.8.html
%%PORTDOCS%%%%DOCSDIR%%/upgrade.html
%%PORTDOCS%%%%DOCSDIR%%/usedietlibc.html
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment