Skip to content
Snippets Groups Projects
Unverified Commit f1f155ee authored by Li-Wen Hsu's avatar Li-Wen Hsu
Browse files

net-im/py-matrix-synapse: Update to 1.82.0

PR:             270737
Approved by:	maintainer timeout
parent 886b412d
No related branches found
No related tags found
No related merge requests found
PORTNAME= matrix-synapse
DISTVERSION= 1.80.0
PORTREVISION= 1
DISTVERSION= 1.82.0
CATEGORIES= net-im python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
......@@ -16,12 +15,12 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}poetry-core>=1.0.0:devel/py-poetry-core@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}setuptools-rust>=1.3:devel/py-setuptools-rust@${PY_FLAVOR}
# Keep the RUN_DEPENDS layout similar to the master/synapse/python_dependencies.py file
# Keep the RUN_DEPENDS layout similar to the pyproject.toml file
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}jsonschema>=3.0.0:devel/py-jsonschema@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}frozendict>=1:devel/py-frozendict@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}immutabledict>=2.0:devel/py-immutabledict@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}unpaddedbase64>=2.1.0:devel/py-unpaddedbase64@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}canonicaljson>=1.5.0:devel/py-canonicaljson@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}signedjson>=1.1.0:security/py-signedjson@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}canonicaljson>=2.0.0<3.0.0:devel/py-canonicaljson@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}signedjson>=1.1.0<2.0.0:security/py-signedjson@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}service_identity>=18.1.0:security/py-service_identity@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}twisted>=18.9.0:devel/py-twisted@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}treq>=15.1:www/py-treq@${PY_FLAVOR} \
......@@ -32,7 +31,6 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}jsonschema>=3.0.0:devel/py-jsonschema@${PY_F
${PYTHON_PKGNAMEPREFIX}bcrypt>=3.1.7:security/py-bcrypt@${PY_FLAVOR} \
${PY_PILLOW} \
${PYTHON_PKGNAMEPREFIX}sortedcontainers>=1.5.2:devel/py-sortedcontainers@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pysaml2>=4.5.0:security/py-pysaml2@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pymacaroons>=0.13.0:security/py-pymacaroons@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}msgpack>=0.5.2:devel/py-msgpack@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}phonenumbers>=8.2.0:devel/py-phonenumbers@${PY_FLAVOR} \
......@@ -42,11 +40,12 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}jsonschema>=3.0.0:devel/py-jsonschema@${PY_F
${PYTHON_PKGNAMEPREFIX}Jinja2>=3.0.0:devel/py-Jinja2@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}bleach>=1.4.3:www/py-bleach@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}typing-extensions>=3.10.0.1:devel/py-typing-extensions@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}cryptography>=0:security/py-cryptography@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}cryptography>=3.4.7:security/py-cryptography@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}ijson>=3.1.4:devel/py-ijson@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}matrix-common>=1.3.0<2.0.0:devel/py-matrix-common@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}packaging>=16.1:devel/py-packaging@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}matrix-common>=1.3.0:devel/py-matrix-common@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pydantic>=1.7.4:devel/py-pydantic@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pysaml2>=4.5.0:security/py-pysaml2@${PY_FLAVOR} \
${LOCALBASE}/share/certs/ca-root-nss.crt:security/ca_root_nss
TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}virtualenv>=15.0:devel/py-virtualenv@${PY_FLAVOR} \
......@@ -65,61 +64,6 @@ CARGO_BUILD= no
CARGO_TEST= no
CARGO_INSTALL= no
CARGO_CARGOTOML= ${WRKSRC}/rust/Cargo.toml
CARGO_CRATES= aho-corasick-0.7.19 \
anyhow-1.0.70 \
arc-swap-1.5.1 \
autocfg-1.1.0 \
bitflags-1.3.2 \
blake2-0.10.6 \
block-buffer-0.10.3 \
cfg-if-1.0.0 \
crypto-common-0.1.6 \
digest-0.10.5 \
generic-array-0.14.6 \
hex-0.4.3 \
indoc-1.0.7 \
itoa-1.0.4 \
lazy_static-1.4.0 \
libc-0.2.135 \
lock_api-0.4.9 \
log-0.4.17 \
memchr-2.5.0 \
memoffset-0.6.5 \
once_cell-1.15.0 \
parking_lot-0.12.1 \
parking_lot_core-0.9.3 \
proc-macro2-1.0.52 \
pyo3-0.17.3 \
pyo3-build-config-0.17.3 \
pyo3-ffi-0.17.3 \
pyo3-log-0.8.1 \
pyo3-macros-0.17.3 \
pyo3-macros-backend-0.17.3 \
pythonize-0.17.0 \
quote-1.0.26 \
redox_syscall-0.2.16 \
regex-1.7.1 \
regex-syntax-0.6.27 \
ryu-1.0.11 \
scopeguard-1.1.0 \
serde-1.0.157 \
serde_derive-1.0.157 \
serde_json-1.0.94 \
smallvec-1.10.0 \
subtle-2.4.1 \
syn-1.0.104 \
syn-2.0.2 \
target-lexicon-0.12.4 \
typenum-1.15.0 \
unicode-ident-1.0.5 \
unindent-0.1.10 \
version_check-0.9.4 \
windows-sys-0.36.1 \
windows_aarch64_msvc-0.36.1 \
windows_i686_gnu-0.36.1 \
windows_i686_msvc-0.36.1 \
windows_x86_64_gnu-0.36.1 \
windows_x86_64_msvc-0.36.1
SUB_FILES= pkg-message log.config
SUB_LIST= PYTHON_CMD=${PYTHON_CMD} DBDIR=${DBDIR} LOGDIR=${LOGDIR} PIDDIR=${PIDDIR} USERS=${USERS}
......
CARGO_CRATES= aho-corasick-0.7.19 \
anyhow-1.0.70 \
arc-swap-1.5.1 \
autocfg-1.1.0 \
bitflags-1.3.2 \
blake2-0.10.6 \
block-buffer-0.10.3 \
cfg-if-1.0.0 \
crypto-common-0.1.6 \
digest-0.10.5 \
generic-array-0.14.6 \
hex-0.4.3 \
indoc-1.0.7 \
itoa-1.0.4 \
lazy_static-1.4.0 \
libc-0.2.135 \
lock_api-0.4.9 \
log-0.4.17 \
memchr-2.5.0 \
memoffset-0.6.5 \
once_cell-1.15.0 \
parking_lot-0.12.1 \
parking_lot_core-0.9.3 \
proc-macro2-1.0.52 \
pyo3-0.17.3 \
pyo3-build-config-0.17.3 \
pyo3-ffi-0.17.3 \
pyo3-log-0.8.1 \
pyo3-macros-0.17.3 \
pyo3-macros-backend-0.17.3 \
pythonize-0.17.0 \
quote-1.0.26 \
redox_syscall-0.2.16 \
regex-1.7.3 \
regex-syntax-0.6.29 \
ryu-1.0.11 \
scopeguard-1.1.0 \
serde-1.0.160 \
serde_derive-1.0.160 \
serde_json-1.0.96 \
smallvec-1.10.0 \
subtle-2.4.1 \
syn-1.0.104 \
syn-2.0.10 \
target-lexicon-0.12.4 \
typenum-1.15.0 \
unicode-ident-1.0.5 \
unindent-0.1.10 \
version_check-0.9.4 \
windows-sys-0.36.1 \
windows_aarch64_msvc-0.36.1 \
windows_i686_gnu-0.36.1 \
windows_i686_msvc-0.36.1 \
windows_x86_64_gnu-0.36.1 \
windows_x86_64_msvc-0.36.1
TIMESTAMP = 1680052681
SHA256 (matrix_synapse-1.80.0.tar.gz) = 16c6df16dfa0d3061bfd9ebee8b6e6935756d35cee32f08ffd831db4624cf031
SIZE (matrix_synapse-1.80.0.tar.gz) = 3167250
TIMESTAMP = 1682497261
SHA256 (matrix_synapse-1.82.0.tar.gz) = 593a72fbb6d18100a6dc837aa8420128ebdd32ffd77a9c2daaf4eb550a6358e7
SIZE (matrix_synapse-1.82.0.tar.gz) = 3158269
SHA256 (rust/crates/aho-corasick-0.7.19.crate) = b4f55bd91a0978cbfd91c457a164bab8b4001c833b7f323132c0a4e1922dd44e
SIZE (rust/crates/aho-corasick-0.7.19.crate) = 113070
SHA256 (rust/crates/anyhow-1.0.70.crate) = 7de8ce5e0f9f8d88245311066a578d72b7af3e7088f32783804676302df237e4
......@@ -67,28 +67,28 @@ SHA256 (rust/crates/quote-1.0.26.crate) = 4424af4bf778aae2051a77b60283332f386554
SIZE (rust/crates/quote-1.0.26.crate) = 28397
SHA256 (rust/crates/redox_syscall-0.2.16.crate) = fb5a58c1855b4b6819d59012155603f0b22ad30cad752600aadfcb695265519a
SIZE (rust/crates/redox_syscall-0.2.16.crate) = 24012
SHA256 (rust/crates/regex-1.7.1.crate) = 48aaa5748ba571fb95cd2c85c09f629215d3a6ece942baa100950af03a34f733
SIZE (rust/crates/regex-1.7.1.crate) = 239648
SHA256 (rust/crates/regex-syntax-0.6.27.crate) = a3f87b73ce11b1619a3c6332f45341e0047173771e8b8b73f87bfeefb7b56244
SIZE (rust/crates/regex-syntax-0.6.27.crate) = 297300
SHA256 (rust/crates/regex-1.7.3.crate) = 8b1f693b24f6ac912f4893ef08244d70b6067480d2f1a46e950c9691e6749d1d
SIZE (rust/crates/regex-1.7.3.crate) = 239886
SHA256 (rust/crates/regex-syntax-0.6.29.crate) = f162c6dd7b008981e4d40210aca20b4bd0f9b60ca9271061b07f78537722f2e1
SIZE (rust/crates/regex-syntax-0.6.29.crate) = 299752
SHA256 (rust/crates/ryu-1.0.11.crate) = 4501abdff3ae82a1c1b477a17252eb69cee9e66eb915c1abaa4f44d873df9f09
SIZE (rust/crates/ryu-1.0.11.crate) = 47007
SHA256 (rust/crates/scopeguard-1.1.0.crate) = d29ab0c6d3fc0ee92fe66e2d99f700eab17a8d57d1c1d3b748380fb20baa78cd
SIZE (rust/crates/scopeguard-1.1.0.crate) = 11470
SHA256 (rust/crates/serde-1.0.157.crate) = 707de5fcf5df2b5788fca98dd7eab490bc2fd9b7ef1404defc462833b83f25ca
SIZE (rust/crates/serde-1.0.157.crate) = 77012
SHA256 (rust/crates/serde_derive-1.0.157.crate) = 78997f4555c22a7971214540c4a661291970619afd56de19f77e0de86296e1e5
SIZE (rust/crates/serde_derive-1.0.157.crate) = 54958
SHA256 (rust/crates/serde_json-1.0.94.crate) = 1c533a59c9d8a93a09c6ab31f0fd5e5f4dd1b8fc9434804029839884765d04ea
SIZE (rust/crates/serde_json-1.0.94.crate) = 144406
SHA256 (rust/crates/serde-1.0.160.crate) = bb2f3770c8bce3bcda7e149193a069a0f4365bda1fa5cd88e03bca26afc1216c
SIZE (rust/crates/serde-1.0.160.crate) = 77010
SHA256 (rust/crates/serde_derive-1.0.160.crate) = 291a097c63d8497e00160b166a967a4a79c64f3facdd01cbd7502231688d77df
SIZE (rust/crates/serde_derive-1.0.160.crate) = 55081
SHA256 (rust/crates/serde_json-1.0.96.crate) = 057d394a50403bcac12672b2b18fb387ab6d289d957dab67dd201875391e52f1
SIZE (rust/crates/serde_json-1.0.96.crate) = 144652
SHA256 (rust/crates/smallvec-1.10.0.crate) = a507befe795404456341dfab10cef66ead4c041f62b8b11bbb92bffe5d0953e0
SIZE (rust/crates/smallvec-1.10.0.crate) = 31564
SHA256 (rust/crates/subtle-2.4.1.crate) = 6bdef32e8150c2a081110b42772ffe7d7c9032b606bc226c8260fd97e0976601
SIZE (rust/crates/subtle-2.4.1.crate) = 12630
SHA256 (rust/crates/syn-1.0.104.crate) = 4ae548ec36cf198c0ef7710d3c230987c2d6d7bd98ad6edc0274462724c585ce
SIZE (rust/crates/syn-1.0.104.crate) = 236683
SHA256 (rust/crates/syn-2.0.2.crate) = 59d3276aee1fa0c33612917969b5172b5be2db051232a6e4826f1a1a9191b045
SIZE (rust/crates/syn-2.0.2.crate) = 240038
SHA256 (rust/crates/syn-2.0.10.crate) = 5aad1363ed6d37b84299588d62d3a7d95b5a5c2d9aad5c85609fda12afaa1f40
SIZE (rust/crates/syn-2.0.10.crate) = 240095
SHA256 (rust/crates/target-lexicon-0.12.4.crate) = c02424087780c9b71cc96799eaeddff35af2bc513278cda5c99fc1f5d026d3c1
SIZE (rust/crates/target-lexicon-0.12.4.crate) = 23020
SHA256 (rust/crates/typenum-1.15.0.crate) = dcf81ac59edc17cc8697ff311e8f5ef2d99fcbd9817b34cec66f90b6c3dfd987
......
--- pyproject.toml.orig 2023-03-28 10:30:20 UTC
--- pyproject.toml.orig 2023-04-21 21:40:26 UTC
+++ pyproject.toml
@@ -156,7 +156,7 @@ jsonschema = ">=3.0.0"
# frozendict 2.1.2 is broken on Debian 10: https://github.com/Marco-Sulla/python-frozendict/issues/41
# We cannot test our wheels against the 2.3.5 release in CI. Putting in an upper bound for this
# because frozendict has been more trouble than it's worth; we would like to move to immutabledict.
-frozendict = ">=1,!=2.1.2,<2.3.5"
+frozendict = ">=1"
# We require 2.1.0 or higher for type hints. Previous guard was >= 1.1.0
unpaddedbase64 = ">=2.1.0"
# We require 1.5.0 to work around an issue when running against the C implementation of
@@ -199,7 +199,7 @@ bleach = ">=1.4.3"
typing-extensions = ">=3.10.0.1"
# We enforce that we have a `cryptography` version that bundles an `openssl`
# with the latest security patches.
-cryptography = ">=3.4.7"
+cryptography = "*"
# ijson 3.1.4 fixes a bug with "." in property names
ijson = ">=3.1.4"
matrix-common = "^1.3.0"
@@ -210,17 +210,6 @@ packaging = ">=16.1"
importlib_metadata = { version = ">=1.4", python = "<3.8" }
# This is the most recent version of Pydantic with available on common distros.
pydantic = ">=1.7.4"
-
-# This is for building the rust components during "poetry install", which
-# currently ignores the `build-system.requires` directive (c.f.
-# https://github.com/python-poetry/poetry/issues/6154). Both `pip install` and
-# `poetry build` do the right thing without this explicit dependency.
-#
-# This isn't really a dev-dependency, as `poetry install --no-dev` will fail,
-# but the alternative is to add it to the main list of deps where it isn't
-# needed.
-setuptools_rust = ">=1.3"
-
@@ -219,7 +219,6 @@ pydantic = ">=1.7.4"
# needed.
setuptools_rust = ">=1.3"
-
# Optional Dependencies
# ---------------------
matrix-synapse-ldap3 = { version = ">=0.1", optional = true }
--- setup.py.orig 1970-01-01 00:00:00 UTC
--- setup.py.orig 2023-04-21 21:41:33 UTC
+++ setup.py
@@ -154,8 +154,8 @@ install_requires = \
'bcrypt>=3.1.7',
'bleach>=1.4.3',
'canonicaljson>=1.5.0,<2.0.0',
- 'cryptography>=3.4.7',
- 'frozendict>=1,!=2.1.2,<2.3.5',
+ 'cryptography',
+ 'frozendict>=1',
'ijson>=3.1.4',
'jsonschema>=3.0.0',
'matrix-common>=1.3.0,<2.0.0',
@@ -170,7 +170,6 @@ install_requires = \
'pydantic>=1.7.4',
'pymacaroons>=0.13.0',
......
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment