Skip to content
Snippets Groups Projects
Commit ed154877 authored by Michael Reifenberger's avatar Michael Reifenberger
Browse files

cad/kicad-devel: Update to latest commit

parent b08a7396
No related branches found
No related tags found
No related merge requests found
......@@ -53,7 +53,7 @@ SHEBANG_FILES= pcbnew/python/plugins/touch_slider_wizard.py
CMAKE_ARGS= -DLOCALBASE="${LOCALBASE}" \
-DCMAKE_BUILD_TYPE="Debug" \
-DKICAD_TESTING_VERSION=ON \
-DKICAD_BUILD_VERSION=${DISTVERSION} \
-DKICAD_VERSION=${DISTVERSION} \
-DCMAKE_INCLUDE_PATH="${WRKSRC}/include ${LOCALBASE}/include" \
-DwxWidgets_CONFIG_EXECUTABLE="${WX_CONFIG}" \
-DwxWidgets_USE_DEBUG=ON \
......
GIT_SRC_HASH= f88be65825d8f23379b55f333a2b7054bea01c58
GIT_SRC_DATE= 20210215215911
GIT_SRC_HASH= 1c3df973d6a480277f0853caad0e7e255981c929
GIT_SRC_DATE= 20210610134502
TIMESTAMP = 1617884322
SHA256 (kicad/kicad/code-kicad-f88be65825d8f23379b55f333a2b7054bea01c58_GL0.tar.gz) = e15acbc8730f779ab5736bb69117558a3da283b2001b0720b2e30b4b94a15e90
SIZE (kicad/kicad/code-kicad-f88be65825d8f23379b55f333a2b7054bea01c58_GL0.tar.gz) = 33377789
TIMESTAMP = 1623329556
SHA256 (kicad/kicad/code-kicad-1c3df973d6a480277f0853caad0e7e255981c929_GL0.tar.gz) = 7b7e5bcd537ba0e854d32ddc2461eee25c2ce14dcd526c820dc7ac51e462fbbc
SIZE (kicad/kicad/code-kicad-1c3df973d6a480277f0853caad0e7e255981c929_GL0.tar.gz) = 35907193
--- 3d-viewer/3d_rendering/legacy/3d_model.cpp.orig 2021-06-08 11:48:08 UTC
+++ 3d-viewer/3d_rendering/legacy/3d_model.cpp
@@ -488,7 +488,7 @@ void MODEL_3D::DrawBbox() const
reinterpret_cast<const void*>( offsetof( VERTEX, m_color ) ) );
glDrawElements( GL_LINES, bbox_idx_count, m_bbox_index_buffer_type,
- reinterpret_cast<const void*>( NULL ) );
+ reinterpret_cast<const void*>( 0 ) );
}
--- CMakeLists.txt.orig 2019-03-11 16:59:38.982264000 +0100
+++ CMakeLists.txt 2019-03-11 17:00:47.354215000 +0100
@@ -668,8 +668,8 @@ if( KICAD_SCRIPTING OR KICAD_SCRIPTING_MODULES )
set( PythonLibs_FIND_VERSION 3.3 )
else()
# force a python version < 3.0
- set( PythonInterp_FIND_VERSION 2.6 )
- set( PythonLibs_FIND_VERSION 2.6 )
+ set( PythonInterp_FIND_VERSION 2.7 )
+ set( PythonLibs_FIND_VERSION 2.7 )
endif()
find_package( PythonInterp )
@@ -711,7 +711,7 @@ if( KICAD_SCRIPTING OR KICAD_SCRIPTING_MODULES )
if( KICAD_SCRIPTING_PYTHON3 )
find_package( PythonLibs 3.3 REQUIRED )
else()
- find_package( PythonLibs 2.6 REQUIRED )
+ find_package( PythonLibs 2.7 REQUIRED )
endif()
if( KICAD_SCRIPTING_WXPYTHON )
--- include/gal/graphics_abstraction_layer.h.orig 2016-04-16 13:14:32.003824016 +0200
+++ include/gal/graphics_abstraction_layer.h 2016-04-16 13:15:06.143789160 +0200
@@ -31,4 +31,5 @@
--- include/gal/graphics_abstraction_layer.h.orig 2021-06-08 00:34:09 UTC
+++ include/gal/graphics_abstraction_layer.h
@@ -30,6 +30,7 @@
#include <deque>
#include <stack>
#include <limits>
+#include <cmath>
#include <math/matrix3x3.h>
--- include/kiway.h.orig 2015-01-10 18:11:39.000000000 +0000
+++ include/kiway.h 2015-01-11 10:51:52.458174797 +0000
@@ -115,5 +115,5 @@
--- include/kiway.h.orig 2021-06-08 00:34:09 UTC
+++ include/kiway.h
@@ -113,7 +113,7 @@
#define KIFACE_INSTANCE_NAME_AND_VERSION "KIFACE_1"
#ifndef SWIG
-#if defined(__linux__) || defined(__FreeBSD__)
+#if defined(__linux__) || defined(__FreeBSD__) || defined(__DragonFly__)
#define LIB_ENV_VAR wxT( "LD_LIBRARY_PATH" )
#elif defined(__WXMAC__)
#define LIB_ENV_VAR wxT( "DYLD_LIBRARY_PATH" )
bin/_cvpcb.kiface
bin/_eeschema.kiface
bin/_gerbview.kiface
bin/_kipython.kiface
bin/_pcb_calculator.kiface
bin/_pcbnew.kiface
bin/_pl_editor.kiface
......@@ -23,13 +24,12 @@ lib/libkicad_3dsg.so
lib/libkicad_3dsg.so.2.0.0
%%PYTHON_SITELIBDIR%%/_pcbnew.so
%%PYTHON_SITELIBDIR%%/pcbnew.py
share/appdata/kicad.appdata.xml
%%DESKTOPDIR%%/bitmap2component.desktop
%%DESKTOPDIR%%/eeschema.desktop
%%DESKTOPDIR%%/gerbview.desktop
%%DESKTOPDIR%%/kicad.desktop
%%DESKTOPDIR%%/pcbcalculator.desktop
%%DESKTOPDIR%%/pcbnew.desktop
%%DESKTOPDIR%%/org.kicad.bitmap2component.desktop
%%DESKTOPDIR%%/org.kicad.eeschema.desktop
%%DESKTOPDIR%%/org.kicad.gerbview.desktop
%%DESKTOPDIR%%/org.kicad.kicad.desktop
%%DESKTOPDIR%%/org.kicad.pcbcalculator.desktop
%%DESKTOPDIR%%/org.kicad.pcbnew.desktop
%%PORTDOCS%%%%DOCSDIR%%/scripts/lib_convert.py
%%PORTDOCS%%%%DOCSDIR%%/scripts/test_kicad_plugin.py
%%PORTDOCS%%%%DOCSDIR%%/scripts/test_plugin.py
......@@ -97,12 +97,10 @@ share/icons/hicolor/scalable/mimetypes/application-x-kicad-pcb.svg
share/icons/hicolor/scalable/mimetypes/application-x-kicad-project.svg
share/icons/hicolor/scalable/mimetypes/application-x-kicad-schematic.svg
%%DATADIR%%/demos/complex_hierarchy/ampli_ht.kicad_sch
%%DATADIR%%/demos/complex_hierarchy/complex_hierarchy-cache.lib
%%DATADIR%%/demos/complex_hierarchy/complex_hierarchy.kicad_pcb
%%DATADIR%%/demos/complex_hierarchy/complex_hierarchy.kicad_pro
%%DATADIR%%/demos/complex_hierarchy/complex_hierarchy.kicad_sch
%%DATADIR%%/demos/complex_hierarchy/complex_hierarchy_schlib.kicad_sym
%%DATADIR%%/demos/complex_hierarchy/complex_hierarchy_schlib.lib
%%DATADIR%%/demos/complex_hierarchy/fp-lib-table
%%DATADIR%%/demos/complex_hierarchy/sym-lib-table
%%DATADIR%%/demos/custom_pads_test/custom_pads_schlib.kicad_sym
......@@ -171,7 +169,7 @@ share/icons/hicolor/scalable/mimetypes/application-x-kicad-schematic.svg
%%DATADIR%%/demos/kit-dev-coldfire-xilinx_5213/sym-lib-table
%%DATADIR%%/demos/kit-dev-coldfire-xilinx_5213/xilinx.kicad_sch
%%DATADIR%%/demos/microwave/microwave.kicad_pcb
%%DATADIR%%/demos/microwave/microwave.pro
%%DATADIR%%/demos/microwave/microwave.kicad_pro
%%DATADIR%%/demos/microwave/shape1.txt
%%DATADIR%%/demos/pic_programmer/fp-lib-table
%%DATADIR%%/demos/pic_programmer/libs/3d_shapes/adjustable_rx2v4.wrl
......@@ -230,6 +228,25 @@ share/icons/hicolor/scalable/mimetypes/application-x-kicad-schematic.svg
%%DATADIR%%/demos/stickhub/StickHub.kicad_pcb
%%DATADIR%%/demos/stickhub/StickHub.kicad_pro
%%DATADIR%%/demos/stickhub/StickHub.kicad_sch
%%DATADIR%%/demos/stickhub/footprints.pretty/1005_C.kicad_mod
%%DATADIR%%/demos/stickhub/footprints.pretty/1006_C.kicad_mod
%%DATADIR%%/demos/stickhub/footprints.pretty/1608_C.kicad_mod
%%DATADIR%%/demos/stickhub/footprints.pretty/1P-1.5x1.5.kicad_mod
%%DATADIR%%/demos/stickhub/footprints.pretty/2012_C.kicad_mod
%%DATADIR%%/demos/stickhub/footprints.pretty/CP_Elec_6.3x11_Board_Edge_Mirrored.kicad_mod
%%DATADIR%%/demos/stickhub/footprints.pretty/Creative_Commons_BY_Mask.kicad_mod
%%DATADIR%%/demos/stickhub/footprints.pretty/Creative_Commons_CC_Mask.kicad_mod
%%DATADIR%%/demos/stickhub/footprints.pretty/Creative_Commons_NC_Mask.kicad_mod
%%DATADIR%%/demos/stickhub/footprints.pretty/Creative_Commons_SA_Mask.kicad_mod
%%DATADIR%%/demos/stickhub/footprints.pretty/Crystal_4-SMD_2.5x2mm.kicad_mod
%%DATADIR%%/demos/stickhub/footprints.pretty/Duo_LED_1.6x0.8_Kingbright_APHB1608LZGKSURKC.kicad_mod
%%DATADIR%%/demos/stickhub/footprints.pretty/JP-2_1.5x1.5.kicad_mod
%%DATADIR%%/demos/stickhub/footprints.pretty/JST_SH_SM04B-SRSS-TB_1x04-1MP_P1.00mm_Horizontal.kicad_mod
%%DATADIR%%/demos/stickhub/footprints.pretty/LQFP-48_7x7mm_P0.5mm.kicad_mod
%%DATADIR%%/demos/stickhub/footprints.pretty/Plain_Hole_3mm.kicad_mod
%%DATADIR%%/demos/stickhub/footprints.pretty/TDFN-8_1.5x2mm_Fused-Lead_JEDEC_MO-252_W2015D.kicad_mod
%%DATADIR%%/demos/stickhub/footprints.pretty/USB_A_PCB_traces_small.kicad_mod
%%DATADIR%%/demos/stickhub/fp-lib-table
%%DATADIR%%/demos/stickhub/sym-lib-table
%%DATADIR%%/demos/test_pads_inside_pads/sym-lib-table
%%DATADIR%%/demos/test_pads_inside_pads/test_pads_inside_pads.kicad_pcb
......@@ -244,7 +261,6 @@ share/icons/hicolor/scalable/mimetypes/application-x-kicad-schematic.svg
%%DATADIR%%/demos/test_xil_95108/sym-lib-table
%%DATADIR%%/demos/video/bus_pci.kicad_sch
%%DATADIR%%/demos/video/esvideo.kicad_sch
%%DATADIR%%/demos/video/esvideo.sch
%%DATADIR%%/demos/video/fp-lib-table
%%DATADIR%%/demos/video/graphic.kicad_sch
%%DATADIR%%/demos/video/libs/footprints.pretty/CV3-30PF.kicad_mod
......@@ -273,14 +289,16 @@ share/icons/hicolor/scalable/mimetypes/application-x-kicad-schematic.svg
%%DATADIR%%/plugins/bom_csv_sorted_by_ref.py
%%DATADIR%%/plugins/bom_html_grouped_by_value.py
%%DATADIR%%/plugins/bom_html_with_advanced_grouping.py
%%DATADIR%%/plugins/bom_sorted_by_ref.py
%%DATADIR%%/plugins/bom_txt_sorted_by_ref.py
%%DATADIR%%/plugins/bom_with_title_block_2_csv.xsl
%%DATADIR%%/plugins/kicad_netlist_reader.py
%%DATADIR%%/plugins/netlist_form_OrcadPcb2.xsl
%%DATADIR%%/plugins/netlist_form_cadstar-RINF.xsl
%%DATADIR%%/plugins/netlist_form_cadstar.xsl
%%DATADIR%%/plugins/netlist_form_pads-pcb.asc.xsl
%%DATADIR%%/resources/images.tar.gz
%%DATADIR%%/scripting/kicad_pyshell/__init__.py
%%DATADIR%%/scripting/kicad_pyshell/kicad_pyeditor.py
%%DATADIR%%/scripting/plugins/FPC_wizard.py
%%DATADIR%%/scripting/plugins/FootprintWizardBase.py
%%DATADIR%%/scripting/plugins/PadArray.py
......@@ -298,5 +316,6 @@ share/icons/hicolor/scalable/mimetypes/application-x-kicad-schematic.svg
%%DATADIR%%/scripting/plugins/uss39_barcode.py
%%DATADIR%%/scripting/plugins/zip_wizard.py
%%DATADIR%%/template/kicad.kicad_pro
share/metainfo/org.kicad.kicad.metainfo.xml
share/mime/packages/kicad-gerbers.xml
share/mime/packages/kicad-kicad.xml
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment