Skip to content
Snippets Groups Projects
Commit ebc45c65 authored by Matthias Andree's avatar Matthias Andree
Browse files

graphics/krita: make compatible with OpenEXR/Imath 3.0

While here, add HEIF as a hard requisite for consistency
because it is automatically picked up by the build if present
and becomes more commonplace these days.
parent a29889b7
No related branches found
No related tags found
No related merge requests found
PORTNAME= krita PORTNAME= krita
DISTVERSION= 4.4.1 DISTVERSION= 4.4.1
PORTREVISION= 11 PORTREVISION= 12
CATEGORIES= graphics kde CATEGORIES= graphics kde
MASTER_SITES= KDE/stable/${PORTNAME}/${DISTVERSION} MASTER_SITES= KDE/stable/${PORTNAME}/${DISTVERSION}
DIST_SUBDIR= KDE/${PORTNAME} DIST_SUBDIR= KDE/${PORTNAME}
...@@ -11,7 +11,7 @@ COMMENT= Sketching and painting program ...@@ -11,7 +11,7 @@ COMMENT= Sketching and painting program
LICENSE= GPLv2 LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libImath.so:graphics/ilmbase \ LIB_DEPENDS= libImath.so:math/Imath \
libOpenColorIO.so:graphics/opencolorio \ libOpenColorIO.so:graphics/opencolorio \
libX11.so:x11/libX11 \ libX11.so:x11/libX11 \
libboost_system.so:devel/boost-libs \ libboost_system.so:devel/boost-libs \
...@@ -20,6 +20,7 @@ LIB_DEPENDS= libImath.so:graphics/ilmbase \ ...@@ -20,6 +20,7 @@ LIB_DEPENDS= libImath.so:graphics/ilmbase \
libcurl.so:ftp/curl \ libcurl.so:ftp/curl \
libgif.so:graphics/giflib \ libgif.so:graphics/giflib \
libgsl.so:math/gsl \ libgsl.so:math/gsl \
libheif.so:graphics/libheif \
liblcms2.so:graphics/lcms2 \ liblcms2.so:graphics/lcms2 \
libpng.so:graphics/png \ libpng.so:graphics/png \
libpoppler.so:graphics/poppler \ libpoppler.so:graphics/poppler \
...@@ -50,7 +51,7 @@ OPTIONS_SUB= yes ...@@ -50,7 +51,7 @@ OPTIONS_SUB= yes
GMIC_DESC= Depend on the G'Mic plugin #' GMIC_DESC= Depend on the G'Mic plugin #'
GMIC_RUN_DEPENDS= gmic_krita_qt:graphics/gmic-qt@krita GMIC_RUN_DEPENDS= gmic_krita_qt:graphics/gmic-qt@krita
OPENEXR_LIB_DEPENDS= libIlmImf.so:graphics/openexr \ OPENEXR_LIB_DEPENDS= libOpenEXR.so:graphics/openexr \
libSeExpr2.so:graphics/seexpr libSeExpr2.so:graphics/seexpr
OPENEXR_CMAKE_BOOL_OFF= CMAKE_DISABLE_FIND_PACKAGE_OpenEXR OPENEXR_CMAKE_BOOL_OFF= CMAKE_DISABLE_FIND_PACKAGE_OpenEXR
...@@ -59,6 +60,7 @@ CONFLICTS_INSTALL= calligra-2* ...@@ -59,6 +60,7 @@ CONFLICTS_INSTALL= calligra-2*
PLIST_SUB= SHLIB_VER=20.0.0 \ PLIST_SUB= SHLIB_VER=20.0.0 \
SHLIB_SHVER=20 SHLIB_SHVER=20
LDFLAGS= -lpthread CFLAGS+= -I${LOCALBASE}/include/Imath
LDFLAGS+= -lpthread
.include <bsd.port.mk> .include <bsd.port.mk>
--- cmake/modules/FindOpenEXR.cmake.orig 2020-10-28 11:42:28 UTC
+++ cmake/modules/FindOpenEXR.cmake
@@ -23,7 +23,7 @@
#
find_path(OPENEXR_INCLUDE_DIR
- OpenEXR/half.h
+ OpenEXR/ImfHeader.h
HINTS
"${OPENEXR_LOCATION}"
"$ENV{OPENEXR_LOCATION}"
@@ -57,11 +57,10 @@ if(OPENEXR_INCLUDE_DIR)
endif()
foreach(OPENEXR_LIB
- Half
Iex
- Imath
- IlmImf
+ OpenEXR
IlmThread
+ Imath
)
# OpenEXR libraries may be suffixed with the version number, so we search
@@ -87,6 +86,7 @@ endforeach(OPENEXR_LIB)
# So #include <half.h> works
list(APPEND OPENEXR_INCLUDE_DIRS ${OPENEXR_INCLUDE_DIR})
list(APPEND OPENEXR_INCLUDE_DIRS ${OPENEXR_INCLUDE_DIR}/OpenEXR)
+list(APPEND OPENEXR_INCLUDE_DIRS ${OPENEXR_INCLUDE_DIR}/Imath)
include(FindPackageHandleStandardArgs)
find_package_handle_standard_args(OpenEXR
--- plugins/impex/exr/exr_converter.cc.orig 2020-10-28 11:42:28 UTC
+++ plugins/impex/exr/exr_converter.cc
@@ -24,6 +24,8 @@
#include <ImfAttribute.h>
#include <ImfChannelList.h>
+#include <ImfFrameBuffer.h>
+#include <ImfHeader.h>
#include <ImfInputFile.h>
#include <ImfOutputFile.h>
...@@ -1038,3 +1038,6 @@ share/locale/xh/LC_MESSAGES/krita.mo ...@@ -1038,3 +1038,6 @@ share/locale/xh/LC_MESSAGES/krita.mo
share/locale/zh_CN/LC_MESSAGES/krita.mo share/locale/zh_CN/LC_MESSAGES/krita.mo
share/locale/zh_TW/LC_MESSAGES/krita.mo share/locale/zh_TW/LC_MESSAGES/krita.mo
share/metainfo/org.kde.krita.appdata.xml share/metainfo/org.kde.krita.appdata.xml
lib/kritaplugins/kritaheifexport.so
lib/kritaplugins/kritaheifimport.so
share/applications/krita_heif.desktop
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Please register or to comment