Skip to content
Snippets Groups Projects
Commit e981a84a authored by Yuri Victorovich's avatar Yuri Victorovich
Browse files

net/ecal: update 5.12.1 → 5.13.0

Reported by:	portscout
parent bdbc4fa3
No related branches found
No related tags found
No related merge requests found
PORTNAME= ecal
DISTVERSIONPREFIX= v
DISTVERSION= 5.12.1
PORTREVISION= 5
DISTVERSION= 5.13.0
CATEGORIES= net devel
MAINTAINER= yuri@FreeBSD.org
......@@ -16,7 +15,8 @@ BROKEN_i386= link fails: undefined reference due to --no-allow-shlib-undefined:
BUILD_DEPENDS= asio>0:net/asio \
termcolor>0:devel/termcolor
LIB_DEPENDS= libcurl.so:ftp/curl \
LIB_DEPENDS= libabsl_hash.so:devel/abseil \
libcurl.so:ftp/curl \
libfmt.so:devel/libfmt \
libfineftp-server.so:ftp/fineftp-server \
libftxui-component.so:devel/ftxui \
......@@ -24,20 +24,21 @@ LIB_DEPENDS= libcurl.so:ftp/curl \
libprotobuf.so:devel/protobuf \
libqwt.so:x11-toolkits/qwt6@qt5 \
libspdlog.so:devel/spdlog \
libsysinfo.so:devel/libsysinfo \
libtinyxml2.so:textproc/tinyxml2 \
libyaml-cpp.so:devel/yaml-cpp
# binaries aren't linked with libfineftp-server.so, see https://github.com/continental/ecal/issues/381; same with libcurl.so
USES= cmake compiler:c++17-lang desktop-file-utils localbase:ldflags pkgconfig qt:5 shared-mime-info
USE_QT= core gui widgets buildtools:build qmake:build
USE_QT= concurrent core gui widgets buildtools:build qmake:build
USE_LDCONFIG= yes
USE_GITHUB= yes
GH_ACCOUNT= eclipse-ecal
GH_TUPLE= eclipse-ecal:tcp_pubsub:f59da78:tcp_pubsub/thirdparty/tcp_pubsub \
brofield:simpleini:9b3ed7e:simpleini/thirdparty/simpleini \
steinwurf:recycle:c542570:recycle/thirdparty/recycle \
xguerin:tclap:349170a:tclap/thirdparty/tclap
GH_TUPLE= eclipse-ecal:tcp_pubsub:b0393e4:tcp_pubsub/thirdparty/tcp_pubsub/tcp_pubsub \
brofield:simpleini:9b3ed7e:simpleini/thirdparty/simpleini/simpleini \
steinwurf:recycle:c542570:recycle/thirdparty/recycle/recycle \
xguerin:tclap:349170a:tclap/thirdparty/tclap/tclap
CMAKE_ON= BUILD_SHARED_LIBS
CMAKE_OFF= BUILD_SAMPLES \
......
TIMESTAMP = 1698604411
SHA256 (eclipse-ecal-ecal-v5.12.1_GH0.tar.gz) = 086af22a5901c0a065dc99321335704d54017e47e8d83849ff763597ae7e72aa
SIZE (eclipse-ecal-ecal-v5.12.1_GH0.tar.gz) = 10097626
SHA256 (eclipse-ecal-tcp_pubsub-f59da78_GH0.tar.gz) = 710aa091c5ee97336f37d9bcfacfc7618a3b5b0bd2aec174475aba26988c1f7f
SIZE (eclipse-ecal-tcp_pubsub-f59da78_GH0.tar.gz) = 33431
TIMESTAMP = 1714104646
SHA256 (eclipse-ecal-ecal-v5.13.0_GH0.tar.gz) = d3872ff6492cf0df297ce75b66a813a2e58e47ed54206219d8916cb8aea0c9da
SIZE (eclipse-ecal-ecal-v5.13.0_GH0.tar.gz) = 10068637
SHA256 (eclipse-ecal-tcp_pubsub-b0393e4_GH0.tar.gz) = 7644e3b3d4b66273b9a77d5b438d28797dc8d7d73361c2aec22eba229b556125
SIZE (eclipse-ecal-tcp_pubsub-b0393e4_GH0.tar.gz) = 35201
SHA256 (brofield-simpleini-9b3ed7e_GH0.tar.gz) = e938e6e2db34bc545275b8c7f5808b45f18f33dd752a21d3621b9b1ba1e0385f
SIZE (brofield-simpleini-9b3ed7e_GH0.tar.gz) = 62804
SHA256 (steinwurf-recycle-c542570_GH0.tar.gz) = b39306b685538a18e6b817e030c30250b3ee21e2cec1e58b745bd7de2f23f1ee
......
--- CMakeLists.txt.orig 2022-12-23 09:10:20 UTC
--- CMakeLists.txt.orig 2024-04-24 12:44:35 UTC
+++ CMakeLists.txt
@@ -231,7 +231,7 @@ endif()
@@ -236,7 +236,7 @@ find_package(CMakeFunctions REQUIRED)
find_package(CMakeFunctions REQUIRED)
......
--- contrib/mma/src/linux/mma_linux.cpp.orig 2024-04-26 04:43:39 UTC
+++ contrib/mma/src/linux/mma_linux.cpp
@@ -44,6 +44,13 @@
#include <pwd.h>
#include <unistd.h>
+#if defined(__FreeBSD__)
+#include <sys/types.h>
+#include <sys/sysctl.h>
+#include <stdio.h>
+#include <stdlib.h>
+#endif
+
#include "../include/linux/mma_linux.h"
#define B_IN_KB 1024.0
@@ -632,7 +639,18 @@ int MMALinux::GetCpuCores(void)
int MMALinux::GetCpuCores(void)
{
+#if defined(__FreeBSD__)
+ static int name[2] = {CTL_HW, HW_NCPU};
+ int32_t ncpu;
+ size_t size = sizeof(ncpu);
+ if (sysctl(name, sizeof(name)/sizeof(*name), &ncpu, &size, NULL, 0)) {
+ perror("unable to determine number of CPUs");
+ abort();
+ }
+ return (int)ncpu;
+#else
return get_nprocs();
+#endif
}
std::string MMALinux::GetOsName()
--- thirdparty/tcp_pubsub/tcp_pubsub/src/portable_endian.h.orig 2023-01-10 09:58:29 UTC
+++ thirdparty/tcp_pubsub/tcp_pubsub/src/portable_endian.h
--- thirdparty/tcp_pubsub/tcp_pubsub/tcp_pubsub/src/portable_endian.h.orig 2024-04-26 04:19:56 UTC
+++ thirdparty/tcp_pubsub/tcp_pubsub/tcp_pubsub/src/portable_endian.h
@@ -58,14 +58,14 @@
# include <sys/endian.h>
# include <sys/endian.h> // IWYU pragma: export
-# define be16toh(x) betoh16(x)
-# define le16toh(x) letoh16(x)
......@@ -21,10 +21,3 @@
#elif defined(__WINDOWS__)
@@ -131,4 +131,4 @@
#endif
-#endif
\ No newline at end of file
+#endif
......@@ -106,6 +106,11 @@ include/ecal/ecal_util.h
include/ecal/ecalc.h
include/ecal/ecalc_types.h
include/ecal/ecaltime/pb/sim_time.pb.h
include/ecal/measurement/base/reader.h
include/ecal/measurement/base/types.h
include/ecal/measurement/base/writer.h
include/ecal/measurement/hdf5/reader.h
include/ecal/measurement/hdf5/writer.h
include/ecal/measurement/imeasurement.h
include/ecal/measurement/measurement.h
include/ecal/measurement/omeasurement.h
......@@ -222,6 +227,7 @@ lib/libecaltime-localtime.so.%%VERSION%%
lib/libecaltime-simtime.so
lib/libecaltime-simtime.so.5
lib/libecaltime-simtime.so.%%VERSION%%
lib/libmeasurement_hdf5.so
lib/libsys_core.so
share/applications/ecal_launcher.desktop
share/applications/ecal_mon_gui.desktop
......@@ -260,6 +266,8 @@ share/applications/ecal_sys_gui.desktop
%%DATADIR%%/samples/cpp/benchmarks/many_connections_rec/src/many_connections_rec.cpp
%%DATADIR%%/samples/cpp/benchmarks/many_connections_snd/CMakeLists.txt
%%DATADIR%%/samples/cpp/benchmarks/many_connections_snd/src/many_connections_snd.cpp
%%DATADIR%%/samples/cpp/benchmarks/measurement/CMakeLists.txt
%%DATADIR%%/samples/cpp/benchmarks/measurement/src/main.cpp
%%DATADIR%%/samples/cpp/benchmarks/multiple_rec_cb/CMakeLists.txt
%%DATADIR%%/samples/cpp/benchmarks/multiple_rec_cb/src/main.cpp
%%DATADIR%%/samples/cpp/benchmarks/multiple_rec_cb/src/multiple_rec_cb.cpp
......@@ -289,6 +297,15 @@ share/applications/ecal_sys_gui.desktop
%%DATADIR%%/samples/cpp/benchmarks/performance_snd/CMakeLists.txt
%%DATADIR%%/samples/cpp/benchmarks/performance_snd/src/binary_payload_writer.h
%%DATADIR%%/samples/cpp/benchmarks/performance_snd/src/performance_snd.cpp
%%DATADIR%%/samples/cpp/benchmarks/perftool/CMakeLists.txt
%%DATADIR%%/samples/cpp/benchmarks/perftool/Readme.md
%%DATADIR%%/samples/cpp/benchmarks/perftool/src/main.cpp
%%DATADIR%%/samples/cpp/benchmarks/perftool/src/publisher.cpp
%%DATADIR%%/samples/cpp/benchmarks/perftool/src/publisher.h
%%DATADIR%%/samples/cpp/benchmarks/perftool/src/publisher_statistics.h
%%DATADIR%%/samples/cpp/benchmarks/perftool/src/subscriber.cpp
%%DATADIR%%/samples/cpp/benchmarks/perftool/src/subscriber.h
%%DATADIR%%/samples/cpp/benchmarks/perftool/src/subscriber_statistics.h
%%DATADIR%%/samples/cpp/benchmarks/pubsub_throughput/CMakeLists.txt
%%DATADIR%%/samples/cpp/benchmarks/pubsub_throughput/src/binary_payload_writer.h
%%DATADIR%%/samples/cpp/benchmarks/pubsub_throughput/src/pubsub_throughput.cpp
......@@ -302,10 +319,6 @@ share/applications/ecal_sys_gui.desktop
%%DATADIR%%/samples/cpp/measurement/measurement_write/src/protobuf/animal.proto
%%DATADIR%%/samples/cpp/measurement/measurement_write/src/protobuf/house.proto
%%DATADIR%%/samples/cpp/measurement/measurement_write/src/protobuf/person.proto
%%DATADIR%%/samples/cpp/misc/event_rec/CMakeLists.txt
%%DATADIR%%/samples/cpp/misc/event_rec/src/event_rec.cpp
%%DATADIR%%/samples/cpp/misc/event_snd/CMakeLists.txt
%%DATADIR%%/samples/cpp/misc/event_snd/src/event_snd.cpp
%%DATADIR%%/samples/cpp/misc/process/CMakeLists.txt
%%DATADIR%%/samples/cpp/misc/process/src/process.cpp
%%DATADIR%%/samples/cpp/misc/time/CMakeLists.txt
......@@ -364,6 +377,11 @@ share/applications/ecal_sys_gui.desktop
%%DATADIR%%/samples/cpp/pubsub/flatbuffer/monster_snd/monster_snd.cpp
%%DATADIR%%/samples/cpp/pubsub/msgpack/address_rec/src/address_rec.cpp
%%DATADIR%%/samples/cpp/pubsub/msgpack/address_snd/src/address_snd.cpp
%%DATADIR%%/samples/cpp/pubsub/protobuf/person_loopback/CMakeLists.txt
%%DATADIR%%/samples/cpp/pubsub/protobuf/person_loopback/src/person_loopback.cpp
%%DATADIR%%/samples/cpp/pubsub/protobuf/person_loopback/src/protobuf/animal.proto
%%DATADIR%%/samples/cpp/pubsub/protobuf/person_loopback/src/protobuf/house.proto
%%DATADIR%%/samples/cpp/pubsub/protobuf/person_loopback/src/protobuf/person.proto
%%DATADIR%%/samples/cpp/pubsub/protobuf/person_rec/CMakeLists.txt
%%DATADIR%%/samples/cpp/pubsub/protobuf/person_rec/src/person_rec.cpp
%%DATADIR%%/samples/cpp/pubsub/protobuf/person_rec/src/protobuf/animal.proto
......
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment