Skip to content
Snippets Groups Projects
Commit e8db9768 authored by Rene Ladan's avatar Rene Ladan
Browse files

cleanup: Remove expired GhostScript 8 ports:

2023-06-30 print/ghostscript8-base: Obsolete and unsupported upstream, consider using a more recent version
2023-06-30 print/ghostscript8-x11: Obsolete and unsupported upstream
parent 8fcc4540
No related branches found
No related tags found
No related merge requests found
Showing
with 2 additions and 1705 deletions
......@@ -7752,3 +7752,5 @@ print/ghostscript7-commfont||2023-06-30|Has expired: Obsolete and unsupported up
print/ghostscript7-korfont||2023-06-30|Has expired: Obsolete and unsupported upstream
print/ghostscript7-x11||2023-06-30|Has expired: Obsolete and unsupported upstream
print/ghostscript7-jpnfont||2023-06-30|Has expired: Obsolete and unsupported upstream
print/ghostscript8-base||2023-06-30|Has expired: Obsolete and unsupported upstream, consider using a more recent version
print/ghostscript8-x11||2023-06-30|Has expired: Obsolete and unsupported upstream
......@@ -57,8 +57,6 @@
SUBDIR += freetype2
SUBDIR += ft2demos
SUBDIR += ghostscript10
SUBDIR += ghostscript8-base
SUBDIR += ghostscript8-x11
SUBDIR += ghostscript9-agpl-base
SUBDIR += ghostscript9-agpl-x11
SUBDIR += gimp-gutenprint
......
PORTNAME= ghostscript
PORTVERSION= 8.71
PORTREVISION= 24
CATEGORIES= print
MASTER_SITES= http://downloads.ghostscript.com/public/:gs_srcs \
SF/ghostscript/GPL%20Ghostscript/${PORTVERSION}:gs_srcs \
http://www.humblesoft.com/pub/:epag
PKGNAMESUFFIX= 8-base
DISTFILES= ${DISTNAME}${EXTRACT_SUFX}:gs_srcs ${EPAG_SRCS}:epag
DIST_SUBDIR= ${PORTNAME}
EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= ports@FreeBSD.org
COMMENT= Ghostscript 8.x PostScript interpreter, base part
WWW= https://www.cs.wisc.edu/~ghost/doc/GPL/index.htm
FORBIDDEN= CVE-2023-28879
LICENSE= GPLv3
DEPRECATED= Obsolete and unsupported upstream, consider using a more recent version
EXPIRATION_DATE=2023-06-30
LIB_DEPENDS= libexpat.so:textproc/expat2 \
libfreetype.so:print/freetype2 \
libjasper.so:graphics/jasper \
libjbig2dec.so:graphics/jbig2dec \
libpaper.so:print/libpaper \
libpng.so:graphics/png \
libtiff.so:graphics/tiff
RUN_DEPENDS= ${LOCALBASE}/share/${PORTNAME}/fonts/a010013l.pfb:print/gsfonts
CONFLICTS_INSTALL= ghostscript*-base # CHECK
USES= autoreconf cpe gmake pkgconfig shebangfix tar:xz
USE_LDCONFIG= yes
CPE_VENDOR= artifex
SHEBANG_FILES= ${WRKSRC}/lib/fixmswrd.pl
EXTRACT_AFTER_ARGS= ${EXCLUDE_DIRS:S/^/--exclude /}
GNU_CONFIGURE= yes
DATADIR= ${PREFIX}/share/${PORTNAME}/${PORTVERSION}
MAKE_JOBS_UNSAFE= yes
MAKE_ENV= CFLAGS_STANDARD="${CFLAGS}" \
XCFLAGS="${XCFLAGS}" XLDFLAGS="${XLDFLAGS}" \
FT_BRIDGE=1 FT_ROOT="${WRKSRC}/freetype" FT_LIB_EXT=".so" \
SOC_LOADER="dxmainc.c"
CONFIGURE_ENV= ${MAKE_ENV}
CONFIGURE_ARGS= --disable-compile-inits \
--enable-contrib \
--enable-dynamic \
--with-ijs \
--with-jasper \
--with-libpaper \
--without-x \
--disable-gtk \
--with-drivers=""
CPPFLAGS+= -DUPD_SIGNAL=0 \
-DJBIG_NO_MEMENTO \
-I. \
-I${WRKSRC}/jasper/src/libjasper/include \
-I${LOCALBASE}/include/freetype2 \
-I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
XCFLAGS= -DA4
XLDFLAGS= -lpthread
ALL_TARGET= so
INSTALL_TARGET= soinstall
PLIST_SUB= SHLIB_VER="${PORTVERSION:R}" \
GS_VERSION="${PORTVERSION}"
SUB_FILES= pkg-message
OPTIONS_DEFINE= DOCS CAIRO CUPS FONTCONFIG ICONV
OPTIONS_DEFAULT=CAIRO CUPS FONTCONFIG ICONV
OPTIONS_SUB= yes
FONTCONFIG_DESC=Enable fontconfig support
FONTCONFIG_LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig
FONTCONFIG_CONFIGURE_ENABLE= fontconfig
NO_OPTIONS_SORT=yes
EXCLUDE_DIRS= jbig2dec jpeg expat jasper libpng tiff zlib
.include "Makefile.drivers"
.include <bsd.port.options.mk>
.include "files/Makefile.drivers_post"
PORTDOCS= japanese chp2200 epson740 lxm3200-tweaked md2k_md5k
PORTDOC_FILES= japanese/Gdevlips.htm japanese/README.gs550j \
japanese/cdj880.txt japanese/dj505j.txt japanese/djgpp.txt \
japanese/gdev10v.txt japanese/gdevalps.txt \
japanese/gdevcd8.txt japanese/gdevdmpr.txt \
japanese/gdevfmlbp.txt japanese/gdevj100.txt \
japanese/gdevlbp3.txt japanese/gdevmag.txt \
japanese/gdevmd2k.txt japanese/gdevmjc.txt \
japanese/gdevml6.txt japanese/gdevp201.txt japanese/gs261j.euc \
japanese/gs261j.txt chp2200/AUTHORS chp2200/INSTALL \
epson740/README epson740/upp-HowTo-to-be \
lxm3200-tweaked/LICENSE lxm3200-tweaked/README \
lxm3200-tweaked/RELEASE_NOTES \
lxm3200-tweaked/Z12-Z31-QuickSetup md2k_md5k/README.jis
post-patch:
${REINPLACE_CMD} -e 's,%%DATADIR%%,${DATADIR},' \
${WRKSRC}/contrib/japanese/dmp_site.ps
pre-build-drivers.mak:
@${ECHO_CMD} '# automatically generated' > ${WRKSRC}/base/drivers.mak
.for N in ${DEVS_LIST}
@${ECHO_CMD} 'DEVICE_${N}=' >> ${WRKSRC}/base/drivers.mak
.endfor
.for D in ${OPTIONS_DEFINE:MGS_*:S/^GS_//} \
${OPTIONS_GROUP_ICONV:MGS_*:S/^GS_//} \
${OPTIONS_GROUP_SVGALIB:MGS_*:S/^GS_//}
.for N in ${DEVS_LIST}
.if ${PORT_OPTIONS:MGS_${D}}
.if !defined(OPTIONS_UNSET) || !${OPTIONS_UNSET:MGS_${D}}
.for X in ${DEVICE_${N}:M${D}.dev}
@${ECHO_CMD} 'DEVICE_${N}+= $$(DD)${D}.dev' >> ${WRKSRC}/base/drivers.mak
.endfor
.endif
.endif
.endfor
.endfor
pre-build: pre-build-drivers.mak
${MKDIR} ${WRKSRC}/obj ${WRKSRC}/bin ${WRKSRC}/freetype/include
${LN} -s -f ${LOCALBASE}/include/ft2build.h \
${WRKSRC}/freetype/include/ft2build.h
${LN} -s -f ${LOCALBASE}/include/freetype2/freetype \
${WRKSRC}/freetype/include/freetype
${MKDIR} ${WRKSRC}/freetype/objs
${LN} -s -f ${LOCALBASE}/lib/libfreetype.so \
${WRKSRC}/freetype/objs/freetype214MT_D.so
pre-install:
cd ${WRKSRC}/Resource/Init && ${RM} \
gs_statd.ps.orig gs_ttf.ps.orig pdf_font.ps.orig
${MKDIR} ${STAGEDIR}${DATADIR}
post-install-DOCS-on: post-install-docs
${MKDIR} ${WRKSRC}/contrib/japanese
${INSTALL_DATA} ${WRKSRC}/contrib/japanese/doc/* \
${WRKSRC}/contrib/japanese
${MKDIR} ${STAGEDIR}${DOCSDIR}
cd ${WRKSRC}/contrib && \
${TAR} -cf - ${PORTDOC_FILES} | \
(cd ${STAGEDIR}${DOCSDIR} && ${TAR} -xof -)
post-install:
${INSTALL_DATA} ${WRKSRC}/lib/FAPIcidfmap \
${WRKSRC}/lib/FAPIconfig ${WRKSRC}/lib/FAPIfontmap \
${STAGEDIR}${DATADIR}/Resource/Init
${LN} -sf gsc ${STAGEDIR}${PREFIX}/bin/gs
${LN} -s -f ${LOCALBASE}/share/fonts/CIDFont \
${STAGEDIR}${DATADIR}/Resource/CIDFont
.include <bsd.port.mk>
This diff is collapsed.
SHA256 (ghostscript/ghostscript-8.71.tar.xz) = f48f7370a00f24fce174b147074aca3f6bede82154dd2bf93d24430a62e4de73
SIZE (ghostscript/ghostscript-8.71.tar.xz) = 15698644
SHA256 (ghostscript/epag-3.09.tar.gz) = ad10eca44c781a5851d5a8993dcd95b2e2b99392cbf2c8372a5a658f3b991b3b
SIZE (ghostscript/epag-3.09.tar.gz) = 12858
post-install-dmprt:
cd ${FILESDIR} && \
${INSTALL_DATA} lqx70ch.upp lqx70cl.upp lqx70cm.upp \
${STAGEDIR}${DATADIR}/lib
post-install: post-install-dmprt
# pre/postprocessing driver variables
# dmprt specific
.if ${PORT_OPTIONS:MGS_dmprt}
.include "${MASTERDIR}/files/Makefile.dmprt"
.endif
# epag specific
.if ${PORT_OPTIONS:MGS_epag}
.include "${MASTERDIR}/files/Makefile.epag"
.endif
EPAG_BASE= epag
EPAG_SRCS= ${EPAG_BASE}-3.09.tar.gz
EPAG_NAME= ${EPAG_SRCS:S,.tar.gz$,,}
post-extract-epag:
${TAR} -C ${WRKSRC} -xzf ${DISTDIR}/${DIST_SUBDIR}/${EPAG_SRCS}
${LN} -s -f ${EPAG_NAME} ${WRKSRC}/${EPAG_BASE}
${INSTALL_DATA} ${FILESDIR}/epag.contrib.mak ${WRKSRC}/base/epag.contrib.mak
post-extract: post-extract-epag
# pcl3 specific
.if ${PORT_OPTIONS:MGS_pcl3}
.include "${MASTERDIR}/files/Makefile.pcl3"
.endif
# cups specific
CUPS_DEVS= cups
.undef _CUPS_DEVS
.for D in ${CUPS_DEVS}
.if ${PORT_OPTIONS:MCUPS} && ${PORT_OPTIONS:MGS_${D}}
_CUPS_DEVS+= ${D}
.else
PORT_OPTIONS:= ${PORT_OPTIONS:NGS_${D}}
.endif
.endfor
.if defined(_CUPS_DEVS)
LIB_DEPENDS+= libcupsimage.so:print/cups
CONFIGURE_ARGS+= --enable-cups
.else
CONFIGURE_ARGS+= --disable-cups
.endif
# vgalib specific
VGA_DEVS= lvga256 vgalib
.undef _VGA_DEVS
.for D in ${VGA_DEVS}
.if ${PORT_OPTIONS:MGS_${D}}
.if ${ARCH:Mamd64} || ${ARCH:Mi386}
_VGA_DEVS+= ${D}
.else
OPTIONS_UNSET+= ${PORT_OPTIONS:MGS_${D}}
.endif
.endif
.endfor
.if defined(_VGA_DEVS)
LIB_DEPENDS+= libvga.so:graphics/svgalib
.endif
# iconv specific
ICONV_DEVS= oprp opvp
.undef _ICONV_DEVS
.for D in ${ICONV_DEVS}
.if ${PORT_OPTIONS:MICONV} && ${PORT_OPTIONS:MGS_${D}}
_ICONV_DEVS+= ${D}
.else
PORT_OPTIONS:= ${PORT_OPTIONS:NGS_${D}}
.endif
.endfor
.if defined(_ICONV_DEVS)
USES+= iconv
CONFIGURE_ARGS+=--with-libiconv=maybe
.else
CONFIGURE_ARGS+=--with-libiconv=no
.endif
# cairo specific
.for D in cairo
.if ${PORT_OPTIONS:MCAIRO} && ${PORT_OPTIONS:MGS_${D}}
_CAIRO_DEVS+= ${D}
.else
PORT_OPTIONS:= ${PORT_OPTIONS:NGS_${D}}
.endif
.endfor
.if defined(_CAIRO_DEVS)
LIB_DEPENDS+= libcairo.so:graphics/cairo
CONFIGURE_ARGS+= --enable-cairo
.else
CONFIGURE_ARGS+= --disable-cairo
.endif
# pre-defined order
DEVS_LIST= DEVS1 DEVS2 DEVS3 DEVS4 DEVS5 DEVS6 DEVS7 DEVS8 DEVS9 \
DEVS10 DEVS11 DEVS12 DEVS13 DEVS14 DEVS15 DEVS16 DEVS17 DEVS18 \
DEVS19 DEVS20 DEVS21
DEVICE_DEVS1= bmpmono.dev bmpgray.dev bmpsep1.dev bmpsep8.dev \
bmp16.dev bmp256.dev bmp16m.dev bmp32b.dev stcolor.dev
DEVICE_DEVS2= epson.dev eps9high.dev eps9mid.dev epsonc.dev ibmpro.dev
DEVICE_DEVS3= deskjet.dev djet500.dev laserjet.dev ljetplus.dev \
ljet2p.dev ljet3.dev ljet3d.dev ljet4.dev ljet4d.dev \
lj5mono.dev lj5gray.dev cups.dev
DEVICE_DEVS4= cdeskjet.dev cdjcolor.dev cdjmono.dev cdj550.dev pj.dev \
pjxl.dev pjxl300.dev ijs.dev
DEVICE_DEVS5= uniprint.dev omni.dev
DEVICE_DEVS6= bj10e.dev bj200.dev bjc600.dev bjc800.dev png48.dev \
png16m.dev pnggray.dev pngmono.dev png256.dev png16.dev \
pngalpha.dev
DEVICE_DEVS7= faxg3.dev faxg32d.dev faxg4.dev
DEVICE_DEVS8= pcxmono.dev pcxgray.dev pcx16.dev pcx256.dev pcx24b.dev \
pcxcmyk.dev svgwrite.dev
DEVICE_DEVS9= pbm.dev pbmraw.dev pgm.dev pgmraw.dev pgnm.dev \
pgnmraw.dev pnm.dev pnmraw.dev ppm.dev ppmraw.dev pkm.dev \
pkmraw.dev pksm.dev pksmraw.dev
DEVICE_DEVS10= tiffcrle.dev tiffg3.dev tiffg32d.dev tiffg4.dev \
tifflzw.dev tiffpack.dev
DEVICE_DEVS11= tiff12nc.dev tiff24nc.dev tiff48nc tiffgray.dev \
tiff32nc.dev tiff64nc.dev tiffsep.dev tiffsep1.dev
DEVICE_DEVS12= psmono.dev psgray.dev psrgb.dev bit.dev bitrgb.dev \
bitcmyk.dev
DEVICE_DEVS13=
DEVICE_DEVS14= jpeg.dev jpeggray.dev jpegcmyk.dev
DEVICE_DEVS15= pdfwrite.dev pswrite.dev ps2write.dev epswrite.dev \
txtwrite.dev pxlmono.dev pxlcolor.dev
DEVICE_DEVS16= bbox.dev
DEVICE_DEVS17=
DEVICE_DEVS18=
DEVICE_DEVS20= cljet5.dev cljet5c.dev
DEVICE_DEVS21= spotcmyk.dev devicen.dev xcf.dev psdcmyk.dev psdrgb.dev \
pamcmyk32.dev
# DEVS19 is for this port specific
DEVICE_DEVS19= alc1900.dev alc2000.dev alc4000.dev alc4100.dev \
alc8500.dev alc8600.dev ap3250.dev appledmp.dev atx23.dev \
atx24.dev atx38.dev bj10v.dev bj10vh.dev bjc880j.dev \
bjccmyk.dev bjccolor.dev bjcgray.dev bjcmono.dev cairo.dev \
ccr.dev cdj1600.dev cdj500.dev cdj670.dev cdj850.dev \
cdj880.dev cdj890.dev cdj970.dev cdnj500.dev cfax.dev \
cgm24.dev cgm8.dev cgmmono.dev chp2200.dev cif.dev \
cljet5pr.dev coslw2p.dev coslwxl.dev cp50.dev declj250.dev \
dfaxhigh.dev dfaxlow.dev display.dev dj505j.dev djet500c.dev \
dl2100.dev dmprt.dev dnj650c.dev epag.dev epl2050.dev \
epl2050p.dev epl2120.dev epl2500.dev epl2750.dev epl5800.dev \
epl5900.dev epl6100.dev eplcolor.dev eplmono.dev escpage.dev \
fmlbp.dev fmpr.dev fs600.dev gdi.dev hl1240.dev hl1250.dev \
hl7x0.dev imagen.dev imdi.dev inferno.dev iwhi.dev iwlo.dev \
iwlq.dev jetp3852.dev jj100.dev jpegcmyk.dev la50.dev la70.dev \
la75.dev la75plus.dev lbp310.dev lbp320.dev lbp8.dev \
lex2050.dev lex3200.dev lex5700.dev lex7000.dev lips2p.dev \
lips3.dev lips4.dev lips4v.dev lj250.dev lj4dith.dev \
lj4dithp.dev ljet4pjl.dev ln03.dev lp1800.dev lp1900.dev \
lp2000.dev lp2200.dev lp2400.dev lp2500.dev lp2563.dev \
lp3000c.dev lp7500.dev lp7700.dev lp7900.dev lp8000.dev \
lp8000c.dev lp8100.dev lp8200c.dev lp8300c.dev lp8300f.dev \
lp8400f.dev lp8500c.dev lp8600.dev lp8600f.dev lp8700.dev \
lp8800c.dev lp8900.dev lp9000b.dev lp9000c.dev lp9100.dev \
lp9300.dev lp9400.dev lp9500c.dev lp9600.dev lp9600s.dev \
lp9800c.dev lq850.dev lvga256.dev lx5000.dev lxm3200.dev \
lxm5700m.dev m8510.dev mag16.dev mag256.dev md1xMono.dev \
md2k.dev md50Eco.dev md50Mono.dev md5k.dev mgr4.dev mgr8.dev \
mgrgray2.dev mgrgray4.dev mgrgray8.dev mgrmono.dev miff24.dev \
mj500c.dev mj6000c.dev mj700v2c.dev mj8000c.dev ml600.dev \
necp6.dev npdl.dev oce9050.dev oki182.dev oki4w.dev okiibm.dev \
oprp.dev opvp.dev paintjet.dev pam.dev pamcmyk32.dev pcl3.dev \
perm.dev photoex.dev picty180.dev pjetxl.dev plan9bm.dev \
pr1000.dev pr1000_4.dev pr150.dev pr201.dev r4081.dev rpdl.dev \
sgirgb.dev sj48.dev st800.dev sunhmono.dev t4693d2.dev \
t4693d4.dev t4693d8.dev tek4696.dev tiff48nc tiff64nc.dev \
tiffsep1.dev txtwrite.dev vgalib.dev wtscmyk.dev wtsimdi.dev \
x11.dev x11alpha.dev x11cmyk.dev x11cmyk2.dev x11cmyk4.dev \
x11cmyk8.dev x11gray2.dev x11gray4.dev x11mono.dev \
x11rg16x.dev x11rg32x.dev xcfcmyk.dev xes.dev
# EPAG - additional driver for Epson ESC/Page printers
# http://www.humblesoft.com/gdevepag.html
PORTDOCS+= epag
PORTDOC_FILES+= epag/ert.txt epag/gdevepag.txt epag/ChangeLog \
epag/psprint epag/gsepagif.sh
pre-build-epag:
${LN} -s -f ${WRKSRC}/${EPAG_NAME}/gdevepag.c ${WRKSRC}/base
${MKDIR} ${WRKSRC}/contrib/epag
${INSTALL_DATA} ${WRKSRC}/${EPAG_NAME}/* ${WRKSRC}/contrib/epag
post-build-epag:
cd ${WRKSRC}/${EPAG_NAME} && \
${SETENV} ${MAKE_ENV} ${MAKE_CMD} ${MAKE_FLAGS} Makefile
post-install-epag:
${INSTALL_PROGRAM} ${WRKSRC}/${EPAG_NAME}/ert ${STAGEDIR}${PREFIX}/bin
pre-build: pre-build-epag
post-build: post-build-epag
post-install: post-install-epag
PORTDOCS+= pcl3
PORTDOC_FILES+= pcl3/NEWS pcl3/BUGS pcl3/README pcl3/gs-pcl3.html \
pcl3/how-to-report.txt pcl3/pcl3opts.html
post-build-pcl3:
cd ${WRKSRC} && \
${CC} ${CFLAGS} -I./obj -I./soobj -I./base \
-I./contrib/pcl3/eprn -o bin/pcl3opts \
contrib/pcl3/src/pcl3opts.c contrib/pcl3/src/pclscan.c \
contrib/pcl3/eprn/mediasize.c contrib/pcl3/src/pclsize.c
post-install-pcl3:
${INSTALL_PROGRAM} ${WRKSRC}/bin/pcl3opts ${STAGEDIR}${PREFIX}/bin
${MKDIR} ${STAGEDIR}${DATADIR}/pcl3
cd ${WRKSRC}/contrib/pcl3 && \
${INSTALL_DATA} lib/example.mcf lib/if-pcl3 \
ps/calign.ps ps/dumppdd.ps ps/levels-test.ps \
ps/margins-A4.ps ps/margins-A4Rotated.ps \
ps/margins-Env10Rotated.ps \
ps/margins-EnvDLRotated.ps \
ps/margins-Letter.ps \
ps/margins-LetterRotated.ps \
${STAGEDIR}${DATADIR}/pcl3
cd ${WRKSRC}/contrib/pcl3/doc && \
${INSTALL_MAN} gs-pcl3.1 pcl3opts.1 \
${STAGEDIR}${MANPREFIX}/man/man1
post-install-docs-pcl3:
${MKDIR} ${WRKSRC}/contrib/pcl3
${INSTALL_DATA} ${WRKSRC}/contrib/pcl3/doc/* ${WRKSRC}/contrib/pcl3
post-build: post-build-pcl3
post-install: post-install-pcl3
post-install-docs: post-install-docs-pcl3
### ------- Epson ESC/Page printer device ----------------- ###
epag_=$(GLOBJ)gdevepag.$(OBJ)
$(DD)epag.dev : $(epag_) $(DD)page.dev
$(SETPDEV) $(DD)epag $(epag_)
$(GLOBJ)gdevepag.$(OBJ): $(GLSRC)gdevepag.c $(gdevprn_h) $(PDEVH)
$(GLCC) $(GLO_)gdevepag.$(OBJ) $(C_) $(GLSRC)gdevepag.c
# $ApsCVS: src/apsfilter/uniprint/lqx70ch.upp,v 1.2 2000/04/21 18:48:00 andreas Exp $
#
-supModel="Epson LQ-1170 ESC/P2 Dot Matrix, 360x360DpI, Plain Paper"
-sDEVICE=uniprint
-dNOPAUSE
-dSAFER
-dupColorModel=/DeviceCMYKgenerate
-dupRendering=/ErrorDiffusion
-dupOutputFormat=/EscP2
-r360x360
-dupMargins="{ 9.0 0.0 9.0 24.0}"
-dupOutputPins=24
-dupBeginPageCommand="<
1b40 1b40
1b2847 0100 01
1b2869 0100 01
1b2855 0100 0A
1b5501
1b2865 0200 0002
1b2843 0200 0000
1b2863 0400 0000 0000
>"
-dupAdjustPageLengthCommand
-dupEndPageCommand="(\014)"
-dupAbortCommand="(\033@\15\12\12\12\12 Printout-Aborted\15\014)"
# $ApsCVS: src/apsfilter/uniprint/lqx70cl.upp,v 1.2 2000/04/21 18:48:00 andreas Exp $
#
-supModel="Epson LQ-1170 ESC/P2 Dot Matrix, 180x180DpI, Plain Paper"
-sDEVICE=uniprint
-dNOPAUSE
-dSAFER
-dupColorModel=/DeviceCMYKgenerate
-dupRendering=/ErrorDiffusion
-dupOutputFormat=/EscP2
-r180x180
-dupMargins="{ 9.0 0.0 9.0 24.0}"
-dupOutputPins=24
-dupBeginPageCommand="<
1b40 1b40
1b2847 0100 01
1b2869 0100 01
1b2855 0100 14
1b5500
1b2865 0200 0002
1b2843 0200 0000
1b2863 0400 0000 0000
>"
-dupAdjustPageLengthCommand
-dupEndPageCommand="(\014)"
-dupAbortCommand="(\033@\15\12\12\12\12 Printout-Aborted\15\014)"
# $ApsCVS: src/apsfilter/uniprint/lqx70cm.upp,v 1.2 2000/04/21 18:48:00 andreas Exp $
#
-supModel="Epson LQ-1170 ESC/P2 Dot Matrix, 360x180DpI, Plain Paper"
-sDEVICE=uniprint
-dNOPAUSE
-dSAFER
-dupColorModel=/DeviceCMYKgenerate
-dupRendering=/ErrorDiffusion
-dupOutputFormat=/EscP2
-r360x180
-dupMargins="{ 9.0 24.0 9.0 24.0}"
-dupOutputPins=24
-dupBeginPageCommand="<
1b40 1b40
1b2847 0100 01
1b2869 0100 01
1b2855 0100 14
1b5501
1b2843 0200 0000
1b2863 0400 0000 0000
>"
-dupAdjustPageLengthCommand
-dupEndPageCommand="(\014)"
-dupAbortCommand="(\033@\15\12\12\12\12 Printout-Aborted\15\014)"
--- Resource/Init/cidfmap.orig 2008-08-08 04:22:38 UTC
+++ Resource/Init/cidfmap
@@ -26,3 +26,64 @@
% /ShinGo-Bold /HeiseiKakuGo-W5 ;
% /Ryumin-Medium << /FileType /TrueType /Path (H:/AuxFiles/Fonts/BATANG.TTC) /SubfontID 3 /CSI [(Japan1) 2] >> ;
%
+/Ryumin-Light << /FileType /TrueType /Path (Ryumin-Light) /SubfontID 0 /CSI [(Japan1) 6] >> ;
+/GothicBBB-Medium << /FileType /TrueType /Path (GothicBBB-Medium) /SubfontID 0 /CSI [(Japan1) 6] >> ;
+
+/Ryumin-Medium /Ryumin-Light ;
+/Ryumin-Regular /Ryumin-Light ;
+/RyuminPro-Light /Ryumin-Light ;
+
+/GothicBBBPro-Medium /GothicBBB-Medium ;
+
+/KozGoPro-Bold /GothicBBB-Medium ;
+/KozGoPro-Heavy /GothicBBB-Medium ;
+/KozGoPro-Medium /GothicBBB-Medium ;
+/KozGoPro-Regular /GothicBBB-Medium ;
+
+/KozMinPro-Bold /Ryumin-Light ;
+/KozMinPro-Light /Ryumin-Light ;
+/KozMinPro-Medium /Ryumin-Light ;
+/KozMinPro-Regular /Ryumin-Light ;
+
+/HiraKakuPro-W3 /GothicBBB-Medium ;
+/HiraKakuPro-W6 /GothicBBB-Medium ;
+/HiraKakuStd-W8 /GothicBBB-Medium ;
+
+/HiraMaruPro-W4 /GothicBBB-Medium ;
+
+/HiraMinPro-W3 /Ryumin-Light ;
+
+/HeiseiMin-W3 /Ryumin-Light ;
+/HeiseiKakuGo-W5 /GothicBBB-Medium ;
+
+/FutoMinA101-Bold /Ryumin-Light ;
+/FutoMinA101Pro-Bold /Ryumin-Light ;
+/FutoGoB101-Bold /GothicBBB-Medium ;
+/FutoGoB101Pro-Bold /GothicBBB-Medium ;
+
+/Jun101-Light /Ryumin-Light ;
+/Jun101Pro-Light /Ryumin-Light ;
+
+/MidashiGo-MB31 /GothicBBB-Medium ;
+/MidashiGoPro-MB31 /GothicBBB-Medium ;
+
+/MidashiMinPro-MA31 /Ryumin-Light ;
+
+/MS-Mincho /Ryumin-Light ;
+/MS-PMincho /Ryumin-Light ;
+/MS-Gothic /GothicBBB-Medium ;
+/MS-PGothic /GothicBBB-Medium ;
+
+%/Munhwa-Regular /Munhwa-Regular ;
+%/MunhwaGothic-Regular /MunhwaGothic-Regular ;
+%/Munhwa-Bold /Munhwa-Bold ;
+%/MunhwaGothic-Bold /MunhwaGothic-Bold ;
+
+/HYGoThic-Medium /MunhwaGothic-Regular ;
+/HYSMyeongJo-Medium /Munhwa-Regular ;
+/HYRGoThic-Medium /MunhwaGothic-Bold ;
+
+/STHeiti-Regular << /FileType /TrueType /Path (STHeiti-Regular) /SubfontID 0 /CSI [(CNS1) 5] >> ;
+/STSong-Light << /FileType /TrueType /Path (STSong-Light) /SubfontID 0 /CSI [(GB1) 5] >> ;
+/MSung-Light << /FileType /TrueType /Path (MSung-Light) /SubfontID 0 /CSI [(CNS1) 5] >> ;
+/MHei-Medium << /FileType /TrueType /Path (MHei-Medium) /SubfontID 0 /CSI [(GB1) 5] >> ;
--- Resource/Init/gs_statd.ps.orig 2009-03-15 22:42:53 UTC
+++ Resource/Init/gs_statd.ps
@@ -111,6 +111,12 @@ STRICT { (%END SIZES) .skipeof } if
/pa4 {595 792 //.setpagesize exec} bind def
% Japanese postcard size, 100mm x 148mm
/hagaki {283 420 //.setpagesize exec} bind def
+ /postcard {284 419 //.setpagesize exec} bind def
+ /dbl_postcard {419 568 //.setpagesize exec} bind def
+ /Executive {522 756 //.setpagesize exec} bind def
+ /jenv_you4 {298 666 //.setpagesize exec} bind def
+ /jenv_you2 {324 460 //.setpagesize exec} bind def
+ /jenv_kaku2 {682 942 //.setpagesize exec} bind def
% /tabloid {792 1224 //.setpagesize exec} bind def % 11x17 portrait
% /csheet {1224 1584 //.setpagesize exec} bind def % ANSI C 17x22
% /dsheet {1584 2448 //.setpagesize exec} bind def % ANSI D 22x34
@@ -127,6 +133,7 @@ statusdict begin
[ /letter /note %do not change this line, needed by 'setpagetype'
/legal /lettersmall
/11x17 /ledger
+ /postcard /dbl_postcard /Executive /hagaki /jenv_you4 /jenv_you2 /jenv_kaku2
/a4small /a3 /a4
STRICT { (%END SIZES) .skipeof } if
/a0 /a1 /a2 /a5 /a6 /a7 /a8 /a9 /a10
--- Resource/Init/gs_ttf.ps.orig 2010-01-03 01:07:12 UTC
+++ Resource/Init/gs_ttf.ps
@@ -1104,10 +1104,17 @@ mark
} ifelse
% Stack: ... /FontInfo mark key1 value1 ...
post null ne {
- /ItalicAngle first_post_string 4 gets32 65536.0 div
- /isFixedPitch first_post_string 12 getu32 0 ne
- /UnderlinePosition first_post_string 8 gets16 upem div
- /UnderlineThickness first_post_string 10 gets16 upem div
+ post type /arraytype eq {
+ % this post table is a big table. /post should be [(...) ...]
+ % data we actually need here should be first one in array.
+ /posttable post 1 get def
+ } {
+ /posttable post def
+ } ifelse
+ /ItalicAngle posttable 4 gets32 65536.0 div
+ /isFixedPitch posttable 12 getu32 0 ne
+ /UnderlinePosition posttable 8 gets16 upem div
+ /UnderlineThickness posttable 10 gets16 upem div
} if
counttomark 0 ne { .dicttomark } { pop pop } ifelse
/XUID [orgXUID 42 curxuid]
--- Resource/Init/pdf_font.ps.orig 2010-02-08 16:45:18 UTC
+++ Resource/Init/pdf_font.ps
@@ -1514,10 +1514,12 @@ currentdict /CMap_read_dict undef
/buildCIDType0 { % <CIDFontType0-font-resource> buildCIDType0 <font>
dup /BaseFont get findCIDFont exch pop
+ addCIDmetrics /CIDFont defineresource
} bdef
/buildCIDType2 { % <CIDFontType2-font-resource> buildCIDType2 <font>
dup /BaseFont get findCIDFont exch pop
+ addCIDmetrics /CIDFont defineresource
} bdef
/processCIDToGIDMap { % <fontres> <cidfont> processCIDToGIDMap <fontres> <cidfont>
--- base/Makefile.in.orig 2009-12-18 07:04:10 UTC
+++ base/Makefile.in
@@ -47,9 +47,9 @@ PSD=$(PSGENDIR)/
# the directories also define the default search path for the
# initialization files (gs_*.ps) and the fonts.
-INSTALL = $(GLSRCDIR)/instcopy -c
-INSTALL_PROGRAM = $(INSTALL) -m 755
-INSTALL_DATA = $(INSTALL) -m 644
+INSTALL_PROGRAM = ${BSD_INSTALL_PROGRAM}
+INSTALL_SCRIPT = ${BSD_INSTALL_SCRIPT}
+INSTALL_DATA = ${BSD_INSTALL_DATA}
INSTALL_SHARED = @INSTALL_SHARED@
prefix = @prefix@
@@ -156,7 +156,7 @@ JSRCDIR=@LIBJPEGDIR@
# some older JPEG streams that violate the standard. If the JPEG
# library built from local sources, the patch will be applied.
-SHARE_JPEG=@SHARE_LIBJPEG@
+SHARE_JPEG=1
JPEG_NAME=jpeg
# Define the directory where the PNG library sources are stored,
@@ -164,12 +164,12 @@ JPEG_NAME=jpeg
# You may need to change this if the libpng version changes.
# See libpng.mak for more information.
-SHARE_LIBPNG=@SHARE_LIBPNG@
+SHARE_LIBPNG=1
PNGSRCDIR=@LIBPNGDIR@
LIBPNG_NAME=png
# libtiff
-SHARE_LIBTIFF=@SHARE_LIBTIFF@
+SHARE_LIBTIFF=1
TIFFSRCDIR=@LIBTIFFDIR@
TIFFPLATFORM=unix
TIFFCONFIG_SUFFIX=
@@ -178,7 +178,7 @@ LIBTIFF_NAME=tiff
# Define the directory where the zlib sources are stored.
# See zlib.mak for more information.
-SHARE_ZLIB=@SHARE_ZLIB@
+SHARE_ZLIB=1
ZSRCDIR=@ZLIBDIR@
#ZLIB_NAME=gz
ZLIB_NAME=z
@@ -254,7 +254,7 @@ GCFLAGS=@CPPFLAGS@ @GCFLAGS@ @CFLAGS@
# Define the added flags for standard, debugging, profiling
# and shared object builds.
-CFLAGS_STANDARD=@OPT_CFLAGS@
+CFLAGS_STANDARD?=@OPT_CFLAGS@
CFLAGS_DEBUG=-g -O0
CFLAGS_PROFILE=-pg @OPT_CFLAGS@
CFLAGS_SO=@DYNAMIC_CFLAGS@
@@ -299,7 +299,7 @@ LDFLAGS=@LDFLAGS@ $(XLDFLAGS)
# Solaris may need -lnsl -lsocket -lposix4.
# (Libraries required by individual drivers are handled automatically.)
-EXTRALIBS=@LIBS@ @DYNAMIC_LIBS@ @FONTCONFIG_LIBS@
+EXTRALIBS=@LIBS@ @DYNAMIC_LIBS@ @FONTCONFIG_LIBS@ -Wl,-export-dynamic
# Define the standard libraries to search at the end of linking.
# Most platforms require -lpthread for the POSIX threads library;
@@ -343,7 +343,7 @@ XLIBS=@X_LIBS@
# the pthread library. Otherwise use SYNC=nosync
#SYNC=posync
#SYNC=nosync
-SYNC=@SYNC@
+SYNC=nosync
# programs we use
RM=rm -f
@@ -436,27 +436,27 @@ DISPLAY_DEV=$(DD)bbox.dev
#DEVICE_DEVS20=$(DD)cljet5.dev $(DD)cljet5c.dev
#DEVICE_DEVS21=$(DD)spotcmyk.dev $(DD)devicen.dev $(DD)xcf.dev $(DD)psdcmyk.dev $(DD)psdrgb.dev
DEVICE_DEVS=$(DISPLAY_DEV) @X_DEVS@
-DEVICE_DEVS1=@FILES@
-DEVICE_DEVS2=@PRINTERS@
-DEVICE_DEVS3=@CUPSDEV@
-DEVICE_DEVS4=@IJSDEVS@
-DEVICE_DEVS5=@OMNIDEVS@
-DEVICE_DEVS6=@PNGDEVS@
-DEVICE_DEVS7=@JBIG2DEVS@
-DEVICE_DEVS8=$(DD)svgwrite.dev
-DEVICE_DEVS9=
-DEVICE_DEVS10=
-DEVICE_DEVS11=
-DEVICE_DEVS12=
-DEVICE_DEVS13=
-DEVICE_DEVS14=
-DEVICE_DEVS15=
-DEVICE_DEVS16=
-DEVICE_DEVS17=
-DEVICE_DEVS18=
-DEVICE_DEVS19=
-DEVICE_DEVS20=
-DEVICE_DEVS21=
+#DEVICE_DEVS1=@FILES@
+#DEVICE_DEVS2=@PRINTERS@
+#DEVICE_DEVS3=@CUPSDEV@
+#DEVICE_DEVS4=@IJSDEVS@
+#DEVICE_DEVS5=@OMNIDEVS@
+#DEVICE_DEVS6=@PNGDEVS@
+#DEVICE_DEVS7=@JBIG2DEVS@
+#DEVICE_DEVS8=$(DD)svgwrite.dev
+#DEVICE_DEVS9=
+#DEVICE_DEVS10=
+#DEVICE_DEVS11=
+#DEVICE_DEVS12=
+#DEVICE_DEVS13=
+#DEVICE_DEVS14=
+#DEVICE_DEVS15=
+#DEVICE_DEVS16=
+#DEVICE_DEVS17=
+#DEVICE_DEVS18=
+#DEVICE_DEVS19=
+#DEVICE_DEVS20=
+#DEVICE_DEVS21=
# Shared library target to build.
@@ -490,6 +490,7 @@ CC_SHARED=$(CC_) @DYNAMIC_LDFLAGS@
# ---------------- End of platform-specific section ---------------- #
INSTALL_CONTRIB=@INSTALL_CONTRIB@
+include $(GLSRCDIR)/drivers.mak
include $(GLSRCDIR)/unixhead.mak
include $(GLSRCDIR)/gs.mak
# psromfs.mak must precede lib.mak
--- base/configure.ac.orig 2009-11-24 08:36:27 UTC
+++ base/configure.ac
@@ -402,7 +402,7 @@ if test -f libpng/pngread.c; then
PNGDEVS="$PNGDEVS_ALL"
else
AC_MSG_RESULT([no])
- AC_CHECK_LIB(png, png_check_sig, [
+ AC_CHECK_LIB(png, png_sig_cmp, [
AC_CHECK_HEADERS(png.h, [
SHARE_LIBPNG=1
PNGDEVS="$PNGDEVS_ALL"
@@ -434,7 +434,7 @@ case "x$with_system_libtiff" in
AC_CHECK_LIB(tiff, TIFFOpen,
[AC_CHECK_HEADERS(tiff.h, [HAVE_SYSTEM_LIBTIFF=1;SHARE_LIBTIFF=1])],
[], [-ljpeg])
- if test -z $LOCAL_LIBTIFF_VERSION && test "x$HAVE_SYSTEM_LIBTIFF" == x; then
+ if test -z $LOCAL_LIBTIFF_VERSION && test "x$HAVE_SYSTEM_LIBTIFF" = x; then
AC_MSG_NOTICE([Could not find a copy of libtiff on your system.
Disabling tiff output devices.])
else
@@ -758,7 +758,7 @@ X_CFLAGS=""
X_DEVS=""
X_LIBS=""
-if test x$no_x != xyes; then
+if test x$with_x != xno; then
if test "$x_libraries" = "/usr/lib"; then
echo "Ignoring X library directory \"$x_libraries\" requested by configure."
x_libraries="NONE"
@@ -1063,7 +1063,11 @@ AC_ARG_ENABLE([dynamic], AC_HELP_STRING(
;;
*BSD)
DYNAMIC_CFLAGS="-fPIC"
- DYNAMIC_DEVS="\$(GLOBJDIR)/X11.so"
+ if test "x$X_DEVS" != x; then
+ INSTALL_SHARED="install-shared"
+ else
+ DYNAMIC_DEVS=""
+ fi
DYNAMIC_FLAGS="-DGS_DEVS_SHARED -DGS_DEVS_SHARED_DIR=\\\"\$(gssharedir)\\\""
DYNAMIC_LDFLAGS="-fPIC -shared"
DYNAMIC_LIBS=""
@@ -1119,11 +1123,11 @@ if test "x$fontpath" = "x"; then
fontpath="${fontpath}:$datadir/fonts/default/TrueType"
# These font directories are used by IRIX...
- fontpath="${fontpath}:/usr/lib/DPS/outline/base"
+ # fontpath="${fontpath}:/usr/lib/DPS/outline/base"
# These font directories are used by Solaris...
- fontpath="${fontpath}:/usr/openwin/lib/X11/fonts/Type1"
- fontpath="${fontpath}:/usr/openwin/lib/X11/fonts/TrueType"
+ # fontpath="${fontpath}:/usr/openwin/lib/X11/fonts/Type1"
+ # fontpath="${fontpath}:/usr/openwin/lib/X11/fonts/TrueType"
# This font directory is used by CUPS...
if test "x$CUPSCONFIG" != x; then
--- base/contrib.mak.orig 2009-04-28 22:11:03 UTC
+++ base/contrib.mak
@@ -858,3 +858,5 @@ $(DD)picty180.dev : $(cdeskjet_)
$(SETPDEV) $(DD)picty180 $(cdeskjet_)
#########################################################################
+
+include $(GLSRCDIR)/epag.contrib.mak
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Please register or to comment