Skip to content
GitLab
Menu
Why GitLab
Pricing
Contact Sales
Explore
Why GitLab
Pricing
Contact Sales
Explore
Sign in
Get free trial
Primary navigation
Search or go to…
Project
F
FreeBSD ports
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Wiki
Requirements
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Locked files
Build
Pipelines
Jobs
Pipeline schedules
Test cases
Artifacts
Deploy
Releases
Package Registry
Container Registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Code review analytics
Issue analytics
Insights
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Privacy statement
Keyboard shortcuts
?
What's new
4
Snippets
Groups
Projects
Show more breadcrumbs
FreeBSD
FreeBSD ports
Commits
d93e8970
Commit
d93e8970
authored
10 months ago
by
Yuri Victorovich
Browse files
Options
Downloads
Patches
Plain Diff
graphics/py-fury: update 0.9.0 → 0.10.0
Reported by: portscout
parent
b7ad9360
No related branches found
Branches containing commit
No related tags found
Tags containing commit
No related merge requests found
Changes
3
Hide whitespace changes
Inline
Side-by-side
Showing
3 changed files
graphics/py-fury/Makefile
+11
-6
11 additions, 6 deletions
graphics/py-fury/Makefile
graphics/py-fury/distinfo
+3
-3
3 additions, 3 deletions
graphics/py-fury/distinfo
graphics/py-fury/files/test-earth_8k.py
+18
-0
18 additions, 0 deletions
graphics/py-fury/files/test-earth_8k.py
with
32 additions
and
9 deletions
graphics/py-fury/Makefile
+
11
−
6
View file @
d93e8970
PORTNAME
=
fury
DISTVERSION
=
0.9.0
PORTREVISION
=
1
DISTVERSION
=
0.10.0
CATEGORIES
=
graphics
MASTER_SITES
=
PYPI
PKGNAMEPREFIX
=
${
PYTHON_PKGNAMEPREFIX
}
...
...
@@ -13,21 +12,27 @@ LICENSE= BSD3CLAUSE
LICENSE_FILE
=
${
WRKSRC
}
/LICENSE
PY_DEPENDS
=
${
PYTHON_PKGNAMEPREFIX
}
aiohttp>
=
3.8.4:www/py-aiohttp@
${
PY_FLAVOR
}
\
${
PY
THON_PKGNAMEPREFIX
}
numpy>
=
1.7.1:math/py-numpy@
${
PY_FLAVOR
}
\
${
PY
NUMPY
}
\
${
PYTHON_PKGNAMEPREFIX
}
packaging>0:devel/py-packaging@
${
PY_FLAVOR
}
\
${
PYTHON_PKGNAMEPREFIX
}
pillow>
=
8.0
.1:graphics/py-pillow@
${
PY_FLAVOR
}
\
${
PYTHON_PKGNAMEPREFIX
}
pygltflib>
=
1.15.
1
:graphics/py-pygltflib@
${
PY_FLAVOR
}
\
${
PYTHON_PKGNAMEPREFIX
}
scipy>
=
1.
4.
0:science/py-scipy@
${
PY_FLAVOR
}
\
${
PYTHON_PKGNAMEPREFIX
}
pillow>
=
5.4
.1:graphics/py-pillow@
${
PY_FLAVOR
}
\
${
PYTHON_PKGNAMEPREFIX
}
pygltflib>
=
1.15.
3
:graphics/py-pygltflib@
${
PY_FLAVOR
}
\
${
PYTHON_PKGNAMEPREFIX
}
scipy>
=
1.0:science/py-scipy@
${
PY_FLAVOR
}
\
vtk
${
VTK_VER:R
}
>
0:math/vtk
${
VTK_VER:R
}
BUILD_DEPENDS
=
${
PYTHON_PKGNAMEPREFIX
}
hatch-vcs>0:devel/py-hatch-vcs@
${
PY_FLAVOR
}
\
${
PYTHON_PKGNAMEPREFIX
}
hatchling>
=
0:devel/py-hatchling@
${
PY_FLAVOR
}
\
${
PY_DEPENDS
}
RUN_DEPENDS
=
${
PY_DEPENDS
}
TEST_DEPENDS
=
${
PYTHON_PKGNAMEPREFIX
}
matplotlib>
=
1.5.3:math/py-matplotlib@
${
PY_FLAVOR
}
USES
=
python
USE_PYTHON
=
pep517 autoplist pytest
# tests fail with signal 10, see https://github.com/fury-gl/fury/issues/795
TEST_ENV
=
${
MAKE_ENV
}
PYTHONPATH
=
${
STAGEDIR
}${
PYTHONPREFIX_SITELIBDIR
}
NO_ARCH
=
yes
test-simple
:
@${
SETENV
}
${
TEST_ENV
}
${
PYTHON_CMD
}
${
FILESDIR
}
/test-earth_8k.py
.
include
<../../math/vtk9/Makefile.version>
.
include
<bsd.port.mk>
This diff is collapsed.
Click to expand it.
graphics/py-fury/distinfo
+
3
−
3
View file @
d93e8970
TIMESTAMP = 1
686173980
SHA256 (fury-0.
9
.0.tar.gz) =
8f92cbb94ca04b7ee78047d83decb3735334f9bdff8b5a29bb1152b706cd71a6
SIZE (fury-0.
9
.0.tar.gz) = 68
194837
TIMESTAMP = 1
709859909
SHA256 (fury-0.
10
.0.tar.gz) =
a55eae00a949304156c75fe26b6e0130c5d7b172593ea626399b8b9eda5c78c7
SIZE (fury-0.
10
.0.tar.gz) = 68
627262
This diff is collapsed.
Click to expand it.
graphics/py-fury/files/test-earth_8k.py
0 → 100644
+
18
−
0
View file @
d93e8970
# from https://fury.gl/latest/auto_examples/01_introductory/viz_texture.html#sphx-glr-auto-examples-01-introductory-viz-texture-py
from
fury
import
actor
,
io
,
window
from
fury.data
import
fetch_viz_textures
,
read_viz_textures
scene
=
window
.
Scene
()
fetch_viz_textures
()
filename
=
read_viz_textures
(
'
1_earth_8k.jpg
'
)
image
=
io
.
load_image
(
filename
)
scene
.
add
(
actor
.
texture_on_sphere
(
image
))
interactive
=
True
if
interactive
:
window
.
show
(
scene
,
size
=
(
600
,
600
),
reset_camera
=
False
)
window
.
record
(
scene
,
size
=
(
900
,
768
),
out_path
=
'
viz_texture.png
'
)
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment