Skip to content
Snippets Groups Projects
Unverified Commit cf16b1c9 authored by Hiroki Sato's avatar Hiroki Sato
Browse files

devel/libspice-server: Remove "openssl" in spice-server.pc

- The "openssl" package listed in spice-server.pc prevented the
  library checking in the downstream software from working because
  OpenSSL in the base system does not use pkgconfig.

- Eliminate dependency on the old autoconf-archive.

Approved by:	maintainer timeout (1 month)
PR:		268819
parent 029a033e
No related branches found
No related tags found
No related merge requests found
PORTNAME= libspice-server
DISTVERSION= 0.15.0
PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= https://www.spice-space.org/download/releases/spice-server/
DISTNAME= spice-${PORTVERSION}
......@@ -11,8 +12,7 @@ WWW= https://spice-space.org/
LICENSE= GPLv2
LIB_DEPENDS= libopus.so:audio/opus
BUILD_DEPENDS= autoconf-archive>=0:devel/autoconf-archive \
spice-protocol>=0.12.10:devel/spice-protocol
BUILD_DEPENDS= spice-protocol>=0.12.10:devel/spice-protocol
OPTIONS_DEFINE= GSTREAMER LZ4 SASL STATISTICS
OPTIONS_DEFAULT= GSTREAMER LZ4 SASL
......@@ -31,7 +31,7 @@ SASL_LIB_DEPENDS= libsasl2.so:security/cyrus-sasl2
STATISTICS_CONFIGURE_ENABLE= statistics
USES= autoreconf:2.69 compiler:c++11-lang cpe gmake gnome jpeg \
USES= autoreconf compiler:c++11-lang cpe gmake gnome jpeg \
libtool localbase:ldflag pkgconfig python ssl tar:bzip2 xorg
USE_GNOME= glib20
......
--- configure.ac.orig 2021-04-17 06:49:29 UTC
+++ configure.ac
@@ -41,6 +41,7 @@ AC_PROG_CC_C99
if test x"$ac_cv_prog_cc_c99" = xno; then
AC_MSG_ERROR([C99 compiler is required.])
fi
+AC_PROG_CPP
AC_PROG_INSTALL
AC_CANONICAL_HOST
LT_INIT([disable-static])
@@ -204,7 +205,8 @@ AS_VAR_APPEND([SPICE_REQUIRES], [" pixman-1 >= $PIXMAN
PKG_CHECK_MODULES(SSL, openssl >= 1.0.0)
AC_SUBST(SSL_CFLAGS)
AC_SUBST(SSL_LIBS)
-AS_VAR_APPEND([SPICE_REQUIRES], [" openssl"])
+dnl OpenSSL in the base system is not managed by pkgconfig
+dnl AS_VAR_APPEND([SPICE_REQUIRES], [" openssl"])
save_CFLAGS="$CFLAGS"
CFLAGS="$CFLAGS $SSL_CFLAGS"
@@ -217,15 +219,16 @@ CFLAGS="$save_CFLAGS"
AC_CHECK_LIB(jpeg, jpeg_destroy_decompress,
AC_MSG_CHECKING([for jpeglib.h])
- AC_TRY_CPP(
-[#include <stdio.h>
+ AC_PREPROC_IFELSE(
+[AC_LANG_SOURCE([[
+#include <stdio.h>
#undef PACKAGE
#undef VERSION
#undef HAVE_STDLIB_H
-#include <jpeglib.h>],
- JPEG_LIBS='-ljpeg'
- AC_MSG_RESULT($jpeg_ok),
- AC_MSG_ERROR([jpeglib.h not found])),
+#include <jpeglib.h>]])],
+ [JPEG_LIBS='-ljpeg'
+ AC_MSG_RESULT($jpeg_ok)],
+ [AC_MSG_ERROR([jpeglib.h not found])]),
AC_MSG_ERROR([libjpeg not found]))
AC_SUBST(JPEG_LIBS)
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment