Skip to content
GitLab
Menu
Why GitLab
Pricing
Contact Sales
Explore
Why GitLab
Pricing
Contact Sales
Explore
Sign in
Get free trial
Primary navigation
Search or go to…
Project
F
FreeBSD ports
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Wiki
Requirements
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Locked files
Build
Pipelines
Jobs
Pipeline schedules
Test cases
Artifacts
Deploy
Releases
Package registry
Container registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Code review analytics
Issue analytics
Insights
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Privacy statement
Keyboard shortcuts
?
What's new
3
Snippets
Groups
Projects
Show more breadcrumbs
FreeBSD
FreeBSD ports
Commits
cd1837f2
Verified
Commit
cd1837f2
authored
1 year ago
by
sunpoet
Browse files
Options
Downloads
Patches
Plain Diff
math/or-tools: Fix build with abseil 20230125.0+ and re2 20230601+
Reference:
https://github.com/google/or-tools/issues/3655
parent
5740e7fe
No related branches found
No related tags found
No related merge requests found
Changes
2
Show whitespace changes
Inline
Side-by-side
Showing
2 changed files
math/or-tools/Makefile
+1
-0
1 addition, 0 deletions
math/or-tools/Makefile
math/or-tools/files/patch-abseil
+20
-0
20 additions, 0 deletions
math/or-tools/files/patch-abseil
with
21 additions
and
0 deletions
math/or-tools/Makefile
+
1
−
0
View file @
cd1837f2
...
...
@@ -35,6 +35,7 @@ USE_LDCONFIG= yes
CMAKE_OFF
=
BUILD_PYTHON BUILD_DEPS INSTALL_BUILD_DEPS BUILD_EXAMPLES BUILD_SAMPLES
CMAKE_ON
=
BUILD_CXX
CMAKE_TESTING_ON
=
BUILD_EXAMPLES BUILD_CXX_EXAMPLES
CXXFLAGS
+=
-DABSL_LEGACY_THREAD_ANNOTATIONS
CONFIGURE_ENV
=
UNIX_CBC_DIR=
${
LOCALBASE
}
UNIX_CLP_DIR=
${
LOCALBASE
}
...
...
This diff is collapsed.
Click to expand it.
math/or-tools/files/patch-abseil
0 → 100644
+
20
−
0
View file @
cd1837f2
--- ortools/lp_data/lp_parser.cc.orig 2022-11-25 09:21:54 UTC
+++ ortools/lp_data/lp_parser.cc
@@ -185,7 +185,7 @@
bool LPParser::ParseIntegerVariablesList(StringPiece l
bool LPParser::ParseConstraint(StringPiece constraint) {
const StatusOr<ParsedConstraint> parsed_constraint_or_status =
- ::operations_research::glop::ParseConstraint(constraint.as_string());
+ ::operations_research::glop::ParseConstraint(std::string(constraint));
if (!parsed_constraint_or_status.ok()) return false;
const ParsedConstraint& parsed_constraint =
parsed_constraint_or_status.value();
@@ -414,7 +414,7 @@
StatusOr<ParsedConstraint> ParseConstraint(absl::strin
if (ConsumeToken(&constraint, &consumed_name, &consumed_coeff) !=
TokenType::END) {
return absl::InvalidArgumentError(absl::StrCat(
- "End of input was expected, found: ", constraint.as_string()));
+ "End of input was expected, found: ", std::string(constraint)));
}
}
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment