Skip to content
Snippets Groups Projects
Commit c9befd7a authored by Dan Langille's avatar Dan Langille
Browse files

security/rhonabwy: New port: JOSE library

Javascript Object Signing and Encryption (JOSE) library
- JWK, JWKS, JWS, JWE and JWT
parent c809a09b
No related branches found
No related tags found
No related merge requests found
......@@ -1009,6 +1009,7 @@
SUBDIR += rcracki_mt
SUBDIR += reop
SUBDIR += rhash
SUBDIR += rhonabwy
SUBDIR += ridl
SUBDIR += rifiuti2
SUBDIR += rkhunter
......
PORTNAME= rhonabwy
DISTVERSIONPREFIX= v
DISTVERSION= 1.1.6
CATEGORIES= security
MAINTAINER= dvl@FreeBSD.org
COMMENT= Javascript Object Signing and Encryption (JOSE) library
LICENSE= LGPL21
LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= yder>1.4.14:devel/yder \
orcania>2.2.1:devel/orcania \
gnutls>0:security/gnutls
LIB_DEPENDS= libcurl.so:ftp/curl \
libgmp.so:math/gmp \
libnettle.so:security/nettle \
libjansson.so:devel/jansson \
libgnutls.so:security/gnutls \
liborcania.so:devel/orcania \
libyder.so:devel/yder
USES= cmake
USE_GITHUB= yes
GH_ACCOUNT= babelouest
CMAKE_ARGS= -DWITH_JOURNALD=off
.include <bsd.port.mk>
TIMESTAMP = 1657299018
SHA256 (babelouest-rhonabwy-v1.1.6_GH0.tar.gz) = 45620a9532104687d7c778b0c8b2390b8c0e5c82c8d8d491937d43063a1dec77
SIZE (babelouest-rhonabwy-v1.1.6_GH0.tar.gz) = 379922
--- CMakeLists.txt.orig 2022-07-08 18:38:40 UTC
+++ CMakeLists.txt
@@ -171,7 +171,7 @@ set_target_properties(rhonabwy PROPERTIES
PUBLIC_HEADER "${INC_DIR}/rhonabwy.h;${PROJECT_BINARY_DIR}/rhonabwy-cfg.h"
VERSION "${LIBRARY_VERSION}"
SOVERSION "${LIBRARY_SOVERSION}")
-target_link_libraries(rhonabwy ${LIBS})
+target_link_libraries(rhonabwy ${LIBS} -L${CMAKE_INSTALL_PREFIX}/lib -lgmp)
set(SEARCH_ORCANIA OFF CACHE BOOL "Force to false") # Avoid to search and download orcania during yder search and download
set(SEARCH_ORCANIA_U OFF CACHE BOOL "Force to false") # Avoid to search and download orcania during ulfius search and download
--- cmake-modules/FindNettle.cmake.orig 2022-07-08 18:30:56 UTC
+++ cmake-modules/FindNettle.cmake
@@ -40,12 +40,16 @@ find_library(NETTLE_LIBRARY
NAMES nettle libnettle
HINTS ${PC_NETTLE_LIBDIR} ${PC_NETTLE_LIBRARY_DIRS})
+find_library(HOGWEED_LIBRARY
+ NAMES hogweed libhogweed
+ HINTS ${PC_NETTLE_LIBDIR} ${PC_NETTLE_LIBRARY_DIRS})
+
include(FindPackageHandleStandardArgs)
find_package_handle_standard_args(Nettle
REQUIRED_VARS NETTLE_LIBRARY NETTLE_INCLUDE_DIR)
if (NETTLE_FOUND)
- set(NETTLE_LIBRARIES ${NETTLE_LIBRARY})
+ set(NETTLE_LIBRARIES ${NETTLE_LIBRARY} ${HOGWEED_LIBRARY})
set(NETTLE_INCLUDE_DIRS ${NETTLE_INCLUDE_DIR})
endif ()
Single-Sign-On (SSO) server with multiple factor authentication.
Authentication processes supported:
* OAuth2
* OpenID Connect
* Allows users to authenticate via multiple factors:
Password
* One-time password (TOTP/HOTP)
* Webauthn (Yubikey, Android devices)
* One-time password sent via e-mail
* TLS Certificate
* Users and clients can be stored and managed from various backends:
Database
* LDAP service
* HTTP Backend service providing Basic Authentication
WWW: https://github.com/babelouest/glewlwyd
bin/rnbyc
include/rhonabwy-cfg.h
include/rhonabwy.h
lib/librhonabwy.so
lib/librhonabwy.so.1.1
lib/librhonabwy.so.1.1.6
libdata/pkgconfig/librhonabwy.pc
share/man/man1/rnbyc.1.gz
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment