Skip to content
GitLab
Menu
Why GitLab
Pricing
Contact Sales
Explore
Why GitLab
Pricing
Contact Sales
Explore
Sign in
Get free trial
Primary navigation
Search or go to…
Project
F
FreeBSD ports
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Wiki
Requirements
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Locked files
Build
Pipelines
Jobs
Pipeline schedules
Test cases
Artifacts
Deploy
Releases
Package registry
Container registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Code review analytics
Issue analytics
Insights
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Privacy statement
Keyboard shortcuts
?
What's new
3
Snippets
Groups
Projects
Show more breadcrumbs
FreeBSD
FreeBSD ports
Commits
c7f1f693
Commit
c7f1f693
authored
3 years ago
by
Piotr Kubaj
Browse files
Options
Downloads
Patches
Plain Diff
math/pffft: remove -march=native
parent
4e73dc01
Branches
Branches containing commit
Tags
Tags containing commit
No related merge requests found
Changes
1
Show whitespace changes
Inline
Side-by-side
Showing
1 changed file
math/pffft/files/patch-CMakeLists.txt
+14
-5
14 additions, 5 deletions
math/pffft/files/patch-CMakeLists.txt
with
14 additions
and
5 deletions
math/pffft/files/patch-CMakeLists.txt
+
14
−
5
View file @
c7f1f693
...
...
@@ -9,7 +9,16 @@
set_target_properties(PFFFT PROPERTIES OUTPUT_NAME "pffft")
target_compile_definitions(PFFFT PRIVATE _USE_MATH_DEFINES)
if (USE_SCALAR_VECT)
@@ -193,7 +193,7 @@ endif()
@@ -173,8 +173,6 @@ if (USE_SIMD AND USE_TYPE_DOUBLE)
else()
set_property(SOURCE pffft_double.c PROPERTY COMPILE_FLAGS "-mavx")
endif()
- else()
- set_property(SOURCE pffft_double.c PROPERTY COMPILE_FLAGS "-march=native")
endif()
if(DISABLE_SIMD_AVX)
target_compile_definitions(PFFFT PRIVATE PFFFT_AVX_DISABLE=1)
@@ -193,7 +191,7 @@ endif()
if (USE_TYPE_FLOAT)
...
...
@@ -18,7 +27,7 @@
set_target_properties(PFDSP PROPERTIES OUTPUT_NAME "pfdsp")
target_compile_definitions(PFDSP PRIVATE _USE_MATH_DEFINES)
if (USE_DEBUG_ASAN)
@@ -218,7 +21
8
,7 @@ endif()
@@ -218,7 +21
6
,7 @@ endif()
if (USE_FFTPACK)
# float / single precision
...
...
@@ -27,7 +36,7 @@
target_compile_definitions(FFTPACK_FLOAT PRIVATE _USE_MATH_DEFINES)
target_compile_options(FFTPACK_FLOAT PRIVATE $<$<C_COMPILER_ID:GNU>:-Wall -Wextra -pedantic>)
target_link_libraries( FFTPACK_FLOAT ${MATHLIB} )
@@ -227,7 +22
7
,7 @@ if (USE_FFTPACK)
@@ -227,7 +22
5
,7 @@ if (USE_FFTPACK)
)
# double precision
...
...
@@ -36,7 +45,7 @@
target_compile_definitions(FFTPACK_DOUBLE PRIVATE _USE_MATH_DEFINES)
target_compile_definitions(FFTPACK_DOUBLE PUBLIC FFTPACK_DOUBLE_PRECISION)
target_compile_options(FFTPACK_DOUBLE PRIVATE $<$<C_COMPILER_ID:GNU>:-Wall -Wextra -pedantic>)
@@ -251,7 +2
51
,7 @@ endif()
@@ -251,7 +2
49
,7 @@ endif()
if (USE_TYPE_FLOAT)
# only 'float' supported in PFFASTCONV
...
...
@@ -45,7 +54,7 @@
set_target_properties(PFFASTCONV PROPERTIES OUTPUT_NAME "pffastconv")
target_compile_definitions(PFFASTCONV PRIVATE _USE_MATH_DEFINES)
if (USE_DEBUG_ASAN)
@@ -447,7 +44
7
,9 @@ endif()
@@ -447,7 +44
5
,9 @@ endif()
######################################################
...
...
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment