Skip to content
Snippets Groups Projects
Verified Commit c7ce20ed authored by sunpoet's avatar sunpoet
Browse files

www/cpr: Update to 1.10.0

parent 5351d02b
No related branches found
No related tags found
No related merge requests found
PORTNAME= cpr
PORTVERSION= 1.9.3
PORTVERSION= 1.10.0
CATEGORIES= www
MAINTAINER= sunpoet@FreeBSD.org
......@@ -11,10 +11,10 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
LIB_DEPENDS= libcurl.so:ftp/curl
USES= cmake compiler:c++11-lang ssl
USES= cmake compiler:c++17-lang ssl
CMAKE_OFF= CPR_BUILD_TESTS CPR_BUILD_TESTS_SSL CPR_CURL_NOSIGNAL CPR_FORCE_DARWINSSL_BACKEND CPR_FORCE_WINSSL_BACKEND CPR_GENERATE_COVERAGE CPR_USE_SYSTEM_GTEST
CMAKE_ON= BUILD_SHARED_LIBS CPR_ENABLE_SSL CPR_FORCE_OPENSSL_BACKEND CPR_FORCE_USE_SYSTEM_CURL
CMAKE_OFF= CPR_BUILD_TESTS CPR_BUILD_TESTS_PROXY CPR_BUILD_TESTS_SSL CPR_CURL_NOSIGNAL CPR_DEBUG_SANITIZER_FLAG_ADDR CPR_DEBUG_SANITIZER_FLAG_ALL CPR_DEBUG_SANITIZER_FLAG_LEAK CPR_DEBUG_SANITIZER_FLAG_THREAD CPR_DEBUG_SANITIZER_FLAG_UB CPR_ENABLE_CPPCHECK CPR_ENABLE_CURL_HTTP_ONLY CPR_ENABLE_LINTING CPR_GENERATE_COVERAGE CPR_USE_BOOST_FILESYSTEM CPR_USE_SYSTEM_GTEST CURL_VERBOSE_LOGGING
CMAKE_ON= BUILD_SHARED_LIBS BUILD_STATIC_LIBS CPR_ENABLE_SSL CPR_SKIP_CA_BUNDLE_SEARCH CPR_USE_SYSTEM_CURL
PLIST_SUB= PORTVERSION=${PORTVERSION}
......
TIMESTAMP = 1674589560
SHA256 (libcpr-cpr-1.9.3_GH0.tar.gz) = df53e7213d80fdc24583528521f7d3349099f5bb4ed05ab05206091a678cc53c
SIZE (libcpr-cpr-1.9.3_GH0.tar.gz) = 111834
TIMESTAMP = 1675190947
SHA256 (libcpr-cpr-1.10.0_GH0.tar.gz) = d669c028bd63a1c8827c32b348ecc85e46747bb33be3b00ce59b77717b91aee8
SIZE (libcpr-cpr-1.10.0_GH0.tar.gz) = 130750
--- CMakeLists.txt.orig 2023-01-26 16:47:20 UTC
+++ CMakeLists.txt
@@ -1,5 +1,5 @@
cmake_minimum_required(VERSION 3.15)
-project(cpr VERSION 1.9.0 LANGUAGES CXX)
+project(cpr VERSION 1.10.0 LANGUAGES CXX)
math(EXPR cpr_VERSION_NUM "${cpr_VERSION_MAJOR} * 0x10000 + ${cpr_VERSION_MINOR} * 0x100 + ${cpr_VERSION_PATCH}" OUTPUT_FORMAT HEXADECIMAL)
configure_file("${cpr_SOURCE_DIR}/cmake/cprver.h.in" "${cpr_BINARY_DIR}/cpr_generated_includes/cpr/cprver.h")
--- include/CMakeLists.txt.orig 2023-01-26 16:47:20 UTC
+++ include/CMakeLists.txt
@@ -60,7 +60,7 @@ if(CPR_USE_BOOST_FILESYSTEM)
endif()
endif()
-if (((CMAKE_CXX_COMPILER_ID STREQUAL "GNU" AND CMAKE_CXX_COMPILER_VERSION VERSION_LESS 9.1) OR CMAKE_CXX_COMPILER_ID STREQUAL "Clang") AND NOT CPR_USE_BOOST_FILESYSTEM)
+if (CMAKE_CXX_COMPILER_ID STREQUAL "GNU" AND CMAKE_CXX_COMPILER_VERSION VERSION_LESS 9.1 AND NOT CPR_USE_BOOST_FILESYSTEM)
target_link_libraries(cpr PUBLIC stdc++fs)
endif()
include/cpr/accept_encoding.h
include/cpr/api.h
include/cpr/async.h
include/cpr/async_wrapper.h
include/cpr/auth.h
include/cpr/bearer.h
include/cpr/body.h
......@@ -14,8 +15,10 @@ include/cpr/cprtypes.h
include/cpr/cprver.h
include/cpr/curl_container.h
include/cpr/curlholder.h
include/cpr/curlmultiholder.h
include/cpr/error.h
include/cpr/file.h
include/cpr/filesystem.h
include/cpr/http_version.h
include/cpr/interceptor.h
include/cpr/interface.h
......@@ -24,6 +27,7 @@ include/cpr/local_port.h
include/cpr/local_port_range.h
include/cpr/low_speed.h
include/cpr/multipart.h
include/cpr/multiperform.h
include/cpr/parameters.h
include/cpr/payload.h
include/cpr/proxies.h
......@@ -31,6 +35,7 @@ include/cpr/proxyauth.h
include/cpr/range.h
include/cpr/redirect.h
include/cpr/reserve_size.h
include/cpr/resolve.h
include/cpr/response.h
include/cpr/session.h
include/cpr/singleton.h
......
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment