Skip to content
GitLab
Next
Menu
Why GitLab
Pricing
Contact Sales
Explore
Why GitLab
Pricing
Contact Sales
Explore
Sign in
Get free trial
Primary navigation
Search or go to…
Project
F
FreeBSD ports
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Wiki
Requirements
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Locked files
Build
Pipelines
Jobs
Pipeline schedules
Test cases
Artifacts
Deploy
Releases
Package registry
Container registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Code review analytics
Issue analytics
Insights
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Privacy statement
Keyboard shortcuts
?
What's new
6
Snippets
Groups
Projects
Show more breadcrumbs
FreeBSD
FreeBSD ports
Commits
c3ff3096
Commit
c3ff3096
authored
3 years ago
by
Yuri Victorovich
Browse files
Options
Downloads
Patches
Plain Diff
devel/google-perftools: Add LD_32_PRELOAD to the valgrind detection code
Suggested by: Paul Floyd <pjfloyd@wanadoo.fr>
parent
0bae2dd0
No related branches found
No related tags found
No related merge requests found
Changes
2
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
devel/google-perftools/Makefile
+1
-1
1 addition, 1 deletion
devel/google-perftools/Makefile
devel/google-perftools/files/patch-src_base_dynamic__annotations.c
+4
-2
4 additions, 2 deletions
...gle-perftools/files/patch-src_base_dynamic__annotations.c
with
5 additions
and
3 deletions
devel/google-perftools/Makefile
+
1
−
1
View file @
c3ff3096
...
...
@@ -3,7 +3,7 @@
PORTNAME
=
google-perftools
DISTVERSIONPREFIX
=
gperftools-
DISTVERSION
=
2.9.1
PORTREVISION
=
2
PORTREVISION
=
3
CATEGORIES
=
devel
MASTER_SITES
=
https://github.com/gperftools/gperftools/releases/download/gperftools-
${
PORTVERSION
}
/
DISTNAME
=
gperftools-
${
PORTVERSION
}
...
...
This diff is collapsed.
Click to expand it.
devel/google-perftools/files/patch-src_base_dynamic__annotations.c
+
4
−
2
View file @
c3ff3096
...
...
@@ -3,13 +3,15 @@
---
src
/
base
/
dynamic_annotations
.
c
.
orig
2021
-
02
-
15
06
:
44
:
21
UTC
+++
src
/
base
/
dynamic_annotations
.
c
@@
-
43
,
6
+
43
,
1
9
@@
@@
-
43
,
6
+
43
,
2
1
@@
#include
"base/dynamic_annotations.h"
#include
"getenv_safe.h"
// for TCMallocGetenvSafe
+
static
int
running_on_valgrind_preload
=
-
1
;
+
void
__attribute__
((
constructor
))
premain
()
{
+
char
*
LD_PRELOAD
=
getenv
(
"LD_PRELOAD"
);
+
if
(
LD_PRELOAD
==
NULL
)
+
LD_PRELOAD
=
getenv
(
"LD_32_PRELOAD"
);
+
running_on_valgrind_preload
=
LD_PRELOAD
!=
NULL
&&
+
(
+
strstr
(
LD_PRELOAD
,
"/valgrind/"
)
!=
NULL
...
...
@@ -23,7 +25,7 @@
static
int
GetRunningOnValgrind
(
void
)
{
#ifdef RUNNING_ON_VALGRIND
if
(
RUNNING_ON_VALGRIND
)
return
1
;
@@
-
51
,
6
+
6
4
,
11
@@
static
int
GetRunningOnValgrind
(
void
)
{
@@
-
51
,
6
+
6
6
,
11
@@
static
int
GetRunningOnValgrind
(
void
)
{
if
(
running_on_valgrind_str
)
{
return
strcmp
(
running_on_valgrind_str
,
"0"
)
!=
0
;
}
...
...
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment