Skip to content
Snippets Groups Projects
Commit bfdb36ac authored by Neel Chauhan's avatar Neel Chauhan
Browse files

x11/gnome-console: New port

parent e57c55d7
No related branches found
No related tags found
No related merge requests found
......@@ -80,6 +80,7 @@
SUBDIR += gmrun
SUBDIR += gnome
SUBDIR += gnome-clipboard-daemon
SUBDIR += gnome-console
SUBDIR += gnome-desktop
SUBDIR += gnome-menus
SUBDIR += gnome-pie
......
PORTNAME= gnome-console
PORTVERSION= 42.2
CATEGORIES= x11 gnome
MASTER_SITES= GNOME/sources/${PORTNAME}/${PORTVERSION:C/^([0-9]+)\..*/\1/}
DIST_SUBDIR= gnome
MAINTAINER= gnome@FreeBSD.org
COMMENT= Minimal terminal for GNOME
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/COPYING
BUILD_DEPENDS= itstool>0:textproc/itstool \
sassc>0:textproc/sassc
LIB_DEPENDS= libenchant-2.so:textproc/enchant2 \
libgtop-2.0.so:devel/libgtop \
libhandy-1.so:x11-toolkits/libhandy \
libicudata.so:devel/icu \
libpcre2-8.so:devel/pcre2 \
libvte-2.91.so:x11-toolkits/vte3
USES= compiler:c11 desktop-file-utils gettext gnome localbase meson \
pkgconfig tar:xz
USE_CSTD= c11
USE_GNOME= gtk30 gtksourceview5 libadwaita
GLIB_SCHEMAS= org.gnome.Console.gschema.xml
PORTSCOUT= limitw:1,even
.include <bsd.port.mk>
TIMESTAMP = 1657835361
SHA256 (gnome/gnome-console-42.2.tar.xz) = 7d26e6c18744c575a787293263f60ceff630107098e9e58a7765b00ac7437049
SIZE (gnome/gnome-console-42.2.tar.xz) = 152288
--- src/kgx-pages.c.orig 2022-07-14 22:39:12 UTC
+++ src/kgx-pages.c
@@ -835,7 +835,9 @@ kgx_pages_get_children (KgxPages *self)
GPtrArray *children;
guint n;
+#ifndef __FreeBSD__
g_return_val_if_fail (KGX_IS_PAGES (self), KGX_NONE);
+#endif
priv = kgx_pages_get_instance_private (self);
--- src/kgx-window.c.orig 2022-07-14 22:37:21 UTC
+++ src/kgx-window.c
@@ -83,7 +83,6 @@ kgx_window_constructed (GObject *object)
kgx_window_constructed (GObject *object)
{
KgxWindow *self = KGX_WINDOW (object);
- g_autoptr (GError) error = NULL;
GtkApplication *application = NULL;
HdyStyleManager *style_manager;
Console is a minimal terminal for GNOME
Console is supposed to be a simple terminal emulator for the average user
to carry out simple cli tasks and aims to be a ‘core’ app for GNOME/Phosh.
We are not however trying to replace GNOME Terminal/Tilix, these advanced
tools are great for developers and administrators, rather Console aims to
serve the casual linux user who rarely needs a terminal
WWW: https://gitlab.gnome.org/GNOME/console
bin/kgx
share/applications/org.gnome.Console.desktop
share/dbus-1/services/org.gnome.Console.service
share/icons/hicolor/scalable/apps/org.gnome.Console.svg
share/icons/hicolor/symbolic/apps/org.gnome.Console-symbolic.svg
share/locale/bg/LC_MESSAGES/kgx.mo
share/locale/ca/LC_MESSAGES/kgx.mo
share/locale/cs/LC_MESSAGES/kgx.mo
share/locale/da/LC_MESSAGES/kgx.mo
share/locale/de/LC_MESSAGES/kgx.mo
share/locale/el/LC_MESSAGES/kgx.mo
share/locale/en_GB/LC_MESSAGES/kgx.mo
share/locale/es/LC_MESSAGES/kgx.mo
share/locale/eu/LC_MESSAGES/kgx.mo
share/locale/fa/LC_MESSAGES/kgx.mo
share/locale/fi/LC_MESSAGES/kgx.mo
share/locale/fr/LC_MESSAGES/kgx.mo
share/locale/fur/LC_MESSAGES/kgx.mo
share/locale/gl/LC_MESSAGES/kgx.mo
share/locale/he/LC_MESSAGES/kgx.mo
share/locale/hr/LC_MESSAGES/kgx.mo
share/locale/hu/LC_MESSAGES/kgx.mo
share/locale/id/LC_MESSAGES/kgx.mo
share/locale/it/LC_MESSAGES/kgx.mo
share/locale/ja/LC_MESSAGES/kgx.mo
share/locale/kk/LC_MESSAGES/kgx.mo
share/locale/ko/LC_MESSAGES/kgx.mo
share/locale/lt/LC_MESSAGES/kgx.mo
share/locale/nb/LC_MESSAGES/kgx.mo
share/locale/ne/LC_MESSAGES/kgx.mo
share/locale/nl/LC_MESSAGES/kgx.mo
share/locale/oc/LC_MESSAGES/kgx.mo
share/locale/pa/LC_MESSAGES/kgx.mo
share/locale/pl/LC_MESSAGES/kgx.mo
share/locale/pt/LC_MESSAGES/kgx.mo
share/locale/pt_BR/LC_MESSAGES/kgx.mo
share/locale/ro/LC_MESSAGES/kgx.mo
share/locale/ru/LC_MESSAGES/kgx.mo
share/locale/sk/LC_MESSAGES/kgx.mo
share/locale/sl/LC_MESSAGES/kgx.mo
share/locale/sr/LC_MESSAGES/kgx.mo
share/locale/sv/LC_MESSAGES/kgx.mo
share/locale/tr/LC_MESSAGES/kgx.mo
share/locale/uk/LC_MESSAGES/kgx.mo
share/locale/vi/LC_MESSAGES/kgx.mo
share/locale/zh_CN/LC_MESSAGES/kgx.mo
share/metainfo/org.gnome.Console.metainfo.xml
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment