ld: error: can't create dynamic relocation R_AARCH64_ABS64 against local symbol in readonly segment; recompile object files with -fPIC or pass '-Wl,-z,notext' to allow text relocations in the output
>>> defined in loader/CMakeFiles/vulkan.dir/unknown_ext_chain_gas_aarch64.S.o
>>> referenced by loader/CMakeFiles/vulkan.dir/unknown_ext_chain_gas_aarch64.S.o:(.text+0x61A8)
-- The ASM compiler identification is Clang
-- Found assembler: /usr/bin/cc
CMake Warning at loader/CMakeLists.txt:252 (message):
...
...
@@ -19,22 +15,18 @@ CMake Error at loader/CMakeLists.txt:332 (target_compile_definitions):
Cannot specify compile definitions for target "asm_offset" which is not
built by this project.
--- loader/CMakeLists.txt.orig 2021-11-16 19:22:26 UTC
--- loader/CMakeLists.txt.orig 2021-12-20 16:46:42 UTC
+++ loader/CMakeLists.txt
@@ -228,8 +228,11 @@ else(UNIX AND NOT APPLE) # i.e.: Linux