Skip to content
Snippets Groups Projects
Commit b172a2c1 authored by Piotr Kubaj's avatar Piotr Kubaj
Browse files

net/intel-ice-kmod: add a port for Intel 100G driver

parent 24ad47b2
Branches
Tags
No related merge requests found
......@@ -276,6 +276,7 @@
SUBDIR += imapproxy
SUBDIR += incidenceeditor
SUBDIR += intel-em-kmod
SUBDIR += intel-ice-kmod
SUBDIR += intel-igb-kmod
SUBDIR += intel-ix-kmod
SUBDIR += intel-ixl-kmod
......
PORTNAME= ice
PORTVERSION= 1.37.11
PORTEPOCH= 0
MASTER_SITES?= https://downloadmirror.intel.com/772531/
MAINTAINER= freebsd@intel.com
COMMENT= Intel® Network Adapter Driver for E810 Series Devices
MANPAGENAME= ice
MANPAGELINKS= if_ice
MASTERDIR= ${.CURDIR}/../intel-ixl-kmod
PATCHDIR= ${.CURDIR}/files
PKGDIR= ${.CURDIR}
DISTINFO_FILE= ${.CURDIR}/distinfo
WRKSRC_SUBDIR=
OPTIONS_DEFINE= SRIOV
SRIOV_DESC= Enable SR-IOV support (experimental)
SRIOV_MAKE_ENV= SRIOV_ENABLE=1
SRIOV_MAKE_ENV_OFF= SRIOV_ENABLE=0
.include "${MASTERDIR}/Makefile"
TIMESTAMP = 1686582215
SHA256 (ice-1.37.11.tar.gz) = 628675f6a5a4b72746365a8efb11b7758f781e8541f3de3ae47468b673e9c1f3
SIZE (ice-1.37.11.tar.gz) = 578969
--- if_ice_iflib.c.orig 2023-06-12 15:11:11 UTC
+++ if_ice_iflib.c
@@ -287,8 +287,12 @@ static struct if_shared_ctx ice_sctx = {
*
* device class used to setup the ice driver module kobject class.
*/
+#if __FreeBSD_version >= 1400058
+DRIVER_MODULE(ice, pci, ice_driver, ice_module_event_handler, 0);
+#else
devclass_t ice_devclass;
DRIVER_MODULE(ice, pci, ice_driver, ice_devclass, ice_module_event_handler, 0);
+#endif
MODULE_VERSION(ice, 1);
MODULE_DEPEND(ice, pci, 1, 1, 1);
This release includes the 10 gigabit FreeBSD*-based driver for Intel(R) Network
Connections.
The ix driver supports all 10 gigabit network connections based on
82599, 82598EB, X520, X540, and X550 series controllers.
......@@ -27,7 +27,7 @@ NETMAP_OFF_DESC= Disable netmap(4) support unconditionally
NETMAP_ON_CFLAGS= -DDEV_NETMAP
NETMAP_OFF_CFLAGS= -UDEV_NETMAP
WRKSRC_SUBDIR= src
WRKSRC_SUBDIR?= src
SUB_FILES= pkg-message
SUB_LIST= PORTNAME=${PORTNAME}
......
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Please register or to comment