Skip to content
Snippets Groups Projects
Commit ae334add authored by Mateusz Piotrowski's avatar Mateusz Piotrowski
Browse files

security/sssd: Fix pkg-plist and chase krb5 update

This patch fixes two issues.

The first issue was presence of missing files of the SSSDConfig Python
module: PKG-INFO, SOURCES.txt, dependency_links., and top_level.txt. It
looks like those files are not installed anymore so let's just remove
them from pkg-plist.

The other issue was the build system not accepting the new version of
secruity/krb5. The fix is to patch sssd's build system to accept the new
version. This is how we fixed previous incarnations of this bug in the
past.

PR:		271939
Reported by:	ddrinnon@cdor.net
Fixes:	7228a09d security/krb5: krb5-121 is now default
MFH:		2023Q3
Sponsored by:	Klara Inc.
parent 9b5538c5
No related branches found
No related tags found
No related merge requests found
PORTNAME= sssd
PORTVERSION= 1.16.5
PORTREVISION= 9
PORTREVISION= 10
CATEGORIES= security
MASTER_SITES= https://releases.pagure.org/SSSD/${PORTNAME}/
......
......@@ -9,7 +9,7 @@
AC_MSG_CHECKING(for supported MIT krb5 version)
KRB5_VERSION="`$KRB5_CONFIG --version`"
case $KRB5_VERSION in
@@ -19,7 +19,10 @@ then
@@ -19,7 +19,11 @@ then
Kerberos\ 5\ release\ 1.14* | \
Kerberos\ 5\ release\ 1.15* | \
Kerberos\ 5\ release\ 1.16* | \
......@@ -17,7 +17,8 @@
+ Kerberos\ 5\ release\ 1.17* | \
+ Kerberos\ 5\ release\ 1.18* | \
+ Kerberos\ 5\ release\ 1.19* | \
+ Kerberos\ 5\ release\ 1.20*)
+ Kerberos\ 5\ release\ 1.20* | \
+ Kerberos\ 5\ release\ 1.21*)
krb5_version_ok=yes
AC_MSG_RESULT([yes])
;;
......@@ -34,10 +34,6 @@ lib/nss_sss.so.2
lib/nss_sss.so.2.0.0
lib/pam_sss.so
%%NO_SMB%%%%PYTHON_SITELIBDIR%%/SSSDConfig-1.16.5-py%%PYTHON_VER%%.egg-info
%%SMB%%%%PYTHON_SITELIBDIR%%/SSSDConfig-1.16.5-py%%PYTHON_VER%%.egg-info/PKG-INFO
%%SMB%%%%PYTHON_SITELIBDIR%%/SSSDConfig-1.16.5-py%%PYTHON_VER%%.egg-info/SOURCES.txt
%%SMB%%%%PYTHON_SITELIBDIR%%/SSSDConfig-1.16.5-py%%PYTHON_VER%%.egg-info/dependency_links.txt
%%SMB%%%%PYTHON_SITELIBDIR%%/SSSDConfig-1.16.5-py%%PYTHON_VER%%.egg-info/top_level.txt
%%PYTHON_SITELIBDIR%%/SSSDConfig/__init__.py
%%PYTHON_SITELIBDIR%%/SSSDConfig/__pycache__/__init__.cpython-%%PYTHON_SUFFIX%%.pyc
%%PYTHON_SITELIBDIR%%/SSSDConfig/__pycache__/ipachangeconf.cpython-%%PYTHON_SUFFIX%%.pyc
......
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment