Skip to content
Snippets Groups Projects
Commit ae256a06 authored by Koichiro Iwao's avatar Koichiro Iwao
Browse files

net/tigervnc-{server,viewer,viewer-java}: Update to 1.13.0

Changes:	https://github.com/TigerVNC/tigervnc/releases/tag/v1.13.0
Sponsored by:	Miracle Linux
parent 7ad0eea3
Branches
Tags
No related merge requests found
PORTREVISION= 6
PKGNAMESUFFIX= -server
COMMENT= TigerVNC Server
WWW= https://tigervnc.org/
EXTRA_PATCHES= ${FILESDIR}/xorg-1.21.patch:-p1 \
${FILESDIR}/xvnc-adapt-xorg-1.21.patch:-p1
PATCH_DEPENDS+= ${NONEXISTENT}:x11-servers/xorg-server:patch
BUILD_DEPENDS+= ${LOCALBASE}/include/GL/internal/dri_interface.h:graphics/mesa-dri \
${LOCALBASE}/libdata/pkgconfig/fontutil.pc:x11-fonts/font-util \
......
PORTNAME= tigervnc
DISTVERSIONPREFIX= v
DISTVERSION= 1.12.0
DISTVERSION= 1.13.0
CATEGORIES= net x11-servers
MAINTAINER?= meta@FreeBSD.org
......
TIMESTAMP = 1637499866
SHA256 (TigerVNC-tigervnc-v1.12.0_GH0.tar.gz) = 9ff3f3948f2a4e8cc06ee598ee4b1096beb62094c13e0b1462bff78587bed789
SIZE (TigerVNC-tigervnc-v1.12.0_GH0.tar.gz) = 1561898
TIMESTAMP = 1675905528
SHA256 (TigerVNC-tigervnc-v1.13.0_GH0.tar.gz) = 770e272f5fcd265a7c518f9a38b3bece1cf91e0f4e5e8d01f095b5e58c6f9c40
SIZE (TigerVNC-tigervnc-v1.13.0_GH0.tar.gz) = 1986759
From 736b50d04e1ba965696cd15d456dc2b7fc123150 Mon Sep 17 00:00:00 2001
From: Joakim Tjernlund <joakim.tjernlund@infinera.com>
Date: Wed, 24 Nov 2021 21:09:36 +0100
Subject: [PATCH] xorg-version.h: Increase supported Xorg version to 1.21
---
unix/xserver/hw/vnc/xorg-version.h | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/unix/xserver/hw/vnc/xorg-version.h b/unix/xserver/hw/vnc/xorg-version.h
index 5df9f8d21..a0d44d926 100644
--- a/unix/xserver/hw/vnc/xorg-version.h
+++ b/unix/xserver/hw/vnc/xorg-version.h
@@ -33,8 +33,8 @@
#error "X.Org older than 1.16 is not supported"
#endif
-#if XORG_AT_LEAST(1, 21, 0)
-#error "X.Org newer than 1.20 is not supported"
+#if XORG_AT_LEAST(1, 22, 0)
+#error "X.Org newer than 1.21 is not supported"
#endif
#endif
diff -urpN xorg-server-1.20.0/configure.ac xorg-server-1.20.0/configure.ac
--- xorg-server-1.20.0/configure.ac 2018-05-10 09:32:34.000000000 -0700
+++ xorg-server-1.20.0/configure.ac 2018-06-13 19:04:47.536413626 -0700
@@ -74,6 +74,7 @@ dnl forcing an entire recompile.x
AC_CONFIG_HEADERS(include/version-config.h)
AM_PROG_AS
+AC_PROG_CXX
AC_PROG_LN_S
LT_PREREQ([2.2])
LT_INIT([disable-static win32-dll])
@@ -1777,6 +1778,10 @@ if test "x$XVFB" = xyes; then
AC_SUBST([XVFB_SYS_LIBS])
fi
+dnl Xvnc DDX
+AC_SUBST([XVNC_CPPFLAGS], ["-DHAVE_DIX_CONFIG_H $XSERVER_CFLAGS"])
+AC_SUBST([XVNC_LIBS], ["$FB_LIB $FIXES_LIB $XEXT_LIB $CONFIG_LIB $DBE_LIB $RECORD_LIB $GLX_LIBS $RANDR_LIB $RENDER_LIB $DAMAGE_LIB $DRI3_LIB $PRESENT_LIB $MIEXT_SYNC_LIB $MIEXT_DAMAGE_LIB $MIEXT_SHADOW_LIB $XI_LIB $XKB_LIB $XKB_STUB_LIB $COMPOSITE_LIB $MAIN_LIB"])
+AC_SUBST([XVNC_SYS_LIBS], ["$GLX_SYS_LIBS"])
dnl Xnest DDX
@@ -1812,6 +1817,8 @@ if test "x$XORG" = xauto; then
fi
AC_MSG_RESULT([$XORG])
+AC_DEFINE_UNQUOTED(XORG_VERSION_CURRENT, [$VENDOR_RELEASE], [Current Xorg version])
+
if test "x$XORG" = xyes; then
XORG_DDXINCS='-I$(top_srcdir)/hw/xfree86 -I$(top_srcdir)/hw/xfree86/include -I$(top_srcdir)/hw/xfree86/common'
XORG_OSINCS='-I$(top_srcdir)/hw/xfree86/os-support -I$(top_srcdir)/hw/xfree86/os-support/bus -I$(top_srcdir)/os'
@@ -2029,7 +2036,6 @@ if test "x$XORG" = xyes; then
AC_DEFINE(XORG_SERVER, 1, [Building Xorg server])
AC_DEFINE(XORGSERVER, 1, [Building Xorg server])
AC_DEFINE(XFree86Server, 1, [Building XFree86 server])
- AC_DEFINE_UNQUOTED(XORG_VERSION_CURRENT, [$VENDOR_RELEASE], [Current Xorg version])
AC_DEFINE(NEED_XF86_TYPES, 1, [Need XFree86 typedefs])
AC_DEFINE(NEED_XF86_PROTOTYPES, 1, [Need XFree86 helper functions])
AC_DEFINE(__XSERVERNAME__, "Xorg", [Name of X server])
@@ -2565,6 +2571,7 @@ hw/dmx/Makefile
hw/dmx/man/Makefile
hw/vfb/Makefile
hw/vfb/man/Makefile
+hw/vnc/Makefile
hw/xnest/Makefile
hw/xnest/man/Makefile
hw/xwin/Makefile
diff -urpN xorg-server-1.20.0/hw/Makefile.am xorg-server-1.20.0/hw/Makefile.am
--- xorg-server-1.20.0/hw/Makefile.am 2018-05-10 09:32:34.000000000 -0700
+++ xorg-server-1.20.0/hw/Makefile.am 2018-06-13 19:04:47.536413626 -0700
@@ -44,3 +44,5 @@
relink:
$(AM_V_at)for i in $(SUBDIRS) ; do $(MAKE) -C $$i relink || exit 1 ; done
+
+SUBDIRS += vnc
diff -urpN xorg-server-1.20.0/mi/miinitext.c xorg-server-1.20.0/mi/miinitext.c
--- xorg-server-1.20.0/mi/miinitext.c 2018-05-10 09:32:37.000000000 -0700
+++ xorg-server-1.20.0/mi/miinitext.c 2018-06-13 19:05:14.742200675 -0700
@@ -107,8 +107,15 @@ SOFTWARE.
#include "os.h"
#include "globals.h"
+#ifdef TIGERVNC
+extern void vncExtensionInit(void);
+#endif
+
/* List of built-in (statically linked) extensions */
static const ExtensionModule staticExtensions[] = {
+#ifdef TIGERVNC
+ {vncExtensionInit, "VNC-EXTENSION", NULL},
+#endif
{GEExtensionInit, "Generic Event Extension", &noGEExtension},
{ShapeExtensionInit, "SHAPE", NULL},
#ifdef MITSHM
From f2577107f7f55382c524d8c738a777e5cdd80f60 Mon Sep 17 00:00:00 2001
From: Joakim Tjernlund <joakim.tjernlund@infinera.com>
Date: Wed, 24 Nov 2021 21:10:56 +0100
Subject: [PATCH] xvnc: adapt for 1.21
VENDOR_STRING is gone as is DEFAULT_LOG_VERBOSITY
site.h has been removed and is not needed.
---
unix/xserver/hw/vnc/xvnc.c | 6 ++----
1 file changed, 2 insertions(+), 4 deletions(-)
diff --git a/unix/xserver/hw/vnc/xvnc.c b/unix/xserver/hw/vnc/xvnc.c
index a655239fd..3bc77b2cf 100644
--- a/unix/xserver/hw/vnc/xvnc.c
+++ b/unix/xserver/hw/vnc/xvnc.c
@@ -69,7 +69,6 @@ extern char buildtime[];
#undef VENDOR_RELEASE
#undef VENDOR_STRING
#include "version-config.h"
-#include "site.h"
#define XVNCVERSION "TigerVNC 1.12.80"
#define XVNCCOPYRIGHT ("Copyright (C) 1999-2021 TigerVNC Team and many others (see README.rst)\n" \
@@ -111,14 +110,13 @@ static Bool Render = TRUE;
static Bool displaySpecified = FALSE;
static char displayNumStr[16];
-static int vncVerbose = DEFAULT_LOG_VERBOSITY;
+static int vncVerbose = 0;
static void
vncPrintBanner(void)
{
ErrorF("\nXvnc %s - built %s\n%s", XVNCVERSION, buildtime, XVNCCOPYRIGHT);
- ErrorF("Underlying X server release %d, %s\n\n", VENDOR_RELEASE,
- VENDOR_STRING);
+ ErrorF("Underlying X server release %d\n\n", VENDOR_RELEASE);
}
static void
......@@ -9,7 +9,9 @@ USE_XORG+= ice pixman sm x11 xcursor xext xfixes xft xi xinerama xrender xrandr
LIB_DEPENDS+= libfontconfig.so:x11-fonts/fontconfig \
libpng.so:graphics/png \
libfltk.so:x11-toolkits/fltk
libfltk.so:x11-toolkits/fltk \
libnettle.so:security/nettle \
libgmp.so:math/gmp
OPTIONS_DEFINE= DOCS GNUTLS NLS
OPTIONS_DEFAULT= GNUTLS
......
......@@ -5,7 +5,10 @@ share/icons/hicolor/22x22/apps/tigervnc.png
share/icons/hicolor/24x24/apps/tigervnc.png
share/icons/hicolor/32x32/apps/tigervnc.png
share/icons/hicolor/48x48/apps/tigervnc.png
share/icons/hicolor/64x64/apps/tigervnc.png
share/icons/hicolor/128x128/apps/tigervnc.png
share/icons/hicolor/scalable/apps/tigervnc.svg
share/metainfo/org.tigervnc.vncviewer.metainfo.xml
%%NLS%%share/locale/bg/LC_MESSAGES/tigervnc.mo
%%NLS%%share/locale/cs/LC_MESSAGES/tigervnc.mo
%%NLS%%share/locale/da/LC_MESSAGES/tigervnc.mo
......@@ -20,10 +23,12 @@ share/icons/hicolor/scalable/apps/tigervnc.svg
%%NLS%%share/locale/hu/LC_MESSAGES/tigervnc.mo
%%NLS%%share/locale/id/LC_MESSAGES/tigervnc.mo
%%NLS%%share/locale/it/LC_MESSAGES/tigervnc.mo
%%NLS%%share/locale/ka/LC_MESSAGES/tigervnc.mo
%%NLS%%share/locale/ko/LC_MESSAGES/tigervnc.mo
%%NLS%%share/locale/nl/LC_MESSAGES/tigervnc.mo
%%NLS%%share/locale/pl/LC_MESSAGES/tigervnc.mo
%%NLS%%share/locale/pt_BR/LC_MESSAGES/tigervnc.mo
%%NLS%%share/locale/ro/LC_MESSAGES/tigervnc.mo
%%NLS%%share/locale/ru/LC_MESSAGES/tigervnc.mo
%%NLS%%share/locale/sk/LC_MESSAGES/tigervnc.mo
%%NLS%%share/locale/sr/LC_MESSAGES/tigervnc.mo
......
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Please register or to comment