Skip to content
Snippets Groups Projects
Commit ad96d988 authored by Kai Knoblich's avatar Kai Knoblich
Browse files

textproc/py-pymdown-extensions: Update to 9.9.2

* Switch to PEP517 build framework and remove no longer required
  setuptools workaround.

Changelog since 9.9:

https://github.com/facelessuser/pymdown-extensions/compare/9.9...9.9.2

MFH:		No (PEP517 support not present in 2023Q1 branch)
parent aa25e5ba
No related branches found
No related tags found
No related merge requests found
PORTNAME= pymdown-extensions
DISTVERSION= 9.9
DISTVERSION= 9.9.2
CATEGORIES= textproc python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
......@@ -12,18 +12,12 @@ WWW= https://github.com/facelessuser/pymdown-extensions
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE.md
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}hatchling>=0.21.1:devel/py-hatchling@${PY_FLAVOR}
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}markdown>=3.2:textproc/py-markdown@${PY_FLAVOR}
USES= python:3.7+
USE_PYTHON= autoplist distutils
USE_PYTHON= autoplist pep517
NO_ARCH= yes
# Avoid that pyproject.toml is read during setup otherwise build fails
post-extract:
@${MV} ${WRKSRC}/pyproject.toml ${WRKSRC}/pyproject.toml.dist
post-patch:
@${REINPLACE_CMD} -e 's/%%DISTVERSION%%/${DISTVERSION}/' ${WRKSRC}/setup.py
.include <bsd.port.mk>
TIMESTAMP = 1671528940
SHA256 (pymdown_extensions-9.9.tar.gz) = 0f8fb7b74a37a61cc34e90b2c91865458b713ec774894ffad64353a5fce85cfc
SIZE (pymdown_extensions-9.9.tar.gz) = 743948
TIMESTAMP = 1677140141
SHA256 (pymdown_extensions-9.9.2.tar.gz) = ebb33069bafcb64d5f5988043331d4ea4929325dc678a6bcf247ddfcf96499f8
SIZE (pymdown_extensions-9.9.2.tar.gz) = 744017
Generated via adding
[tool.hatch.build.targets.sdist]
support-legacy = true
to setup.py and then run "hatchling build".
--- setup.py.orig 2022-11-19 11:48:49 UTC
+++ setup.py
@@ -0,0 +1,32 @@
+# -*- coding: utf-8 -*-
+from setuptools import setup
+
+setup(
+ name='pymdown-extensions',
+ version='%%DISTVERSION%%',
+ description='Extension pack for Python Markdown.',
+ long_description='',
+ author_email='Isaac Muse <Isaac.Muse@gmail.com>',
+ classifiers=[
+ 'Development Status :: 5 - Production/Stable',
+ 'Environment :: Console',
+ 'Intended Audience :: Developers',
+ 'License :: OSI Approved :: MIT License',
+ 'Operating System :: OS Independent',
+ 'Programming Language :: Python :: 3',
+ 'Programming Language :: Python :: 3.7',
+ 'Programming Language :: Python :: 3.8',
+ 'Programming Language :: Python :: 3.9',
+ 'Programming Language :: Python :: 3.10',
+ 'Topic :: Internet :: WWW/HTTP :: Dynamic Content',
+ 'Topic :: Software Development :: Libraries :: Python Modules',
+ 'Topic :: Text Processing :: Filters',
+ 'Topic :: Text Processing :: Markup :: HTML',
+ ],
+ install_requires=[
+ 'markdown>=3.2',
+ ],
+ packages=[
+ 'pymdownx',
+ ],
+)
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment