Skip to content
Snippets Groups Projects
Commit ab3e7c2c authored by Dave Cottlehuber's avatar Dave Cottlehuber
Browse files

databases/foundationdb-devel: update to 7.0.0

Sponsored by:	SkunkWerks, GmbH
parent 9f9424d3
Branches
Tags
No related merge requests found
PORTNAME= foundationdb-devel
DISTVERSION= 7.0.0.a.20211125
DISTVERSION= 7.0.0
CATEGORIES= databases
# PATCH_SITES= https://github.com/${GH_ACCOUNT}/${GH_PROJECT}/pull/
......@@ -26,14 +26,15 @@ USES= cmake compiler:c++17-lang mono:build python:build shebangfix \
USE_GITHUB= yes
GH_ACCOUNT= apple
GH_PROJECT= foundationdb
GH_TAGNAME= 09fedc4
USE_LDCONFIG= yes
USE_RC_SUBR= foundationdb
SHEBANG_FILES= bindings/c/generate_asm.py
CMAKE_ARGS= -DOPENSSL_ROOT_DIR=${OPENSSLLIB}
CMAKE_OFF= DISABLE_TLS USE_DTRACE USE_JEMALLOC
CMAKE_OFF= DISABLE_TLS USE_DTRACE USE_JEMALLOC WITH_CONTRIB WITH_FLOWBENCH
MAKE_ENV= MONO_REGISTRY_PATH=/tmp/registry
USERS= foundationdb
GROUPS= foundationdb
......@@ -53,17 +54,15 @@ post-patch:
do-install:
# commands on first line, dev tools on next two
.for f in fdbbackup fdbcli fdbmonitor fdbserver \
actor_flamegraph fdb_c_performance_test fdb_c_ryw_benchmark \
fdb_c_txn_size_test fdb_flow_tester fdbconvert fdbdecode mako tutorial
actor_flamegraph fdb_flow_tester fdbconvert fdbdecode tutorial
${INSTALL_PROGRAM} ${WRKDIR}/.build/bin/${f} ${STAGEDIR}${PREFIX}/bin/
.endfor
# confirm with upstream if these are actually needed
.for s in backup_agent dr_agent fastrestore_agent fdbr fdbrestore
${RLN} ${STAGEDIR}${PREFIX}/bin/fdbbackup ${STAGEDIR}${PREFIX}/bin/${s}
.endfor
# exposed libraries - confirm with upstream
.for l in libfdb_c.so libfdb_flow.a libfdb_sqlite.a libfdbclient.a \
libfdbrpc.a libflow.a
.for l in libfdb_c.so libfdb_flow.a libfdb_sqlite.a libfdbclient.a libfdbrpc.a \
libflow.a
${STRIP_CMD} ${WRKDIR}/.build/lib/${l}
${INSTALL_DATA} ${WRKDIR}/.build/lib/${l} ${STAGEDIR}/${PREFIX}/lib/
.endfor
......
TIMESTAMP = 1638100203
SHA256 (apple-foundationdb-7.0.0.a.20211125-09fedc4_GH0.tar.gz) = 645e7913a13a8e9a2bd08dea6521a4437ab1a305feb48d26d3d2fa19852c2a9c
SIZE (apple-foundationdb-7.0.0.a.20211125-09fedc4_GH0.tar.gz) = 11293576
TIMESTAMP = 1640764452
SHA256 (apple-foundationdb-7.0.0_GH0.tar.gz) = 9a5ef672e32b6976b04a20c013b28c4aeeb7d35456afdefbc552707d52bc31ca
SIZE (apple-foundationdb-7.0.0_GH0.tar.gz) = 10875992
--- CMakeLists.txt.orig 2021-11-25 00:33:05 UTC
--- CMakeLists.txt.orig 2021-12-29 09:04:08 UTC
+++ CMakeLists.txt
@@ -171,7 +171,9 @@ else()
@@ -172,9 +172,13 @@ else()
add_subdirectory(fdbservice)
endif()
add_subdirectory(fdbbackup)
-add_subdirectory(contrib)
+if(WITH_CONTRIB)
+ add_subdirectory(contrib)
+endif()
add_subdirectory(tests)
-add_subdirectory(flowbench EXCLUDE_FROM_ALL)
+if(WITH_FLOWBENCH)
add_subdirectory(flowbench EXCLUDE_FROM_ALL)
+ add_subdirectory(flowbench EXCLUDE_FROM_ALL)
+endif()
if(WITH_PYTHON AND WITH_C_BINDING)
add_subdirectory(bindings)
......
--- bindings/c/CMakeLists.txt.orig 2021-11-25 00:33:05 UTC
--- bindings/c/CMakeLists.txt.orig 2021-12-29 13:15:46 UTC
+++ bindings/c/CMakeLists.txt
@@ -77,7 +77,7 @@ endif()
# The tests don't build on windows and ARM macs
# doctest doesn't seem to compile on ARM macs, we should
# check later whether this works
-if(NOT WIN32 AND NOT IS_ARM_MAC)
+if(NOT WIN32 AND NOT IS_ARM_MAC AND NOT CMAKE_SYSTEM_NAME MATCHES "FreeBSD")
@@ -65,7 +65,7 @@ if(WIN32)
endif()
# The tests don't build on windows
-if(NOT WIN32)
+if(NOT WIN32 AND NOT CMAKE_SYSTEM_NAME STREQUAL "FreeBSD")
set(MAKO_SRCS
test/mako/mako.c
test/mako/mako.h
--- bindings/c/test/unit/third_party/CMakeLists.txt.orig 2021-01-04 00:07:51 UTC
--- bindings/c/test/unit/third_party/CMakeLists.txt.orig 2021-12-07 03:03:34 UTC
+++ bindings/c/test/unit/third_party/CMakeLists.txt
@@ -1,18 +1 @@
-# Download doctest repo.
......
--- cmake/FDBComponents.cmake.orig 2021-12-07 03:03:34 UTC
+++ cmake/FDBComponents.cmake
@@ -24,7 +24,7 @@ set(DISABLE_TLS OFF CACHE BOOL "Don't try to find Open
if(DISABLE_TLS)
set(WITH_TLS OFF)
else()
- set(OPENSSL_USE_STATIC_LIBS TRUE)
+ set(OPENSSL_USE_STATIC_LIBS FALSE)
find_package(OpenSSL)
if(OPENSSL_FOUND)
set(CMAKE_REQUIRED_INCLUDES ${OPENSSL_INCLUDE_DIR})
@@ -203,6 +203,13 @@ else()
endif()
################################################################################
+# misc optional components
+################################################################################
+
+set(WITH_CONTRIB ON)
+set(WITH_FLOWBENCH OFF)
+
+################################################################################
# Coroutine implementation
################################################################################
@@ -236,6 +243,8 @@ function(print_components)
message(STATUS "Build Documentation (make html): ${WITH_DOCUMENTATION}")
message(STATUS "Build Python sdist (make package): ${WITH_PYTHON_BINDING}")
message(STATUS "Configure CTest (depends on Python): ${WITH_PYTHON}")
+ message(STATUS "Build contrib: ${WITH_CONTRIB}")
+ message(STATUS "Build with FlowBench: ${WITH_FLOWBENCH}")
message(STATUS "Build with RocksDB: ${WITH_ROCKSDB_EXPERIMENTAL}")
message(STATUS "=========================================")
endfunction()
......@@ -4,17 +4,17 @@
bin/actor_flamegraph
bin/backup_agent
bin/dr_agent
bin/fdb_c_performance_test
bin/fdb_c_ryw_benchmark
bin/fdb_c_txn_size_test
bin/fastrestore_agent
bin/fdb_flow_tester
bin/fdbbackup
bin/fdbcli
bin/fdbconvert
bin/fdbdecode
bin/fdbmonitor
bin/fdbr
bin/fdbrestore
bin/fdbserver
bin/mako
bin/tutorial
include/foundationdb/fdb.options
include/foundationdb/fdb_c.h
include/foundationdb/fdb_c_options.g.h
......
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Please register or to comment