Skip to content
Snippets Groups Projects
Unverified Commit a5aabfcb authored by Robert Clausecker's avatar Robert Clausecker Committed by Li-Wen Hsu
Browse files

security/hyperhotp: update to 0.1

Upstream changes:

 - add man page
 - integrate FreeBSD patches
 - improve usability

PR:		267275
parent d5c6e741
No related branches found
No related tags found
No related merge requests found
Showing with 7 additions and 113 deletions
PORTNAME= hyperhotp
DISTVERSION= g20211005
DISTVERSIONPREFIX= v
DISTVERSION= 0.1
CATEGORIES= security comms
MAINTAINER= fuz@fuz.su
......@@ -11,9 +12,8 @@ LICENSE= GPLv3
USES= cmake pkgconfig
USE_GITHUB= yes
GH_ACCOUNT= casept
#GH_PROJECT= hyperhotp
GH_TAGNAME= ad1f71d0e4669e7b693ae0fd794186204b1941e8
PLIST_FILES= bin/hyperhotp
PLIST_FILES= bin/hyperhotp \
share/man/man1/hyperhotp.1.gz
.include <bsd.port.mk>
TIMESTAMP = 1666202596
SHA256 (casept-hyperhotp-g20211005-ad1f71d0e4669e7b693ae0fd794186204b1941e8_GH0.tar.gz) = 42f522de25252a78a92460651845aece35dfe6da827ce3bbd9a27c6f42d8fabd
SIZE (casept-hyperhotp-g20211005-ad1f71d0e4669e7b693ae0fd794186204b1941e8_GH0.tar.gz) = 29308
TIMESTAMP = 1666467446
SHA256 (casept-hyperhotp-v0.1_GH0.tar.gz) = 3787ec269d9cf85e882702872df9927d29e7c40699ebc0e96243b2c282ccbeda
SIZE (casept-hyperhotp-v0.1_GH0.tar.gz) = 30594
--- cmake/FindLibusb.cmake.orig 2022-10-19 18:04:24 UTC
+++ cmake/FindLibusb.cmake
@@ -12,14 +12,14 @@ mark_as_advanced(Libusb_VERSION)
# Find header path
find_path(
Libusb_INCLUDE_DIR
- NAMES libusb-1.0/libusb.h
+ NAMES libusb.h
HINTS ${PC_Libusb_INCLUDE_DIRS})
mark_as_advanced(Libusb_INCLUDE_DIR)
# Find lib path
find_library(
Libusb_LIBRARIES
- NAMES usb-1.0
+ NAMES usb
HINTS ${PC_Libusb_LIBRARY_DIRS})
mark_as_advanced(Libusb_LIBRARIES)
--- src/core/hyperhotp.c.orig 2021-10-05 10:43:22 UTC
+++ src/core/hyperhotp.c
@@ -1,6 +1,6 @@
#include "hyperhotp.h"
-#include <libusb-1.0/libusb.h>
+#include <libusb.h>
#include <stdbool.h>
#include <stdint.h>
#include <string.h>
--- src/core/hyperhotp.h.orig 2021-10-05 10:43:22 UTC
+++ src/core/hyperhotp.h
@@ -1,6 +1,6 @@
#pragma once
-#include <libusb-1.0/libusb.h>
+#include <libusb.h>
#include <stdbool.h>
#include "u2fhid.h"
--- src/core/log.c.orig 2021-10-05 10:43:22 UTC
+++ src/core/log.c
@@ -1,4 +1,4 @@
-#include <libusb-1.0/libusb.h>
+#include <libusb.h>
#include <memory.h>
#include <stdbool.h>
#include <stdint.h>
--- src/core/log.h.orig 2021-10-05 10:43:22 UTC
+++ src/core/log.h
@@ -1,6 +1,6 @@
#pragma once
-#include <libusb-1.0/libusb.h>
+#include <libusb.h>
#include <stddef.h>
void log_fatal(const char* msg);
--- src/core/u2fhid.c.orig 2021-10-05 10:43:22 UTC
+++ src/core/u2fhid.c
@@ -1,6 +1,6 @@
#include "u2fhid.h"
-#include <libusb-1.0/libusb.h>
+#include <libusb.h>
#include <stdbool.h>
#include <stdio.h>
#include <string.h>
--- src/core/u2fhid.h.orig 2021-10-05 10:43:22 UTC
+++ src/core/u2fhid.h
@@ -1,6 +1,6 @@
#pragma once
-#include <libusb-1.0/libusb.h>
+#include <libusb.h>
#include <stdbool.h>
#include <stdint.h>
--- src/core/usb.c.orig 2021-10-05 10:43:22 UTC
+++ src/core/usb.c
@@ -1,6 +1,6 @@
#include "usb.h"
-#include <libusb-1.0/libusb.h>
+#include <libusb.h>
#include <stdbool.h>
#include <stdio.h>
#include <stdlib.h>
--- src/core/usb.h.orig 2021-10-05 10:43:22 UTC
+++ src/core/usb.h
@@ -1,6 +1,6 @@
#pragma once
-#include <libusb-1.0/libusb.h>
+#include <libusb.h>
/*
* Initialize the hyperFIDO usb device's libusb handle.
--- src/gui/main.c.orig 2021-10-05 10:43:22 UTC
+++ src/gui/main.c
@@ -1,5 +1,5 @@
#include <gtk/gtk.h>
-#include <libusb-1.0/libusb.h>
+#include <libusb.h>
#include <pthread.h>
#include <stdio.h>
#include <stdlib.h>
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Please register or to comment