Skip to content
Snippets Groups Projects
Verified Commit a3c6016f authored by Lewis Cook's avatar Lewis Cook
Browse files

misc/xplr: Unbreak build on FreeBSD 11-{i386,amd64}

getentropy(3) did not appear until FreeBSD 12, anything lower will
not compile, throwing an undefined reference to `getentropy'.  We can
safely remove this once FreeBSD 11 is EOL.

Reported-by:	pkg-fallout
parent c391e5fd
No related branches found
No related tags found
No related merge requests found
PORTNAME= xplr PORTNAME= xplr
DISTVERSIONPREFIX= v DISTVERSIONPREFIX= v
DISTVERSION= 0.14.3 DISTVERSION= 0.14.3
PORTREVISION= 2 PORTREVISION= 3
CATEGORIES= misc CATEGORIES= misc
MAINTAINER= lcook@FreeBSD.org MAINTAINER= lcook@FreeBSD.org
...@@ -177,4 +177,13 @@ post-install-EXAMPLES-on: ...@@ -177,4 +177,13 @@ post-install-EXAMPLES-on:
${INSTALL_DATA} ${_EXAMPLES} \ ${INSTALL_DATA} ${_EXAMPLES} \
${STAGEDIR}${EXAMPLESDIR} ${STAGEDIR}${EXAMPLESDIR}
.include <bsd.port.mk> .include <bsd.port.pre.mk>
# XXX: getentropy(3) did not appear until FreeBSD 12, anything lower will
# not compile, throwing an undefined reference to `getentropy'. We can
# safely remove this once FreeBSD 11 is EOL.
.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1200000
EXTRA_PATCHES= ${PATCHDIR}/extra-cargo-crates_luajit-src-210.1.3+restyfe08842_luajit2_src_lj__prng.c
.endif
.include <bsd.port.post.mk>
--- cargo-crates/luajit-src-210.1.3+restyfe08842/luajit2/src/lj_prng.c.orig 2021-07-11 17:23:58 UTC
+++ cargo-crates/luajit-src-210.1.3+restyfe08842/luajit2/src/lj_prng.c
@@ -116,7 +116,7 @@ static PRGR libfunc_rgr;
#define LJ_TARGET_HAS_GETENTROPY 1
#endif
#elif LJ_TARGET_BSD || LJ_TARGET_SOLARIS || LJ_TARGET_CYGWIN
-#define LJ_TARGET_HAS_GETENTROPY 1
+#define LJ_TARGET_HAS_GETENTROPY 0
#endif
#if LJ_TARGET_HAS_GETENTROPY
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment