Skip to content
Snippets Groups Projects
Commit 9f53b598 authored by Ralf Gebhart's avatar Ralf Gebhart Committed by Renato Botelho
Browse files

www/mod_umask: Fix build on FreeBSD 14+

PR:		275429
(cherry picked from commit fc1d174e)
parent 0636425b
No related branches found
No related tags found
No related merge requests found
......@@ -11,13 +11,12 @@ WWW= http://www.outoforder.cc/projects/httpd/mod_umask/
LICENSE= APACHE20
BROKEN_FreeBSD_14= fails to build: incompatible function pointer types
USES= apache tar:bzip2
GNU_CONFIGURE= yes
AP_FAST_BUILD= yes
AP_GENPLIST= yes
SRC_FILE= src/${PORTNAME}.c
GNU_CONFIGURE= yes
.include <bsd.port.mk>
--- src/mod_umask.c.orig 2004-10-12 19:03:16 UTC
+++ src/mod_umask.c
@@ -26,6 +26,7 @@
*
*/
+#include <sys/stat.h>
#include "httpd.h"
#include "http_core.h"
#include "http_config.h"
@@ -42,7 +43,7 @@ struct umask_config_rec
long int mask;
};
-static void *umask_create_config(apr_pool_t * p, char *dir)
+static void *umask_create_config(apr_pool_t * p, server_rec *dir)
{
umask_config_rec *dConfig = apr_pcalloc(p, sizeof(*dConfig));
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment