Skip to content
Snippets Groups Projects
Verified Commit 9b77fbd3 authored by Dima Panov's avatar Dima Panov
Browse files

graphics/luminance-qt5: unbreak build with boost-1.85

With hat:	office
Sponsored by:	Future Crew, LLC
parent 982a0d90
No related branches found
No related tags found
No related merge requests found
PORTNAME= luminance-hdr
DISTVERSION= 2.6.1.1
PORTREVISION= 26
PORTREVISION= 27
CATEGORIES= graphics
MASTER_SITES= SF/qtpfsgui/luminance/${DISTVERSION}
......@@ -24,11 +24,14 @@ LIB_DEPENDS= libImath.so:math/Imath \
CFLAGS+= -I${LOCALBASE}/include/Imath
USES= cmake desktop-file-utils eigen:3 jpeg pkgconfig qt:5 tar:bzip2
USES= cmake compiler:c++14-lang desktop-file-utils \
eigen:3 jpeg pkgconfig qt:5 tar:bzip2
USE_QT= concurrent core declarative gui location network \
printsupport sql svg widgets xml \
buildtools:build linguisttools:build qmake:build
USE_CXXSTD= c++14
OPTIONS_DEFINE= CFITSIO DOCS HELPBROWSER
OPTIONS_DEFAULT= CFITSIO
OPTIONS_DEFAULT_aarch64= HELPBROWSER
......
--- CMakeLists.txt.orig 2021-01-11 09:41:28 UTC
+++ CMakeLists.txt
@@ -64,6 +64,7 @@ find_package(Qt5Core REQUIRED)
@@ -64,6 +64,7 @@ find_package(Qt5Gui REQUIRED)
find_package(Qt5Concurrent REQUIRED)
find_package(Qt5Widgets REQUIRED)
find_package(Qt5Gui REQUIRED)
......@@ -8,12 +8,39 @@
# QtWebEngine is preferred web engine because QtWebKit is deprecated since Qt 5.5:
# https://wiki.qt.io/New-Features-in-Qt-5.5#Deprecated_Functionality. Unfortunately,
# some Qt distributions still provide QtWebKit instead of QtWebEngine. So first we
@@ -75,6 +76,8 @@ else()
find_package(Qt5WebKit REQUIRED)
@@ -76,6 +77,8 @@ endif()
find_package(Qt5WebKitWidgets REQUIRED)
add_definitions(-DUSE_DEPRECATED_QTWEBKIT)
+endif()
+ add_definitions(-DWITH_HELPBROWSER)
endif()
+ add_definitions(-DWITH_HELPBROWSER)
+endif()
find_package(Qt5Xml REQUIRED)
find_package(Qt5Sql REQUIRED)
find_package(Qt5Svg REQUIRED)
@@ -345,7 +348,6 @@ IF(APPLE)
FILE(COPY
${CMAKE_SOURCE_DIR}/AUTHORS
${CMAKE_SOURCE_DIR}/README.md
- ${CMAKE_SOURCE_DIR}/LICENSE
${CMAKE_SOURCE_DIR}/Changelog
DESTINATION ${LHDR_OSX_EXECUTABLE_NAME}.app/Contents
)
@@ -416,9 +418,8 @@ ELSEIF(UNIX)
INSTALL(FILES
${CMAKE_SOURCE_DIR}/AUTHORS
${CMAKE_SOURCE_DIR}/README.md
- ${CMAKE_SOURCE_DIR}/LICENSE
${CMAKE_SOURCE_DIR}/Changelog
- DESTINATION share/luminance-hdr/doc) #info files
+ DESTINATION share/doc/luminance-hdr) #info files
INSTALL(DIRECTORY ${CMAKE_SOURCE_DIR}/help DESTINATION share/luminance-hdr) # help directory
INSTALL(DIRECTORY ${CMAKE_SOURCE_DIR}/hdrhtml DESTINATION share/luminance-hdr) # hdrhtml directory
# Microsoft Windows
@@ -508,7 +509,6 @@ ELSEIF(WIN32)
INSTALL(FILES ${CMAKE_SOURCE_DIR}/program-icons/luminance-hdr.png DESTINATION ./icons/hicolor/48x48/apps) # icon
INSTALL(FILES ${CMAKE_SOURCE_DIR}/AUTHORS
${CMAKE_SOURCE_DIR}/README.md
- ${CMAKE_SOURCE_DIR}/LICENSE
${CMAKE_SOURCE_DIR}/Changelog
DESTINATION ./) #info files
INSTALL(DIRECTORY ${CMAKE_SOURCE_DIR}/icons DESTINATION ./) # icons directory
--- src/Common/init_fftw.h.orig 2021-01-11 09:41:28 UTC
+++ src/Common/init_fftw.h
@@ -22,7 +22,7 @@
#ifndef INIT_FFTW_H
#define INIT_FFTW_H
-#include <boost/thread/mutex.hpp>
+#include <mutex>
class FFTW_MUTEX {
public:
Include cstdio for stderr, to fix the build with gcc 4.9
--- src/Libpfs/manip/projection.cpp.orig 2015-10-29 16:26:58.000000000 +0100
+++ src/Libpfs/manip/projection.cpp 2015-10-29 16:27:41.000000000 +0100
@@ -26,6 +26,7 @@
--- src/Libpfs/manip/projection.cpp.orig 2021-01-11 09:41:28 UTC
+++ src/Libpfs/manip/projection.cpp
@@ -28,6 +28,7 @@
#include <cmath>
#include <cstring>
......
Fix build with boost 1.85.
--- src/Libpfs/manip/resize.hxx.orig 2024-05-30 18:37:03.836910306 +0000
+++ src/Libpfs/manip/resize.hxx
@@ -23,6 +23,7 @@
#define PFS_RESIZE_HXX
#include <boost/math/constants/constants.hpp>
+#include <boost/numeric/conversion/bounds.hpp>
#include "copy.h"
#include "resize.h"
#include "../../sleef.c"
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment