Skip to content
GitLab
Menu
Why GitLab
Pricing
Contact Sales
Explore
Why GitLab
Pricing
Contact Sales
Explore
Sign in
Get free trial
Primary navigation
Search or go to…
Project
F
FreeBSD ports
Manage
Activity
Members
Labels
Plan
Issues
Issue boards
Milestones
Wiki
Requirements
Code
Merge requests
Repository
Branches
Commits
Tags
Repository graph
Compare revisions
Snippets
Locked files
Build
Pipelines
Jobs
Pipeline schedules
Test cases
Artifacts
Deploy
Releases
Package registry
Container registry
Model registry
Operate
Environments
Terraform modules
Monitor
Incidents
Service Desk
Analyze
Value stream analytics
Contributor analytics
CI/CD analytics
Repository analytics
Code review analytics
Issue analytics
Insights
Model experiments
Help
Help
Support
GitLab documentation
Compare GitLab plans
Community forum
Contribute to GitLab
Provide feedback
Privacy statement
Keyboard shortcuts
?
What's new
6
Snippets
Groups
Projects
Show more breadcrumbs
FreeBSD
FreeBSD ports
Commits
9638af3b
Commit
9638af3b
authored
3 years ago
by
Mikael Urankar
Browse files
Options
Downloads
Patches
Plain Diff
security/hashcat: Fix build on aarch64
Same fix as archivers/7-zip Approved by: portmgr (build fix blanket)
parent
3d5c66e1
No related branches found
Branches containing commit
No related tags found
Tags containing commit
No related merge requests found
Changes
2
Hide whitespace changes
Inline
Side-by-side
Showing
2 changed files
security/hashcat/Makefile
+3
-2
3 additions, 2 deletions
security/hashcat/Makefile
security/hashcat/files/patch-deps_LZMA-SDK_C_CpuArch.c
+34
-0
34 additions, 0 deletions
security/hashcat/files/patch-deps_LZMA-SDK_C_CpuArch.c
with
37 additions
and
2 deletions
security/hashcat/Makefile
+
3
−
2
View file @
9638af3b
...
...
@@ -11,9 +11,8 @@ COMMENT= Advanced CPU-based password recovery utility
LICENSE
=
MIT
LICENSE_FILE
=
${
WRKSRC
}
/docs/license.txt
NOT_FOR_ARCHS
=
aarch64
powerpc powerpc64 powerpcspe sparc64
NOT_FOR_ARCHS
=
powerpc powerpc64 powerpcspe sparc64
NOT_FOR_ARCHS_REASON
=
fails to compile: compiling
for
big-endian architecture not supported
NOT_FOR_ARCHS_REASON_aarch64
=
fails to compile
BUILD_DEPENDS
=
minizip:archivers/minizip
...
...
@@ -40,6 +39,8 @@ BRAIN_DESC= Build Hashcat Brain
BRAIN_MAKE_ARGS_OFF
=
ENABLE_BRAIN
=
0
BRAIN_CFLAGS
=
-DWITH_BRAIN
-Ideps
/git/xxHash
CFLAGS_aarch64
+=
-march
=
armv8-a+crc+crypto
pre-install
:
${
STRIP_CMD
}
${
WRKSRC
}
/libhashcat.so.
${
PORTVERSION
}
${
STRIP_CMD
}
${
WRKSRC
}
/modules/
*
.so
...
...
This diff is collapsed.
Click to expand it.
security/hashcat/files/patch-deps_LZMA-SDK_C_CpuArch.c
0 → 100644
+
34
−
0
View file @
9638af3b
---
deps
/
LZMA
-
SDK
/
C
/
CpuArch
.
c
.
orig
2022
-
03
-
25
08
:
13
:
08
UTC
+++
deps
/
LZMA
-
SDK
/
C
/
CpuArch
.
c
@@
-
384
,
6
+
384
,
23
@@
BoolInt
CPU_IsSupported_AES
(
void
)
{
return
APPLE_CRYP
#include
<sys/auxv.h>
+
#
if
defined
(
__FreeBSD__
)
+
static
UInt64
get_hwcap
()
{
+
unsigned
long
hwcap
;
+
if
(
elf_aux_info
(
AT_HWCAP
,
&
hwcap
,
sizeof
(
unsigned
long
))
!=
0
)
{
+
return
(
0
);
+
}
+
return
hwcap
;
+
}
+
+
BoolInt
CPU_IsSupported_CRC32
(
void
)
{
return
get_hwcap
()
&
HWCAP_CRC32
;
}
+
BoolInt
CPU_IsSupported_NEON
(
void
)
{
return
1
;
}
+
BoolInt
CPU_IsSupported_SHA1
(
void
){
return
get_hwcap
()
&
HWCAP_SHA1
;
}
+
BoolInt
CPU_IsSupported_SHA2
(
void
)
{
return
get_hwcap
()
&
HWCAP_SHA2
;
}
+
BoolInt
CPU_IsSupported_AES
(
void
)
{
return
get_hwcap
()
&
HWCAP_AES
;
}
+
+
#
else
// __FreeBSD__
+
#define USE_HWCAP
#ifdef USE_HWCAP
@@
-
410
,
6
+
427
,
7
@@
MY_HWCAP_CHECK_FUNC
(
SHA1
)
MY_HWCAP_CHECK_FUNC
(
SHA2
)
MY_HWCAP_CHECK_FUNC
(
AES
)
+
#
endif
// FreeBSD
#endif // __APPLE__
#endif // _WIN32
This diff is collapsed.
Click to expand it.
Preview
0%
Loading
Try again
or
attach a new file
.
Cancel
You are about to add
0
people
to the discussion. Proceed with caution.
Finish editing this message first!
Save comment
Cancel
Please
register
or
sign in
to comment