Skip to content
Snippets Groups Projects
Commit 95272789 authored by MANTANI Nobutaka's avatar MANTANI Nobutaka
Browse files

editors/imhex: Fix build with llvm15

parent 6b71ba2b
No related branches found
No related tags found
No related merge requests found
--- lib/external/pattern_language/lib/CMakeLists.txt.orig 2023-02-12 13:35:48 UTC
+++ lib/external/pattern_language/lib/CMakeLists.txt
@@ -34,7 +34,7 @@ add_library(libpl ${LIBRARY_TYPE}
source/pl/lib/std/hash.cpp
)
-target_compile_options(libpl PRIVATE -Wall -Wextra -Werror -Wpedantic -Wno-unknown-pragmas)
+target_compile_options(libpl PRIVATE -Wall -Wextra -Werror -Wpedantic -Wno-unknown-pragmas -Wno-error=deprecated-declarations)
target_include_directories(libpl PUBLIC include)
target_link_libraries(libpl PRIVATE fmt::fmt-header-only)
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment