Skip to content
Snippets Groups Projects
Commit 87cf7522 authored by Tiago Gasiba's avatar Tiago Gasiba Committed by Yuri Victorovich
Browse files

devel/asmx: update 1.8.2 → 2.0.0; take maintainership

PR:	259012
parent 0b031438
Branches
Tags
No related merge requests found
PORTNAME= asmx
PORTVERSION= 1.8.2
PORTREVISION= 2
PORTVERSION= 2.0.0
CATEGORIES= devel
MASTER_SITES= http://xi6.com/files/
MAINTAINER= ports@FreeBSD.org
MAINTAINER= tiago.gasiba@gmail.com
COMMENT= Multi-CPU macro assembler for many major 8-bit and 16-bit CPUs
WWW= http://xi6.com/projects/asmx/
LICENSE= PD
USES= zip
NO_WRKSUBDIR= yes
PORTDOCS= README.txt
OPTIONS_DEFINE= 1802 6502 6809 68HC11 68HC16 68000 8051 8085 F8 Z80 DOCS
OPTIONS_DEFAULT=1802 6502 6809 68HC11 68HC16 68000 8051 8085 F8 Z80
1802_DESC= RCA 1802
6502_DESC= MOS Technology 6502, 65C02 and 6502
6809_DESC= Motorola 6809
68HC11_DESC= Motorola 6800/6801/68HC11 and Hitachi 6303
68HC16_DESC= Motorola 68HC16
68000_DESC= Motorola 68000/68010
8051_DESC= Intel 8051
8085_DESC= Intel 8080 and 8085
F8_DESC= Fairchild F8
Z80_DESC= Zilog Z-80 and Nintendo Gameboy Z-80 variant
1802_ALL_TARGET= asmx-1802
1802_PLIST_FILES= bin/asmx-1802
6502_ALL_TARGET= asmx-6502
6502_PLIST_FILES= bin/asmx-6502
6809_ALL_TARGET= asmx-6809
6809_PLIST_FILES= bin/asmx-6809
68HC11_ALL_TARGET= asmx-68hc11
68HC11_PLIST_FILES= bin/asmx-68hc11
68HC16_ALL_TARGET= asmx-68hc16
68HC16_PLIST_FILES= bin/asmx-68hc16
68000_ALL_TARGET= asmx-68k
68000_PLIST_FILES= bin/asmx-68k
8051_ALL_TARGET= asmx-8051
8051_PLIST_FILES= bin/asmx-8051
8085_ALL_TARGET= asmx-8085
8085_PLIST_FILES= bin/asmx-8085
F8_ALL_TARGET= asmx-f8
F8_PLIST_FILES= bin/asmx-f8
Z80_ALL_TARGET= asmx-z80
Z80_PLIST_FILES= bin/asmx-z80
.include <bsd.port.options.mk>
post-patch:
@${ECHO_CMD} >> ${WRKSRC}/asmguts.h
do-build:
.for f in ${ALL_TARGET}
(cd ${BUILD_WRKSRC} && ${CC} ${CFLAGS} ${f:S/asmx-/asm/}.c -o ${f})
.endfor
cd ${BUILD_WRKSRC}/src && ${CC} ${CFLAGS} *.c -o asmx
do-install:
.for f in ${ALL_TARGET}
${INSTALL_PROGRAM} ${WRKSRC}/${f} ${STAGEDIR}${PREFIX}/bin
.endfor
do-install-DOCS-on:
${INSTALL_PROGRAM} ${WRKSRC}/src/asmx ${STAGEDIR}${PREFIX}/bin
${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/asmx
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README.txt ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/asmx-doc.html ${STAGEDIR}${DOCSDIR}
do-test:
@cd ${BUILD_WRKSRC}/test && ${SHELL} testit
.include <bsd.port.mk>
SHA256 (asmx-1.8.2.zip) = 16bc2fb7580664d76d0b6ed7cefc46cc406c059f4667fac4c62e3a976e57222b
SIZE (asmx-1.8.2.zip) = 106964
TIMESTAMP = 1742866101
SHA256 (asmx-2.0.0.zip) = b8e119faaeb8556cb6b71bea38c19cb6e9a7531f492620d03b84c2cdc0e6473f
SIZE (asmx-2.0.0.zip) = 346087
--- src/asm6805.c.orig 2025-03-25 02:16:34 UTC
+++ src/asm6805.c
@@ -180,7 +180,7 @@ static int M6805_DoCPUOpcode(int typ, int parm)
char *oldLine;
int token;
char force;
- char reg;
+ signed char reg;
switch (typ) {
case o_Inh08: // 68HCS08 inherent instructions
--- src/asm68hc16.c.orig 2025-03-25 02:17:39 UTC
+++ src/asm68hc16.c
@@ -345,7 +345,7 @@ static int M68HC16_DoCPUOpcode(int typ, int parm)
char *oldLine;
int token;
// char force;
- char reg;
+ signed char reg;
bool known;
switch (typ) {
--- test/testit.orig 2025-03-25 02:20:05 UTC
+++ test/testit
@@ -1,8 +1,8 @@
-#!/bin/bash
+#!/bin/sh
# this tests the various assemblers' instruction lists by
# comparing with pre-assembled .hex files in the ref sub-directory
-function testit()
+testit()
{
echo -n "Testing $1:"
@@ -37,17 +37,17 @@ testit 68hcs08
testit 68hc11
testit 68hc16
testit 68hcs08
-#testit 68k # already tested by 68000 / 68010
+testit 68k # already tested by 68000 / 68010
testit 8048
testit 8051
-#testit 8085 # already tested by 8085u
+testit 8085 # already tested by 8085u
testit 8085u
testit 8008
-#testit arm
+testit arm
testit f8
testit gbz80
testit jerry
-#testit thumb
+testit thumb
testit tom
testit z80
testit z8
bin/asmx
%%DOCSDIR%%/asmx-doc.html
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Please register or to comment