Skip to content
Snippets Groups Projects
Commit 86b27ebb authored by Daniel Engberg's avatar Daniel Engberg
Browse files

net-p2p/mkbrr: New port: Commmand-line utility to create, modify and inspect torrent files

Supports features such as:

* Creating torrent files
* Inspecting torrent files
* Modifying torrent metadata
* Supports tracker-specific requirements automatically
* Batch mode
parent e9a5a355
No related branches found
No related tags found
No related merge requests found
......@@ -53,6 +53,7 @@
SUBDIR += lxmf
SUBDIR += microdc2
SUBDIR += minder
SUBDIR += mkbrr
SUBDIR += mktorrent
SUBDIR += mldonkey
SUBDIR += mldonkey-core
......
PORTNAME= mkbrr
DISTVERSIONPREFIX= v
DISTVERSION= 1.3.0
CATEGORIES= net-p2p
MAINTAINER= diizzy@FreeBSD.org
COMMENT= Commmand-line utility to create, modify and inspect torrent files written in Go
WWW= https://github.com/autobrr/mkbrr
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/LICENSE
USES= go:1.23,modules
CGO_ENABLED= 0
GO_MODULE= github.com/autobrr/${PORTNAME}
PLIST_FILES= bin/mkbrr
post-patch:
@${REINPLACE_CMD} -e 's|%%DISTVERSION%%|${DISTVERSION}|g' \
${PATCH_WRKSRC}/main.go
@${REINPLACE_CMD} -e 's|%%BUILDTIME%%|${CONFIGURE_TARGET}|g' \
${PATCH_WRKSRC}/main.go
${RM} ${PATCH_WRKSRC}/cmd/update.go
.include <bsd.port.mk>
TIMESTAMP = 1741382943
SHA256 (go/net-p2p_mkbrr/mkbrr-v1.3.0/v1.3.0.mod) = 7eb4252628e608712058fbed6f72cfa3a97fc6e8c5d7d3feb9efa8ec6d5d4676
SIZE (go/net-p2p_mkbrr/mkbrr-v1.3.0/v1.3.0.mod) = 2106
SHA256 (go/net-p2p_mkbrr/mkbrr-v1.3.0/v1.3.0.zip) = 426fd987d9f71b890d579d4d2a03b70d911b9e9a9e3ebc2824583a10012e13aa
SIZE (go/net-p2p_mkbrr/mkbrr-v1.3.0/v1.3.0.zip) = 73885
--- main.go.orig 2025-03-07 21:35:10 UTC
+++ main.go
@@ -7,8 +7,8 @@ var (
)
var (
- version = "dev"
- buildTime = "unknown"
+ version = "%%DISTVERSION%%"
+ buildTime = "%%BUILDTIME%%"
)
func main() {
Commmand-line utility to create, modify and inspect torrent files written in Go
A simple yet powerful tool for:
* Creating torrent files
* Inspecting torrent files
* Modifying torrent metadata
* Supports tracker-specific requirements automatically
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment